I have a script which calls two commands:

long_running_command | print_progress

The long_running_command prints progress but I'm unhappy with it. I'm using print_progress to make it nicer (namely, I print the progress in a single line).

The problem: Connection a pipe to stdout also activates a 4K buffer, so the nice print program gets nothing ... nothing ... nothing ... a whole lot ... :)

How can I disable the 4K buffer for the long_running_command (no, I do not have the source)?

  • 2
    So when you run long_running_command without piping you can see the progress updates properly, but when piping they get buffered?
    – second
    Commented Jun 16, 2009 at 10:58
  • 2
    Yes, that's exactly what happens. Commented Jun 16, 2009 at 11:50
  • 39
    The inability for a simple way of controlling buffering has been a problem for decades. For example, see: marc.info/?l=glibc-bug&m=98313957306297&w=4 which basicly says "I can't be arsed doing this and here's some clap-trap to justify my position"
    – Adrian Pronk
    Commented Oct 19, 2010 at 21:59
  • 2
    – Nakilon
    Commented Feb 9, 2015 at 9:08
  • 10
    It is actually stdio not the pipe that causes a delay while waiting for enough data. Pipes do have a capacity, but as soon as there is any data written to the pipe, it is immediately ready to read at the other end. Commented Dec 16, 2016 at 11:37

15 Answers 15


Another way to skin this cat is to use the stdbuf program, which is part of the GNU Coreutils (FreeBSD also has its own one).

stdbuf -i0 -o0 -e0 command

This turns off buffering completely for input, output and error. For some applications, line buffering may be more suitable for performance reasons:

stdbuf -oL -eL command

Note that it only works for stdio buffering (printf(), fputs()...) for dynamically linked applications, and only if that application doesn't otherwise adjust the buffering of its standard streams by itself, though that should cover most applications.

  • 9
    "unbuffer" needs to be installed in Ubuntu, which is inside the package: expect-dev which is 2MB...
    – lepe
    Commented Jun 27, 2013 at 6:21
  • 32
    @qdii stdbuf does not work with tee, because tee overwrites the defaults set by stdbuf. See the manual page of stdbuf.
    – ceving
    Commented Jun 30, 2014 at 11:51
  • 5
    @lepe Bizarrely, unbuffer has dependencies on x11 and tcl/tk, meaning it actually needs >80 MB if you're installing it on a server without them. Commented Aug 28, 2014 at 12:27
  • 16
    @qdii stdbuf uses LD_PRELOAD mechanism to insert its own dynamically loaded library libstdbuf.so. This means that it will not work with these kinds executables: with setuid or file capabilities set, statically linked, not using standard libc. In these cases it is better to use the solutions with unbuffer / script / socat. See also stdbuf with setuid/capabilities. Commented Oct 12, 2015 at 9:20
  • 3
    @jchook Yes, what was said in the accepted answer using unbuffer above also applies here: "for longer pipelines, you may have to unbuffer each command"
    – shaneb
    Commented Dec 4, 2018 at 15:18

You can use the unbuffer command (which comes as part of the expect package), e.g.

unbuffer long_running_command | print_progress

unbuffer connects to long_running_command via a pseudoterminal (pty), which makes the system treat it as an interactive process, therefore not using the 4-kiB buffering in the pipeline that is the likely cause of the delay.

For longer pipelines, you may have to unbuffer each command (except the final one), e.g.

unbuffer x | unbuffer -p y | z
  • 4
    In fact, the use of a pty to connect to interactive processes is true of expect in general.
    – cheduardo
    Commented Jun 17, 2009 at 7:58
  • 24
    When pipelining calls to unbuffer, you should use the -p argument so that unbuffer reads from stdin.
    – Chris Conway
    Commented Oct 6, 2009 at 20:18
  • 34
    Note: On debian systems, this is called expect_unbuffer and is in the expect-dev package, not the expect package
    – bdonlan
    Commented Jan 24, 2011 at 11:14
  • 5
    @bdonlan: At least on Ubuntu (debian-based), expect-dev provides both unbuffer and expect_unbuffer (the former is a symlink to the latter). The links are available since expect (2009).
    – jfs
    Commented Apr 11, 2013 at 13:00
  • 3
    unbuffer is in the main expect package on debian now (it's still a symlink to expect_unbuffer, which is also in the main expect package)
    – cas
    Commented Nov 4, 2015 at 23:50

For grep, sed and awk you can force output to be line buffered. You can use:

grep --line-buffered

Force output to be line buffered.  By default, output is line buffered when standard output is a terminal and block buffered other-wise.

sed -u

Make output line buffered.

See this page for more information: http://www.perkin.org.uk/posts/how-to-fix-stdio-buffering.html

  • 11
    Notably python also supports the -u parameter to disable buffering. Commented Dec 19, 2019 at 21:52
  • 1
    Using grep(etc.) like this won't work. By the time you've executed long_running_command it's too late. It'll be buffered before it even gets to grep. Commented Jan 24, 2020 at 15:26
  • This is still buffered. what if one wants to see the line progress...
    – Michael
    Commented Feb 3, 2020 at 18:48
  • Should this work with grep --line-buffered pattern *many*many*files* | head? It looks like grep processes all the files before feeding the output lines to head
    – golimar
    Commented Feb 28, 2020 at 11:27
  • And here I thought I was a grep power user.
    – BaseZen
    Commented Jan 2, 2021 at 3:31

Yet another way to turn on line-buffering output mode for the long_running_command is to use the script command that runs your long_running_command in a pseudo terminal (pty).

script -q /dev/null long_running_command | print_progress      # (FreeBSD, Mac OS X)
script -q -c "long_running_command" /dev/null | print_progress # (Linux)
  • 20
    +1 nice trick, since script is such an old command, it should be available on all Unix-like platforms. Commented Jan 20, 2013 at 13:01
  • 6
    you also need -q on Linux: script -q -c 'long_running_command' /dev/null | print_progress
    – jfs
    Commented Apr 11, 2013 at 12:51
  • 1
    It seems like script reads from stdin, which makes it impossible to run such a long_running_command in the background, at least when started from interactive terminal. To workaround, I was able to redirect stdin from /dev/null, since my long_running_command doesn't use stdin.
    – haridsv
    Commented Nov 15, 2013 at 12:44
  • 3
    One significant disadvantage: ctrl-z no longer works (i.e. I can't suspend the script). This can be fixed by, for example: echo | sudo script -c /usr/local/bin/ec2-snapshot-all /dev/null | ts , if you don't mind not being able to interact with the program.
    – rlpowell
    Commented Jul 24, 2015 at 0:03
  • 3
    Using script worked for me where stdbuf did not. Use script -e -c <cmd> /dev/null if you want script to return the exit code of <cmd>.
    – ntc2
    Commented Dec 24, 2018 at 18:09

If it is a problem with the libc modifying its buffering / flushing when output does not go to a terminal, you should try socat. You can create a bidirectional stream between almost any kind of I/O mechanism. One of those is a forked program speaking to a pseudo tty.

 socat EXEC:long_running_command,pty,ctty STDIO 

What it does is

  • create a pseudo tty
  • fork long_running_command with the slave side of the pty as stdin/stdout
  • establish a bidirectional stream between the master side of the pty and the second address (here it is STDIO)

If this gives you the same output as long_running_command, then you can continue with a pipe.

Edit : Wow Did not see the unbuffer answer ! Well, socat is a great tool anyway, so I might just leave this answer

  • 2
    ...and I didn't know about socat - looks kinda like netcat only perhaps more so. ;) Thanks and +1.
    – cheduardo
    Commented Jun 20, 2009 at 9:32
  • 5
    I'd use socat -u exec:long_running_command,pty,end-close - here Commented Aug 7, 2015 at 13:10

You can use

long_running_command 1>&2 |& print_progress

The problem is that libc will line-buffer when stdout to screen and block-buffer when stdout to a file, but no-buffer for stderr.

I don't think it's the problem with pipe buffer, it's all about libc's buffer policy.

  • You're right; my question is still: How can I influence libc's buffer policy without recompiling? Commented Apr 4, 2014 at 8:55
  • @StéphaneChazelas fd1 will redirected to stderr Commented Aug 7, 2015 at 9:26
  • @StéphaneChazelas i dont get your arguing point. plz do a test, it works Commented Aug 7, 2015 at 9:53
  • 6
    OK, what's happening is that with both zsh (where |& comes from adapted from csh) and bash, when you do cmd1 >&2 |& cmd2, both fd 1 and 2 are connected to the outer stdout. So it works at preventing buffering when that outer stdout is a terminal, but only because the output doesn't go through the pipe (so print_progress prints nothing). So it's the same as long_running_command & print_progress (except that print_progress stdin is a pipe that has no writer). You can verify with ls -l /proc/self/fd >&2 |& cat compared to ls -l /proc/self/fd |& cat. Commented Aug 7, 2015 at 10:44
  • 6
    That's because |& is short for 2>&1 |, literally. So cmd1 |& cmd2 is cmd1 1>&2 2>&1 | cmd2. So, both fd 1 and 2 end up connected to the original stderr, and nothing is left writing to the pipe. (s/outer stdout/outer stderr/g in my previous comment). Commented Aug 7, 2015 at 10:48

It used to be the case, and probably still is the case, that when standard output is written to a terminal, it is line buffered by default - when a newline is written, the line is written to the terminal. When standard output is sent to a pipe, it is fully buffered - so the data is only sent to the next process in the pipeline when the standard I/O buffer is filled.

That's the source of the trouble. I'm not sure whether there is much you can do to fix it without modifying the program writing into the pipe. You could use the setvbuf() function with the _IOLBF flag to unconditionally put stdout into line buffered mode. But I don't see an easy way to enforce that on a program. Or the program can do fflush() at appropriate points (after each line of output), but the same comment applies.

I suppose that if you replaced the pipe with a pseudo-terminal, then the standard I/O library would think the output was a terminal (because it is a type of terminal) and would line buffer automatically. That is a complex way of dealing with things, though.

  • 1
    Actually, it's an easy way of dealing with things when, as the question says, altering the program code is not an option. unix.stackexchange.com/a/215071/5132
    – JdeBP
    Commented Jan 17, 2020 at 19:11

I know this is an old question and already had lot of answers, but if you wish to avoid the buffer problem, just try something like:

stdbuf -oL tail -f /var/log/messages | tee -a /home/your_user_here/logs.txt

This will output in real time the logs and also save them into the logs.txt file and the buffer will no longer affect the tail -f command.

  • 7
    This looks like the second answer :-/ Commented Aug 11, 2015 at 11:17
  • 2
    stdbuf is included in gnu coreutils(I verified on latest version 8.25). verified this works on an embedded linux.
    – zhaorufei
    Commented Jul 20, 2016 at 10:18
  • From stdbuf's documentation, NOTE: If COMMAND adjusts the buffering of its standard streams ('tee' does for example) then that will override corresponding changes by 'stdbuf'.
    – shrewmouse
    Commented Sep 17, 2019 at 20:58

I don't think the problem is with the pipe. It sounds like your long running process is not flushing its own buffer frequently enough. Changing the pipe's buffer size would be a hack to get round it, but I don't think its possible without rebuilding the kernel - something you wouldn't want to do as a hack, as it probably aversley affect a lot of other processes.

  • 20
    The root cause is that libc switches to 4k buffering if the stdout is not a tty. Commented Jun 16, 2009 at 11:50
  • 5
    That is very interesting ! because pipe don't cause any buffering. They provide buffering, but if you read from a pipe, you get whatever data is available, you don't have to wait for a buffer in the pipe. So the culprit would be the stdio buffering in the application.
    – shodanex
    Commented Jun 16, 2009 at 13:58

In a similar vein to chad's answer, you can write a little script like this:

# save as ~/bin/scriptee, or so
script -q /dev/null sh -c 'exec cat > /dev/null'

Then use this scriptee command as a replacement for tee.

my-long-running-command | scriptee

Alas, I can't seem to get a version like that to work perfectly in Linux, so seems limited to BSD-style unixes.

On Linux, this is close, but you don't get your prompt back when it finishes (until you press enter, etc)...

script -q -c 'cat > /proc/self/fd/1' /dev/null
  • Why does that work? Does "script" turn off buffering? Commented Dec 6, 2016 at 10:09
  • @Aaron Digulla: script emulates a terminal, so yes, I believe it turns off buffering. It also echoes back each character sent to it - which is why cat is sent to /dev/null in the example. As far as the program running inside script is concerned, it is talking to an interactive session. I believe it's similar to expect in this regard, but script likely is part of your base system.
    – jwd
    Commented Dec 7, 2016 at 18:54
  • The reason I use tee is to send a copy of the stream to a file. Where does the file get specified to scriptee? Commented Jul 31, 2019 at 19:26
  • @BrunoBronosky: You are right, it is a bad name for this program. It is not really doing a 'tee' operation. It is just disabling buffering of output, per the original question. Maybe it should be called "scriptcat" (though it's not doing concatenation either...). Regardless, you can replace the cat command with tee myfile.txt, and you should get the effect you want.
    – jwd
    Commented Jul 31, 2019 at 21:51

jq has --unbuffered flag:

Flush the output after each JSON object is printed (useful if you're piping a slow data source into jq and piping jq's output elsewhere).

  • A lot of tools have options like this but my question is really about how to fix that for any tool. I guess I'll have to file a feature request to GLIBC. Commented Jun 19, 2020 at 9:12
  • 1
    I don't see where OP mentions using jq. Commented Feb 17, 2022 at 16:04
  • 1
    Well... the other commenters aren't wrong, but I'm glad you mentioned jq's --unbuffered flag. I've just been trying to pipe the output of mosquitto_sub to jq in a Git Bash terminal. I'm troubleshooting a hardware problem, and I need a 'live' readout of a few values. The messages that get splatted to the terminal are too big to see clearly, so I wanted to filter them using jq, got bit by this exact same buffering behavior. Using jq --unbuffered solved it neatly, thank you!
    – evadeflow
    Commented Nov 14, 2023 at 3:12

Python has the -u (unbuffered) flag.

$ man python3
       -u     Force the stdout and stderr streams to be unbuffered.  This option has no effect on the stdin stream.

I found this clever solution: (echo -e "cmd 1\ncmd 2" && cat) | ./shell_executable

This does the trick. cat will read additional input (until EOF) and pass that to the pipe after the echo has put its arguments into the input stream of shell_executable.

  • 3
    Actually, cat doesn't see the the output of the echo; you just run two commands in a subshell and the output of both is sent into the pipe. The second command in the subshell ('cat') reads from the parent/outer stdin, that's why it works. Commented Nov 9, 2016 at 11:19

According to this post here, you could try reducing the pipe ulimit to one single 512-byte block. It certainly won't turn off buffering, but well, 512 bytes is way less than 4K :3

  • 1
    -1 This is wrong. The problem is the stdio buffering, not the pipe buffering.
    – forest
    Commented May 1, 2021 at 21:42

According to this the pipe buffer size seems to be set in the kernel and would require you to recompile your kernel to alter.

  • 11
    I believe that is a different buffer. Commented Jan 8, 2013 at 21:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .