6

Backup your ~/.asoundrc - if you have one - and add the following, to a new ~/.asoundrc: pcm.!default { type plug slave { pcm "hw:0,0" } }


5

1) USB audio devices are handled by the ALSA kernel drivers, and those react automatically to the vendor:product identifier of the USB device (or the generic interface). None of the drivers you'd normally use would use a devstr. You don't say why you need this string, but you are probably doing it wrong. 2) The example contents of your devstr are the USB ...


3

Option 1: Use madplay to play the mp3 instead (sudo apt-get install madplay) In this case, it seems my USB Audio would only play audio at 48KHz, whereas the mp3s I was trying to play were actually at 44.1KHz It seems that mpg321 would try to play the audio at 44.1KHz anyways even though my USB Audio didn't support it, so it ended up playing it about 10% ...


2

This is possible with the ttable option of the route plugin, which is also integrated in the plug plugin: pcm.MyLittleDevice { type plug slave { pcm "hw:1" channels 16 } ttable [ [ 0 0 0 0 1 1 0 0 0 0 0 0 1 1 0 0 ] [ 0 0 1 1 0 0 0 0 0 0 1 1 0 0 0 0 ] ] } To reduce the volume, replace the 1s with smaller ...


2

Fixed it! Solution: using the alsa_out module. To use them, you start JACK as normal. Then you start an instance of alsa_in or alsa_out for each additional device (and “direction”) that you want to use. alsa_out will create a set of ports representing the playback capabilities of the device, and alsa_in will represent the capture/recording capabilities ...


2

The dmix/dshare/dsnoop plugins always use a fixed sample rate. To allow the device itself to run at a different rate, use PulseAudio instead. To resample the data from the application before it goes to the dshare plugin, wrap a plug plugin around it: pcm.outch1 { type plug slave.pcm { type dshare ipc_key 1111 slave usb_1 ...


2

Fortunately it had nothing to do with the error about the GVC mixer, because I could not find any information on that problem except the source code itself. Eventually I stumbled upon this issue on GitHub that states the same problem. It had to do with Alsa having bad support for USB audio devices and PulseAudio not being enabled in my build of Firefox. ...


2

I found this on Github, a set of pulseaudio profiles which might make it work. However, whilst stereo output was relatively easy to achieve for me, the mic didn't work for me at first (loopback with the nari hardware wheel works, muting via nari / audiomixer but audiolevels always stay at 0, mint 19.3@5.0.0-32-generic, pulseaudio 11.1) Turned out that ...


1

Changing the card number for devices with identical USB IDs is not possible. But it is possible to use udev rules to change the card ID (TT_2 etc. above), which can also be used with arecord. See "Identify two identical audio devices" on https://alsa.opensrc.org/Udev: SUBSYSTEM!="sound", GOTO="my_usb_audio_end" ACTION!="...


1

First step is to look at the alsamixer settings and adjust mixers to avoid clipping. If that doesn't help, the second step is to describe the "noticable digital artifacts" and narrow down their source. Poster reports: Well the levels in alsamixer were ok, but I saw a clock rate option and when I changed it from 0 to 20 (I guess these are just ...


1

I had this same issue, running openbsd 6.6 with a focusrite scarlite 2i2. After reading this post and searching some more I can across this link (https://www.mail-archive.com/misc@openbsd.org/msg171434.html). I set my flags in /etc/rc.conf.local to be: sndiod_flags=-f rsnd/0 -F rsnd/1 And did a full reboot to make sure the changes took place and then ...


1

USB provides a lot of information in a standardized way to the host. Use lsusb -v to see what is available about your attached devices. Among this information is the vendor and device number, similar to PCI devices. There are also several defined device classes, like storage, input or audio. This allows a driver ho handle a device class even if it doesn't ...


1

As you didn't specify which audio stack you use, there are a few options. If you are using PulseAudio, then the easiest software method is to start the loopback module (first answer): run pactl load-module module-loopback latency_msec=1 and set the source to your loopback. I'm fairly sure that ALSA requires a loopback module, after which you can set the ...


1

Some points that can guide you: You don't need AV Linux to use Guitarix once it is in the official repositories in Fedora 26, so I don't see any advantage of using it inside a container/VM. So my idea is to create a Docker image based on AV Linux and somehow pass my USB sound card adapter thingy (which I use to connect my guitar) through to the ...


1

Thanks to @CL. , this is the solution I came up with: pcm.xcoreremapped { type plug hint { show on description "Remapping stereo to 8-ch speaker array." } slave { pcm "hw:1,0" channels 16 } ttable [ [ 0.05 0.05 0.05 0.05 0.05 0.05 0.05 0.05 0.05 0.05 0.05 0.05 0.05 0.05 0.05 0.05 ] [ 0....


1

This may or may not help you, but in my case, when I was getting errors like that ("cannot find the slot for index", and "cannot create card instance"), I edited my /etc/modprobe.d/alsa.conf file (differently named in Gentoo than in your system, apparently), changing lines like these: options snd cards_limit=2 options snd-usb-audio index=2 changing the 2s ...


1

The USB ports found on computer monitors are usually those of a built-in USB hub: you would have to connect the monitor's hub to your computer using a USB cable for it to work. Then any device, sound card or anything else, should work as if it were connected directly to the computer.


1

After I blacklisted snd-hda-intel and rebooted everything worked perfectly out of the box.


1

> cat /etc/modprobe.d/alsa-base.conf options snd_hda_intel index=1 options snd_hda_intel index=2 options snd_usb_audio index=0 There can be only a single options line for one module, so snd-hda-intel ends up with the option index=2. Options with multiple values must use a single line, with the values separated by commas (index=1,2). However, for this ...


1

Finally doing alsamixer and using F6 to select the right soundcard did the job!


1

This is easy to solve. Issue: Your microphone is not getting enough power. The Raspberry Pi USB ports have issues supplying enough amps to USB devices that need more than power than USB memory cards. Solution: Get an active USB hub (powered hub plugged into a power source like an outlet.) The hub will power the microphone.


1

Verify that the snd-usb-audio kernel module is available and loaded, so that ALSA can see the devices.


Only top voted, non community-wiki answers of a minimum length are eligible