New answers tagged

1

audit.log does get the raw SELinux deny messages, that's true. But the messages you're looking at are not generated directly by SELinux itself. Instead, they are logged by setroubleshoot: a Python tool which post-processes the SELinux audit log messages and provides more human-readable, higher-level interpretations of them. The audit log is dedicated to the ...


1

rsyncy is a rsync wrapper that shows a status bar with progress:


0

Problem got fixed by installing "x11-server-utils" and reloading both sshd and my ssh session.


0

It turns out that sudo is the right tool for what you want to do. You can set up sudo for fine grained access control: Both who and what. Read man sudoers. Also ensure that the user has to write access to the script or its containing directory. Caution: use visudo to edit the sudoers file. It will check for errors, and error can get you locked out. Also ...


1

However I don't want to give the developer sudo access to the entire server, but rather only root context to run this bash file. Why would you give access to the entire server when you can set up sudo to allow the user to run a single bash script? cat /etc/sudoers.d/script4username username ALL=(ALL) NOPASSWD: /path/to/script


3

$3 is the third positional parameter (typically the third argument given to the current shell or shell function). Since your string D5P$3r is unquoted, the shell will expand $3 to the value of the third positional parameter. If this value is non-existent or empty, the string will be passed to ssh as D5Pr. To avoid having the shell expand $3, make sure to ...


1

assign your count to a variable count=$(netstat -an | grep ESTABLISHED | grep -w <Port Number> | wc -l) if [[ $count -gt 0 ]]; then #issue your echo or printf


1

Rsync is not suitable for this use case better to use it when trying to backup DATA filesystems rather than the SYSTEM itself. You can use dd command instead : Stop the hosted applications and services. Copy the whole disk using dd and zip it. sudo dd if=/dev/sda conv=sync,noerror bs=64K | gzip -c > <path>/backup_image.gz Execute a checksum on the ...


0

Edit your /etc/nfs-mount.auto : default -rw,sync 10.110.163.10:/nfs-directory/ Per default the mount type is nfs ; also you can access the share with /nfs-directory/default. You can enable logging on autofs in /etc/autofs.conf : logging = debug Check the logs : journalctl -u autofs Restart autofs : systemctl restart autofs


0

user7610's answer works but this will fail when release has minor version as well. For example, I have a Redhat 5 with el5_11. # rpm -q --queryformat '%{RELEASE}' rpm 36.el5_11 # rpm -q --queryformat '%{RELEASE}' rpm | grep -o [[:digit:]]*\$ 11 I tried the user7610 and Brād solutions combinedly. That solved my problem for a common script for all RHEL ...


0

Try to use the above instead : @^Server with GUI


0

Option 1: shrink your /home (you have more than 1 TB free space there) and grow your root logical volume. lvresize -L-500g rhel/root -r lvresize -L+500g rhel/home -r Note this might not be possible if the home logical volume uses XFS filesystem which is not shrinkable (and XFS is default on RHEL). Option 2: resize your physical volume (you have 136 GB free ...


0

You're not doing what the website suggests. Here's what it says (RHEL 7, CentOS 9.6): # Install the repository RPM: sudo yum install -y https://download.postgresql.org/pub/repos/yum/reporpms/EL-7-x86_64/pgdg-redhat-repo-latest.noarch.rpm # Install PostgreSQL: sudo yum install -y postgresql96-server # Optionally initialize the database and enable automatic ...


0

I solved the issue by uninstalling RHEL docker and installing docker 19.03.13 from docker.com. For those curious: [root@oitleap01 ~]# docker info Client: Debug Mode: false Server: Containers: 0 Running: 0 Paused: 0 Stopped: 0 Images: 0 Server Version: 19.03.13 Storage Driver: devicemapper Pool Name: docker-0:61-7297578891-pool Pool Blocksize: ...


-2

I would like to add: your first misunderstanding is what the host name is. When you type hostname at the command line it should only output the name of the server(host). The FQDN is a concatenation of the hostname and the domain. If the command hostname outputs host.domain.com then you have named your host incorrectly. The reason why this is wrong is because ...


1

Is my assumption correct? Yes. This is described in the dnf manpage: DNF uses a separate cache for each user under which it executes. The cache for the root user is called the system cache. This switch allows a regular user read-only access to the system cache, which usually is more fresh than the user’s and thus he does not have to wait for metadata sync. ...


0

fsid=0 for the mount options in /etc/exports was the same and should be different. This works now.


3

It's simply counting the number of commands ran since the HISTFILE was created. So if your shell is configured to create a new HISTFILE on every login, the first command you ran after login will be numbered 1. You can also use this to re-run commands. For example, I want to run command number 1030 again in bash. I can simply do !1030


2

Instead of killing PID, stop the service with sudo systemctl stop calc_live_servers - that is the way to stop a service. And if you don't want to have it running, disable the service with sudo systemctl disable calc_live_servers.


2

This is a known issue with older kernels (Bugzilla 1288237). The fix has been backported into newer kernsla and is tracked under the following security advisories: RHSA-2020:1016 RHSA-2019:3979 This problem is believed to have been introduced by the following upstream commit: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=...


1

Only the zsh shell supports changing effective user it. That is done by changing the value of the $EUID special variable which underneath calls the setresuid() system call. You can also set the UID variable which would set both the real and effective user id, or assign to USERNAME which would simulate a login and set the real effective uids as well as real ...


2

Try using cgroups and define your cpu-sockets as group, and assign processes to that group with cgrules (cgred, cgoups rules engine daemon). But at first: process and memory will be allocated within Linux with the numa policy. I think default policy is to locate the memory of a process to the cpu-socket where the process is running. Whenever you need much ...


2

You should have no problems migrating from CentOS to RHEL. Back in the days CentOS was claiming that it is an operating system binary compatible with RHEL. I do not see that claim any more but still they are very close. CentOS is built on the same sources as RHEL. CentOS group replaces copyrighted material like RHEL logos, etc. A program compiled on CentOS ...


3

If your lsblk supports the --json output format, you could parse that for block devices that (a) have no children (i.e. are unpartitioned) and (b) have no defined filesystem themselves: lsblk --fs --json | jq -r '.blockdevices[] | select(.children == null and .fstype == null) | .name'


4

Free software isn't about price, it's about freedom. “Free software” means software that respects users' freedom and community. Roughly, it means that the users have the freedom to run, copy, distribute, study, change and improve the software. Thus, “free software” is a matter of liberty, not price. To understand the concept, you should think of “free” as ...


0

I have similar keyboard problems with a diferent (and longer) stack of communication programs, like getting invisible characters or rare codes, but I think they are caused by me inadvertently pressing a key combination that changes the terminal functions. I really don't have time, as you say, for diving in the term definitions looking for which keys could ...


2

Perhaps your /etc/fstab specifies some mounts by either UUID= or LABEL= (causing mount to loop through all block devices it finds) and you have some garbage files as /dev/sdf and /dev/sdg that are not actual device nodes? Run ls -l /dev/sdf /dev/sdg. If it displays anything, and the letter in the very first column of the permissions string is not b, those ...


0

(Not an answer, but since I can't post comments yet, I am posting this here.) Could it be that on your system the mount command is wrapped in some script? Could you please post the output of these... mount --version file -L $(which mount) ls -la $(which -a mount) cat /etc/fstab


0

You can specify other remote shell for rsync than ssh using -e and that includes ssh with extra options so adding -e "ssh -o StrictHostKeyChecking=no" will do trick.


Top 50 recent answers are included