Hot answers tagged

39

In general, the difference from a user perspective should be purely cosmetic. Qt and GTK set themes independently (via, e.g., qtconfig or gtk-chtheme) but this is harmonized by some desktop environments. GNU/Linux tends to be more GTK oriented than Qt in the sense that the former is more commonly used, so you may want to prefer it when given the choice; an ...


18

No, there is no difference in the internal structure of such programs. GTK and Qt are user interface toolkits and frameworks. They are libraries that the developers use to design graphical interfaces. When a graphical (GUI) program is written, first its core internals are developed. This is what makes the program run. You never see the core, they simply ...


13

You want libguestfs. You can use it via guestfish or guestmount, or use the library directly through its C interface or any of the many language bindings, like Python.


13

This isn't necessarily Unix/Linux specific, so you are probably better asking this on Stack Overflow. Never the less, QtCreator is usually quite good at detecting alternative Qt installs, just create a new project and look under the Projects tab on the left. You can set different build configurations there. There should be a drop down box to select from the ...


13

It helped me to use -qt=qt5 switch or QT_SELECT=qt5 environment variable. $ qmake --version QMake version 2.01a Using Qt version 4.8.7 in /usr/lib/x86_64-linux-gnu $ qmake -qt=qt5 --version QMake version 3.0 Using Qt version 5.5.1 in /usr/lib/x86_64-linux-gnu $ QT_SELECT=qt5 qmake --version QMake version 3.0 Using Qt version 5.5.1 in /usr/lib/x86_64-linux-...


13

qtconfig no longer exist in Qt5. Qt5 applications will use the current desktop settings by default, but it doesn't work perfectly. For instance I'm using XFCE and it doesn't automatically set the style to Gtk. The style can be set with the -style command line option, for instance -style=gtk . Or you can use a specific Qt stylesheet with -stylesheet. You ...


9

This works for me. Might not work with all applications and all window managers. The pam format is at least supported by ImageMagick, so you can view it with display and convert it to other formats if need be with convert: xprop -notype 32c _NET_WM_ICON | perl -0777 -pe '@_=/\d+/g; printf "P7\nWIDTH %d\nHEIGHT %d\nDEPTH 4\nMAXVAL 255\nTUPLTYPE ...


9

I found the solution after reading https://wiki.archlinux.org/index.php/Uniform_Look_for_Qt_and_GTK_Applications: Qt5 decides the style to use based on what desktop environment is used. If it doesn't recognize the desktop environment, it falls back to a generic style. To force a specific style, you can set the QT_STYLE_OVERRIDE environment variable. ...


7

Found a solution which works for GTK apps (but not Qt). One needs to set XMODIFIERS="@im=none" to let X11 handle dead keys. Thanks to @PabloSaratxaga for his answer.


7

QT_DEVICE_PIXEL_RATIO is deprecated since 5.4; instead, use QT_SCALE_FACTOR. I use it, setting it to 1.5, with good results (e.g., VirtualBox 5.1)


7

VLC media player has been using Qt interface for quite long time. VLC however, has an option to override window style, which will also change the file dialog as well. In VLC media player, do the following steps: Go to Tools > Preferences (or press Ctrl+P) In the first tab, under Interface Settings - Look and feel, look for "Force window style:" with the ...


6

I don't know where you got the idea that doing a make clean before a make install was somehow something you should be doing. The canonical INSTALL file for autotools spells out the process: ./configure make make check (optional) make install make installcheck (optional) At item 6, it says: You can remove the program binaries and object files from the ...


6

It seems to be Qt specific (from trying in Qt Assistant). I think it is because Qt uses only the scrolling distance for its wheel events. Instead of using xmodmap here, you can set your scrolling distance to negative values. You can set it through a file in /etc/X11/xorg.conf.d/, for a mouse managed by evdev : Section "InputClass" Identifier "...


6

According to the Archlinux Wiki: Since Qt 5.6, Qt 5 applications can be instructed to honor screen DPI by setting the QT_AUTO_SCREEN_SCALE_FACTOR environment variable. So, you just need to edit ~/.profile or ~/.bash_profile and add this line to export the correct environment variable like this : export QT_AUTO_SCREEN_SCALE_FACTOR=1 I've tried with ...


6

You have the latest version of qt5-default package available from Ubuntu repositories qt5-default (5.9.5+dfsg-0ubuntu1). To install the 5.10.x version you should follow the instructions described on the official website : Install Qt 5 on Ubuntu The installation file can be downloaded from here. The 5.10.0 version: wget http://download.qt.io/...


5

Ok I've found the solution : mount the directory using cifs rather than smbfs, and it works ! I added the following line to fstab : //windows-computer/share /home/jj/smbShare cifs username=jj,password=***,perm,iocharset=utf8,uid=jj,gid=users,nounix,noserverino 0 0 To avoid putting your Windows password in the fstab file, you may use a credential ...


5

One application is using GTK2 and the other is using GTK3 (unless I'm mistaken). Thus, you need to switch to a theme with both GTK2 and GTK3 components. One theme that supports both is Phenix, but if you search you can find many others. Most GTK3 themes on OpenDesktop.org also support GTK2. As for Qt, install qtconfig (I'm sure Arch has some version of it ...


5

this here do its job: https://www.archlinux.org/packages/community/x86_64/lxqt-config/ not packaged, afaik: http://qt-apps.org/content/show.php/Qt5+Configuration+Tool?content=168066


5

I am answering my own question. This was harder than I expected, and I want to gather all the information in one convenient place. Install Binary, Development, and Debug Packages This can be done using apt (or aptitude). Example for Qt5: Compiled libraries: qt5-default Development package (headers): qtbase5-dev Debugging symbols: qtbase5-dbg Find ...


5

Whilst having connected for media purposes, I'd suggest you to try receving a call on your phone or dial a number. Most of the recent Android versions, provide an option to use your Telephone Audio through your already connected bluetooth speakers on a calling screen once you touch the speakerphone toggle icon. There shouldn't have been an explicit need of ...


4

Your root file system (which by the way is extremely small, even considering that you have /home, /tmp, /usr and /var elsewhere) is practically full; that exact df invocation reports 24 MB free on /, which adds up well with the 23.87 MiB reported by the wizard. I'm guessing this is because parts need to go into locations outside of the supposed installation ...


4

This works as expected out of the box on my system. You don't seem to have your sudo configured to allow you to run graphical applications. I haven't encountered this issue in quite a few years but one of these should work: Switch off access control for X xhost + sudo ./qt-opensource-linux-x64-1.6.0-5-online.run Then, activate it again with xhost -. ...


4

I was struggling with getting Qt5 to use the native style on Linux Mint (18, Cinnamon) for a Qt5 installation I downloaded myself. What seems to work in the end is $ unset QT_STYLE_OVERRIDE I think this variable is set by cinnamon-session itself (grepping the binary returns a match) so there is no easy way to unset it.


4

The qtcurve config file is ~/.config/qtcurve/stylerc. You can copy the contents of your downloaded xxxx.qtcurve file into that file. You can customise many aspetcs of your theme. To understand the functions of keys (activeTabAppearance, appearance, …) you can examine this file. Yet I couldn't find a reference for values (darkinverted, origselected, …). ...


4

I've solved in this way: install ofono in /etc/pulse/default.pa find the line load-module module-bluetooth-discover and change it in load-module module-bluetooth-discover headset=ofono Add the user pulse to group bluetooth to grant the permission: sudo useradd -g bluetooth pulse (probably it's already correct) VERY IMPORTANT: To grant the permission, add ...


4

This sounds very much like a known bug: TightVNC doesn't support XKEYBOARD, which confuses Qt5. (XKEYBOARD is one of several widely-supported extensions to the original X11 protocol.) The bug report against the Qt project has a comment that states that it is unlikely to be fixed because lack of XKEYBOARD is rare. The Debian bug report suggests using TurboVNC ...


3

Have a look at /etc/X11/xinit/xinitrc (this may be different places on different systems) to see what files it sources. Generally, this will have an if..elif..else structure, so that only one initialization file is read, with $HOME/.Xclients prioritized then /etc/X11/xinit/Xclients. That's almost certainly where the terminal that appears comes from (I am ...


3

There is a better method. If you want to make your changes permanent, you need to modify the /usr/lib/x86_64-linux-gnu/qt-default/qtchooser/default.conf file, which is a symlink to ../../../../share/qtchooser/qt4-x86_64-linux-gnu.conf. Here is an example for my system (Ubuntu 17.10 x64, Qt 5.10.1). I would suggest to keep both original symlink file and its ...


3

Have you tried Qt5Ct? from this article Unlike Qt4, Qt5 doesn't come with a configuration tool to allow setting the icon theme, fonts or the style and instead, it tries to use the settings from the running desktop environment. To force the Qt5 style or icon theme, you can use an application called Qt5ct (Qt5 Configuration Tool). Besides the style and ...


3

The problem is that cron runs in a text environment. There are a few different approaches for that, depending on what your machine is running. set a display variable: * * * * * DISPLAY=:0.0 /home/my-user-name/Documents/bin/program set up a password-less ssh key-pair and do * * * * * /usr/bin/ssh -y user@localhost /home/my-user-name/Documents/bin/program


Only top voted, non community-wiki answers of a minimum length are eligible