29

FTP is an ancient protocol. It relies on two TCP connections: a control connection over which commands are exchanged, and data connections for the content of files and also for the output of commands such as ls. What's happening here is that the control connection is established, but the data connections aren't going through. By default (active mode), data ...


4

I'd give ProFTPD a look. ProFTPD is just the server daemon but there are several GUIs that you can use to manage it. Also check out the ProFTPD wikipedia page for additional information as well as a link to a comparison of other FTP servers. GAdmin-ProFTPD GAdmin-ProFTPD is a GTK+ front end for GNOME and KDE, as a part of the GAdmintools collection. ...


3

Full Complete solution for "ftp 500 Illegal PORT command". Click the following link: http://www.ucodice.com/articles/ftp-500-illegal-port-command/. Excerpt Trying to connect the ftp server & getting 500 Illegal port command. This issue may occur when ftp program is not configured for Passive mode. You may get error snippet such as: COMMAND:> ...


3

To split lines into variables, you can use read (although there are a number of caveats, as always when processing text in the shell): pure-pw list | while read s r; do pure-quotacheck -u "$s" -d "$r"; done This allows you to process $r before invoking pure-quotacheck, e.g. to remove the /./. You can also do that by processing pure-pw's output, as you ...


3

Aargh! From README.Virtual-Users : You can add, modify and delete users with the previous commands, or by editing /etc/pureftpd.passwd by hand. But the FTP server won't consider the changes you make to that file, until you commit them. So, simply pure-pw mkdb or pure-pw passwd joe -m did the job


2

It may be the problem with ssl. Try: lftp -e 'set ftp:ssl-allow no' ...


2

I have solved it, it was not straight forward but after a analyzing the script that runs that service of pure-ftpd, i figure that the script /etc/init.d/pure-ftpd starts another script called pure-ftpd-wrapper Looking at this script it apprears to read some configuration values from disk, then searching for manpage of pure-ftpd-wrapper took me to ...


2

To be able to disable SSLv* and use TLS instead, this is what I does with version 1.0.33 and 1.0.38 : Put this in /usr/sbin/pure-ftpd-wrapper.patch (or replace -J global switch by -S): --- pure-ftpd-wrapper 2012-10-29 10:45:31.000000000 +0000 +++ pure-ftpd-wrapper.modified 2015-11-12 15:23:31.104156082 +0000 @@ -87,6 +87,7 @@ 'Quota' => ['...


1

you are getting ftp connection from multiple users but from single serverIP to your ftp server? then look at this line in your config MaxClientsPerIP 20 and increase it to the number of users they are trying to connect from singleIP to your ftp server and reload/restart the service. and also I see you didn't enable the logs yet, see VerboseLog no line in ...


1

Looks like probably epel on your machine is not enabled. Even though you installed it, you may have to enable it manually. Check /etc/yum.repos.d/ for epel.repo file and set it to enabled=1 if it's not already. As per your finding, check also /etc/yum.repos.d/archive, as the file may be put there by the package installation.


1

You could try to use lftp, setting first ftp:home /particulardirectory in LFTP's config file ~/.lftprc. From the manpage: ftp:home (string) Initial directory. Default is empty string which means auto. Set this to `/' if you don't like the look of %2F in FTP URLs. The closure for this setting has format ...


1

Did you know that systemd comes with some generators that generate the pure-ftpd.service file for you? The result is a not so nice unit file, but working. The folder where it is generated is /run/systemd/generator.late You can see the source with cat pure-ftpd.service Then, create a new /lib/systemd/system/pure-ftpd.service and put the contents of the /run/...


1

I have resolved the matter on my own. I did my research by doing ftp to my own server. The thing is that the file owner isn't changing. The 1st output shows the username and the 2nd shows the user ID for the same user. So simple but for confirming this I had to experiment with my own server.


1

Please take a look at the following answer https://stackoverflow.com/questions/394984/best-practice-to-run-linux-service-as-a-different-user it does not fully answer your question - i.e it does not provide an answer using pure-ftpd switches but gives several generic methods as well as gotchas that may be worth thinking about


1

Some daemons (e.g.: postfix, apache) have the option to lower their operating UID after they start. It doesn't appear that pure-ftpd has that option. So you need to have your distro do it. FreeBSD, for example, allows you to set the UID of each daemon in the various rc scripts. You could also start it out of inetd. Using inetd will cause it to take longer ...


1

The behaviour you are observing happens because even though the client has written data to the socket for the FTP data connection and the client's kernel has replied that this happened successfully (by returning successfully from the write() or send() system call), the data is still in all sort of buffers and not already committed to the destination file. It'...


Only top voted, non community-wiki answers of a minimum length are eligible