New answers tagged

0

I had a similar issue where volumes around 30 % were already very loud, so I wanted a limit too. I found a similar question was asked over at askubuntu: https://askubuntu.com/questions/32383/adjust-pcm-volume Essentially sound cards have many volume sliders in alsa, and pulseaudio usually only sets the Master, and then sets everything else to 100 %. However, ...


0

DO YOU HAVE TRIED TO RESET SOUND SYSTEM ? sudo pulseaudio -k && sudo alsa force-reload


0

Upgrading the operating system fixed the issue.


0

I had this problem, but noticed that every time I connected to the headphones the maximum volume available would be different. e.g. 100% on the laptop could be either quiet or loud with the same test audio. Also it didn't matter whether it was headphones or a portable BT speaker. Same issue. I use my bluetooth headset with both my android phone and my Pop!OS ...


0

This is most likely happening to you when you leave the computer for a while, then come back. Why? You have a monitor connected via HDMI. HDMI supports carrying audio, and is thus an audio output device. When the monitor powers off due to inactivity , then back on, this audio device becomes available again. PulseAudio is configured to switch its default ...


0

Besides creating the sink, most applications filter out monitor sources. To be able to pick the source directly for example in Google Meet, the module-remap-source helps. # create sink pactl load-module module-null-sink sink_name=virtmic \ sink_properties=device.description=Virtual_Microphone_Sink # remap the monitor to a new source pactl load-module ...


0

This worked for me: ffmpeg -f alsa -ac 1 -i dsnoop:CARD=USB,DEV=0 -acodec mp3 -y ~/recording/$(date +"%Y-%m-%d_%H:%M").mp3 I think the key may be to use one of the dsnoop entries that points to a physical device, not the loopback, but I'm not sure.


2

I followed some of the comments here: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/809 Killing pipewire and then restarting pulseaudio fixed the problem: systemctl --user stop pipewire.service systemctl --user restart pulseaudio.service It appears to be a race between pipewire and pulseaudio. I don't know anything about pipewire, but it ...


0

Somehow, installing the debian-pulseaudio-config-override package makes all audio go through the PulseAudio server. Now, in PulseAudio, the choice of default audio output device was wrong - it was one of the HDMI connections. That should really not have happened, since I don't have an audio-capable monitor, but - it did (perhaps because of loading the ...


0

I managed to solve the problem satisfactorily. As I suspected, root cannot access my user's sink because of pulseaudio. The answer from @dirkt prompted me to look for solutions for pulseaudio, and the solution is highlighted here: pactl works in userspace not as root on i3. Since I'm using doas, I had to add setenv {XDG_RUNTIME_DIR=/run/user/1000} to doas....


0

@Arthur's answer works if you boot with the device plugged in. However, if it's a hot-pluggable device that won't exactly work. It looks like PulseAudio 14 put out a fix for your issue (switching to HDMI specifically) by adding a default blacklist option for HDMI outputs. In my case, I want to blacklist my CalDigit dock, so I've modified my /etc/pulse/...


0

I'm an Arch user but the issue you have faced is common to any distribution and seems occur depending on the hardware support , drivers side. There are workaround and maybe with time it will come to be fixed by some one skilled enough to code few lines. There are two approach to this case , one easy one less: 1) Via App (the easy one): The 150% of override ...


0

I use PulseAudio for bluetooth support. If you run Pulseaudio, please use the Pulseaudio API for volume settings (or script it via pacmd or pactl). Pulseaudio provides a compatibility layer for ALSA that include this "Master" control, but that gets mapped to Pulseaudio volume settings. Also read up on system-wide Pulseaudio vs. per-user Pulseaudio....


0

This worked for me from a response in askubuntu - I am running pulseaudio 13 None of the above fixes worked for me (pulseaudio 11.1); what solved it for me was going into /etc/pulse/daemon.conf and turning off realtime-scheduling by adding in the line realtime-scheduling = no beneath the line reading ;realtime-scheduling = yes like so: ;realtime-scheduling =...


0

PulseAudio devices can go above 100%. On my i3 desktop, I map my volume keys with: bindsym XF86AudioLowerVolume exec pactl set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo -5% bindsym XF86AudioRaiseVolume exec pactl set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo +4% This means it will continue to get louder as long as I keep pushing ...


1

I would recommend installing Cadence from the KXStudio repositories and have it Auto-Start Jack at login, including PulseAudio & ALSA bridges. Works fine for me.


0

On the different systems I've worked with, Audacity tends to be the most flexible of DAWs. Try changing devices in Edit>Preferences. ALSA might be a safer bet than Jack. Firefox is typically PulseAudio dependent. One thing that might really help is to get Cadence from the KXStudio repositories.


1

You might be able to do this with PipeWire instead of PulseAudio. Comment from Ric @tornado99: On arch-based distros: uninstall pulseaudio-bluetooth force uninstall just pulseaudio without removing any dependencies, so sudo -Rdd pulseaudio install pipewire and pipewire-pulse edit /etc/pipewire/media-session.d/bluez-monitor.conf to allow mSBC make sure you ...


1

It appears that this was an issue with the USB sound interface, as I was getting the following errors in the journalctl -xe log: kernel: usb 1-8: uac_clock_source_is_valid(): cannot get clock validity for id 18 kernel: usb 1-8: clock source 18 is not valid, cannot use kernel: usb 1-8: 1:1: cannot get freq (v2/v3): err -110 kernel: usb 1-8: 1:1: cannot set ...


0

Suggest you check the manpage or help for whatever command you intend to use and see if the Sink name can be used instead of the index number


0

Update: I managed to fix my problem using this solution. Create the following file: /etc/modprobe.d/audio-fix.conf --------------------------------------------------------- blacklist snd-sof-pci options snd-intel-dspcfg dsp_driver=1


Top 50 recent answers are included