Hot answers tagged

21

Yes, found out ! To activate VIRTUAL output of the intel driver, you need to create a 20-intel.conf file in the Xorg configuration directory (/usr/share/X11/xorg.conf.d under Debian stretch, found out by reading /var/log/Xorg.0.log) Section "Device" Identifier "intelgpu0" Driver "intel" Option "VirtualHeads" "2" EndSection My /etc/bumblebee/...


2

Solution: sudo apt-get purge bumblebee* sudo apt-get purge bbswitch* sudo apt-get purge nvidia* sudo apt-get --purge autoremove Afterwards, run driver-manager, install the Nvidia proprietary driver and reboot.


2

I know Arch is the pinnacle of Linux distro documentation, but in this case there is also an Excellent guide to Bumblebee on Fedora. Unfortunately, I'm afraid this will get you to the same place: "it works :D but I have to use optirun everytime :-(", which, by your sad-face, is not what you want. The good news is that better Optimus support is in the works ...


2

I had the same problem of "Screen 1 deleted" on Debian testing with 4.9 kernel. I resolved adding the following lines to /etc/bumblebee/xorg.conf.nvidia as described here https://wiki.debian.org/Bumblebee: Section "Screen" Identifier "Default Screen" Device "DiscreteNvidia" EndSection Eventually try also to set the BusID manually in the same file, ...


2

How they work depends on the distribution in question. What you've described as the actual behavior matches how most distros behave, but there a few odd cases like Gentoo (which requires you to manually blacklist the in-kernel drivers to have the proprietary ones load) that don't do things that way. As to why it behaves that way, modern X servers will auto ...


2

Added xrandr --setprovideroutputsource modesetting NVIDIA-0 xrandr --auto to my ~/.xinitrc file and that made me able to boot with my NVIDIA GPU enabled in BIOS, and without SDDM. The reason why that wasn't added yet was because when using SDDM I had to add that to /usr/share/sddm/scripts/Xsetup instead of to ~/.xinitrc. I completely forgot that I didn't ...


2

With the nouveau driver, "power management" can mean several things. On modern kernels, the nouveau driver knows how to access the same ACPI interface as bbswitch does, and will present it using the vgaswitcheroo mechanism, as /sys/kernel/debug/vgaswitcheroo/switch if you have the debugfs virtual filesystem mounted. This is essentially a solved problem: ...


1

To answer my own question, I finally found the solution here: https://github.com/Bumblebee-Project/Bumblebee/issues/764#issuecomment-448327665 So the actual problem is that the X Server and lspci freezes the system when encountering an NVidia GPU which is powered off. I guess setting the kernel option pci=noacpi just accidentally worked around this problem ...


1

00:16.3 Serial controller [0700]: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller [8086:1c3d] (rev 04) This is not a display controller at all. Your grep is catching the "3d" part in the vendor:product ID (8086:1c3d). This looks like it would be the part of the Management Engine that acts as a virtual serial port that would be ...


1

After 1 week of multiple re-installation, I decided to give up. I uninstall those drivers, go to customize other parts of my laptop change config, edit grub, power management. And surprisingly, out of nowhere. I run neofetch paraduxos@ASUSDOGE:~$ neofetch _,met$$$$$gg. paraduxos@ASUSDOGE ,g$$$$$$$$$$$$$$$P. ------------------ ...


1

Searching nVidia, it seems version 435.21 is the minimum needed. Those aren't debian offered versions of nvidia-driver packages, but buster-backports give you the opportunity to use 440.59 as of writing. You should add backports in your repositories and force nvidia-driver from there. Greetings. -edit- didn't read everything ! You tried the backports, but ...


1

Not sure if the problem is in mesa, xserver or primus, but here's the upstream bug report: https://bugs.freedesktop.org/show_bug.cgi?id=106910 and here's a simple workaround: export LIBGL_DRI3_DISABLE=1 primusrun glxgears


1

I had the same problem here. Just downgrade mesa to 18.0.4. I use Arch, so I did: pacman -U /var/cache/pacman/pkg/mesa-18.0.4-1-x86_64.pkg.tar.xz


1

Downgrade to 4.9.0-3 solves the problem.


1

I've used some scripts on top of xrandr for some years now to set up side-by-side and (currently) tee-shaped desktops on Arch Linux. It should be a simple job to adapt side-by-side.sh to your needs: #!/bin/sh eval `\`dirname -- "$0"\`/monitor_resolutions.sh` expected_monitors=2 if [ "${monitor_count:-0}" -ne "$expected_monitors" ] then echo "$0: ...


1

I have always had the best luck running Nvidia proprietary drivers on my machines. Nvidia driver installation: The latest driver can be downloaded from here (http://www.nvidia.com/Download/index.aspx), but generally unless you have a specific reason to have the latest driver, it is always easier to use the one included in your distribution (sudo apt-get ...


1

I can answer your second question: What can I do to work around this? What we want to do is to run Steam through PlayonLinux with optirun/primusrun as a prefix. All games that you run through Steam will also be launched automatically like this. We have to go to /usr/share/playonlinux/lib/ There is a file there called wine.lib that we will edit. Important:...


1

After a while, I found out, it is a separate package called nvidia-prime-applet. sudo apt-get install nvidia-prime-applet and enabling it in Applets (one of Mint's configuration application).


1

2560x1440 resolution is only possible via DisplayPort. Note that the "hacks" on the net aren't supported on most models of displays. Despite in your case it was possible, linux only supports "official" modes AFAIK.


1

Here is a step-by-step guide for what I did to make Nvidia Optimus work on Kubuntu 15.10 64-bit. Note that I describe the user friendly way because it's meant for all users to be able to do it. In the Device Manager choose the recommended driver, in my case nvidia-352 If you don't have it already, in Muon Discover find Muon Package Manager and install it ...


1

After you uninstall nvidia drivers and the related stuff like bumblebee, reverting to Intel should be straightforward: $ cd /etc/X11/ $ su - # Xorg -configure What does it say?


1

I think the reason you're having problems is that your video card requires the proprietary nvidia 352 driver and the only driver available in the jessie, jessie-backports, and sid repositores is the version 340 driver. You should check on the Nvidia website drivers page to verify the version your card requires. The proprietary version 352 driver is ...


1

I have a similar setup on Slackware: # lspci | grep -E 'VGA|3D' 00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06) 01:00.0 VGA compatible controller: NVIDIA Corporation GK106M [GeForce GTX 765M] (rev ff)} And my xrandr only shows one card: xrandr --listproviders Providers: number : 1 Provider 0: id: 0x47 ...


1

Problem You don't have a battery hogger. You have an incorrectly configured driver. You have a NVIDIA Optimus Powered Graphics System Optimus is not pure NVIDIA. It is an Intel Graphics Card( Intel HD 4000) used to drive a discrete NVIDIA Card(GeForce GT 740M) Linux Mint has the required option, VGA_SWITCHEROO, on by defult, therefore all your graphics ...


Only top voted, non community-wiki answers of a minimum length are eligible