New answers tagged

0

UDP packets from port 19132 were actually routed through eth0 but somehow with the wrong source address. The server was binding to 0.0.0.0 and binding to 192.168.1.5 fixed the problem.


0

You can use a firewall for that. Disable all incoming and outgoing traffic by default. Allow outgoing traffic on the openvpn network interface. Allow the access to your vpn server from all interfaces (so you can connect to vpn). If you can only use a host name to access the vpn server, you'll have to make these rules more permissive. Allow outgoing port 53 ...


0

As per Stephen Harris' comment above, this works great: gpg -d -a < xAptive.ovpn.enc | sudo openvpn --config /dev/stdin


1

I got it working. It looks like I have to enable IPv6 manually: docker run -it --rm --cap-add=NET_ADMIN --device /dev/net/tun \ --sysctl net.ipv6.conf.all.disable_ipv6=0 -v $PWD:$PWD \ ubuntu bash


0

If your gameserver is running Linux then yes. You need to get rid of the SNAT rule, unfortunately when you do so you create another problem, there is no longer anything to force traffic that came from the VPN to go back over the VPN. To fix this you can use policy routing on the game server. I belive you would set this up roughly as follows (but this is ...


0

By default, Amazon EC2 instances have a form of "IP address spoofing" applied. So traffic to/from an EC2 instance must have the address of that instance in the packet. That means it can't be used as a router or a VPN gateway; Amazon blocks this traffic. This is called a "SourceDestCheck" in the Amazon documentation. So you need to tell Amazon to disable ...


0

The problem was that pihole was reading the server's IP address from '/etc/hosts' in which it was 127.0.0.1. The solution was to edit the hosts file to look like this: mydomain.com my domain.com 127.0.0.1 localhost


0

Here is the solution: Click NetworkManager applet icon > VPN Connections > Configure VPN... > select VPN network > Edit > IPv4 Settings > Routes... > Check 'Use this connection only for resources on its network'


2

You need to run some kind of DNS server of proxy. An ideal location would be the VPS server itself. dnsmasq has a small footprint and will act as DNS proxy: It will pick up /etc/hosts entries from the machine it is running on and add them to the upstream DNS information. So this will be the single location you have to edit for new entries. All your clients ...


0

The key of custom configuration is to use the client-connect option Extract of vpn-endpoint.conf script-security 2 client-connect /etc/openvpn/up-client A very basic script #!/bin/sh CONFIG_FILE=$1 ( env ; echo CONFIG_FILE ${CONFIG_FILE} ) >> /var/log/openvpn-up-client.log case "$username" in (me) echo 'push "route 192.168.168....


0

Ok, so I made few false assumptions: 1) I've read somewhere that appending interface name to "input_" will automatically filter traffic from that interface, which was false. 2) I did see encapsulated traffic, but there also were some valid "10.52.0.0/16" packets, brodcast ones to be specific. So finally I remembered THIS: https://serverfault.com/questions/...


0

Not enough rep to comment but I wanted to add that according to this page, it is possible to specify the protocol for each remote entry. How do I set up my profile for server failover? You can provide OpenVPN with a list of servers to connect to. On connection failure, OpenVPN will rotate through the list until it finds a responsive server. For ...


0

At the moment your description sounds like you have all traffic routed over the VPN tunnel. To use two (or more) simultaneous tunnels, you need to define which networks are to be routed via which VPN tunnel. You can have networks a,b,c routed through VPN 1 and networks x,y,z routed through VPN 2. Or everything except x,y,z routed through VPN 1 and x,y,z ...


Top 50 recent answers are included