Hot answers tagged

52

I imagine you want to stop the display manager which is what I'd suspect would be using the Nvidia drivers. After change to a text console (pressing Ctrl+Alt+F2) and logging in as root, use the following command to disable the graphical target, which is what keeps the display manager running: # systemctl isolate multi-user.target At this point, I'd expect ...


25

In theory, primusrun is preferred over optirun for performance and stability, as recommended by the bumblebee devs. I'm unsure why you get the results you did. I know in some cases, frames are capped, but that doesn't seem to be the case for you. (In my case I get 150 fps for optirun glxspheres64 and 60 fps for primusrun glxspheres64, which I believe is due ...


19

The versions are as follows: nvidia-331: the current release nvidia-173: an old legacy binary driver, supporting (much) older cards nvidia-304: a more recent legacy binary driver, supporting older cards nvidia-331-updates: the update channel for the current release (but it's the same as the version in nvidia-331 now) nvidia-304-updates: the update channel ...


18

Try to run the nvidia-smi command. It will give you information about your driver version, the cards you have in your system, etc. The advantage is that you do not need a GUI, and it is an altervative to modinfo nvidia.


16

For newer Debian & Ubuntu distros using nvidia, I had to do the following: First, edit /etc/default/grub. Change the following line: #GRUB_GFXMODE=640x480 to this: GRUB_GFXMODE=1280x800 GRUB_GFXPAYLOAD_LINUX=keep replacing 1280x800 with the desired resolution. Then: echo "echo FRAMEBUFFER=y" | sudo tee /etc/initramfs-tools/conf.d/splash sudo ...


12

I am not sure if you have created the string following xrandr --newmode by yourself or have you copied it from somewhere else, but it won't work in its current form. I recommend to do it step by step. First, you need to generate the new mode. I recommend using 60Hz with LCD or 85Hz with CRT monitor gtf 1280 1024 60 You will get something like: # ...


12

I know your pain, this has been annoying me for months now. The only way to fix the desktop I've found is brute force, I made a shortcut to do this and run it every time I resume from standby: killall plasmashell; kstart plasmashell EDIT: 2020/10/6 - this bug has since been fixed, but for reference: restart command for plasma 5.18.5 is now: kstart5 ...


10

Here's your best option: Use sudo hwinfo --framebuffer as described, choose a video mode you would like to see during boot in console, then add the option vga=nnn to the kernel boot parameters. The only trick is that nnn is the video mode you selected from the list produced by hwinfo - CONVERTED TO DECIMAL !!! If you try vga=0xwhatever it's not going to ...


10

You need to enable the non-free repositories: sudo sed -i.bak 's/stretch[^ ]* main$/& contrib non-free/g' /etc/apt/sources.list Then run apt update and try your installation again. You’ll probably also need to install the kernel headers if you haven’t already: sudo apt install linux-headers-$(uname -r) See the full instructions on the Debian wiki.


9

Update typing: nvidia-smi gives you the driver verson nowadays. Old answer: Typing nvidia-settings --version will tell you what version of the NVidia driver is currently installed (even when it's not running). lsmod | grep video will show you the running video module. modinfo szWhateverWasTheOutputOfThePreviousCommand will give you the version of the ...


8

Based on your xrandr output above there are two problems; firstly the output name is VGA-2 (not VGA0) and secondly it seems that you don't have a mode available for 1920x1200. First just try setting the resolution: xrandr --output VGA-2 --size 1920x1200 If that doesn't work (which I think it won't as 1920x1200 isn't a mode) then do the following: cvt ...


7

Easiest way to isolate the NVidia Driver Version number alone is to run the following: nvidia-smi --query-gpu=driver_version --format=csv,noheader On my system this produces the following result: andrew@illium~$ nvidia-smi --query-gpu=driver_version --format=csv,noheader 396.51 andrew@illium~$


7

You can boot into single user mode or text-only mode, make the necessary changes, and then boot back into graphical mode. You can force booting into a specific mode when first turn on your computer by appending a number to the end of the linux line in GRUB2 (or the kernel line, in GRUB Legacy). When you boot your computer, press e at the GRUB screen (the ...


7

I always suspect the cables long before I suspect the actual Ethernet NICs. They almost never fail! To methodically debug the issue I'd first eliminate the following things: Ethernet Cable Ethernet female connectors on NIC and switch Another device on the network using the same IP Once the above have been eliminated as potential problems then move up to ...


7

The basic steps are: sudo apt-get install nvidia-kernel-dkms linux-headers \ nvidia-settings nvidia-xconfig sudo nvidia-xconfig The last step is running nvidia-xconfig to set everything up. That should sort it all out, including blackisting the nouveau driver if you were using it. You'll have to reboot for it to take effect (well, ...


7

I never was able to get it to work by hand editing xorg.conf. What did work was to execute on the command line which sets it all up for you: sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration Then edit xorg.conf. For me that was sudo vi /etc/X11/xorg.conf and prepend "#" to each line containing allow-empty-initial-configuration to ...


7

You need to unload the nouveau driver before you can load the nvidia driver. However, the nouveau driver is currently in use by the X-server, so it cannot be unloaded yet. You have to stop the X-server first (but don't just re-start it, as then it will use the nouveau driver again). So in short: stop X-server: sudo service lightdm stop unload the nouveau ...


7

The following is a simple method that does not require scripting, connecting fake monitors, or fiddling and can be executed over SSH to control multiple NVIDIA GPUs' fans. It has been tested on Arch Linux. Create xorg.conf sudo nvidia-xconfig --allow-empty-initial-configuration --enable-all-gpus --cool-bits=7 This will create an /etc/X11/xorg.conf with an ...


7

I have cuda 9.1 installed on Minty 18.3 with nvidia 387 390 drivers. This is what I did: Use the driver manager to install nvidia 390 387 (for some reason, 390 isn't working). Note the pic shows 387, but 390 works now. Get the nvidia repo from: wget http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1704/x86_64/cuda-repo-ubuntu1704_9.1.85-...


6

Depending on your version the way of stopping the X server varies. You have to exit the graphic mode (by typing alt+ctrl+F1, for example), login, and then type one of the following commands to stop the X server: sudo service lightdm stop sudo service gdm stop sudo service kdm stop //this is the one that worked for mi as I use kdm and Linux mint Now you ...


6

There is probably a line in /etc/apt/sources.list (or in one of the files in /etc/apt/sources.lists.d/) starting with deb cdrom ... Comment this line out and Debian won’t try to install packages from this disc.


6

The answer was simple: just install nvidia drivers, open the nvidia settings page and set to use the Intel HD GPU only. Login again and you are done. Works perfectly. Battery lasts much much longer and wayland works properly. As soon as the nvidia GPU is enabled, it seems that the fan turns on immediately, and keeps running even when idle. That is probably a ...


6

In most cases, the RandR extension is used to configure display settings. Therefore, I will focus on it in this answer. So this answer may not apply if you're using Wayland, the proprietary NVIDIA drivers without DRM (Direct Rendering Manager) kernel mode setting enabled or have disabled the RandR extensions. If so, calling xrandr should result in an error ...


6

lsof lists any files that are in use by userspace processes. But nvidia_drm is a kernel module, so lsof won't necessarily see whether or not it is actually in use. (The module file won't be open because the kernel has already completely loaded it into RAM. But the module might be providing services to the userspace or other kernel components, and that is ...


5

As the error states, you are still running an X server. This error occurs when you try to install the Nvidia .run files while logged in. Make sure you are logged out. Hit CTRL+ALT+F1 and login using your credentials. kill your current X server session by typing sudo service lightdm stop or sudo stop lightdm Enter runlevel 3 (or 5) by typing sudo init 3 (...


5

Gaming: nvidia closed-source drivers outperform nouveau drivers. Here's a comparison between nvidia and nouveau on several nVidia GPUs, including the desktop version of your GPU: Nouveau vs. NVIDIA Linux Comparison


5

Xorg --configure while X is not running did it for me - I'm on debian Sid (unstable). You MUST NOT have X running when you do this, and must be in a console TTY. (ctrl-alt-f1/f2/f3/f4/f5/f6) If Xorg.conf doesn't change after doing this, and the program didn't return an error but printed an Xorg.conf configuration file to the screen, do Xorg --configure >...


5

you can determine the device attached to this root port with the command lspci -v -s 3.0 | grep Bus: you should see a line something like this: Bus: primary=00, secondary=04, subordinate=04, sec-latency=0 the secondary and subordinate are often the same, so you could then use the command lspci -s 4:0 to see what devices are on that bus. for my system ...


5

The module might be loaded in the initramfs on boot. You must regenerate the initramfs to include your modifications to /etc/modprobe.d/* Run the following to regenerate your initramfs dracut -f /boot/your-initramfs On reboot, the driver should not be loaded automatically


5

As seen in the QA test case, you only need to specify the DRI_PRIME=1 environment variable when launching the application, like so: [dkarlovi@amelie ~]$ glxgears -info | grep REND GL_RENDERER = Mesa DRI Intel(R) Sandybridge Mobile ^C [dkarlovi@amelie ~]$ DRI_PRIME=1 glxgears -info | grep REND GL_RENDERER = Gallium 0.4 on NVD9 ^C


Only top voted, non community-wiki answers of a minimum length are eligible