New answers tagged

1

Yes, it is possible. At least Linux allows you to run two separate networks on the same physical network. On IPv6 this is in fact standard procedure, with a global address and a link local address assigned to each node on the network. But it works using IPv4, too.


0

With a udev rule and a small script, it is possible to assign a fixed Mac Address when the usb tethering is established, as Mon Bloc-Notes explains. Find the serial of your device (in the article it is usb0, yours is eth0 if I'm not mistaken). udevadm info -a -p /sys/class/net/eth0 Create or add a new rule to /etc/udev/rules.d/90-local.rules ACTION=="add"...


1

A road junction between two roads, needs to be on both roads. They can be on the same physical network (or not). In ether case, you need a bridge/gateway/router between the two logical networks. This gateway has to be on both networks, physically and logically(so have an address on both), and configured as a router. And every device on the two networks ...


0

Can't comment, so I hope someone moves this to comments. Currently (March 2020) this solution is not possible with firejail and Wifi, see https://github.com/netblue30/firejail/issues/3000


0

For those using Centos, this will work: sudo yum install "kernel-devel-uname-r == $(uname -r)" It will find the headers for the exact version of the kernel that you're using.


0

To read the files you can use lookup plugin: vars: file_contents: "{{lookup('file', 'path/to/file.txt')}}" To restart network interface you can use service module: - name: Restart network service for vlan interface service: name: network state: restarted args: '{{ item }}' with_items: '{{ var_with_iface_list }}'


3

It all depends on your routing table. Type ip route or route -n If you have not messed up with the route, for your questions the answers would be: For 192.168.0.100, network A will be used because it is on the same subnet. For 10.31.17.25, it is impossible to tell. Routing table will tell you, which device is used as a default gateway device. Lets take ...


0

I don't think I can give you a complete answer, just something to investigate... This doesn't look to me like your configuration is being ignored, it looks like it's being overwritten by something. IPv6 addresses starting FDxx:: are local address IPs. Typically un-configured interfaces will have a link local address (beginning FE80::) as well as other ...


0

/etc/resolv.conf file is usually managed by your network manager. You can force your network manager to use specific DNS server. For example, if you have Gnome, then in gnome-control-center you can do this: The procedure will be similar for others network managers.


0

This is a Network Monitor to monitor the network traffic. The network manager applet nm-applet is provided by network-manager-gnome package: sudo apt install network-manager-gnome From the terminal: nm-applet & After installing network-manager-gnome , you will be able to add the network manager applet to your panel.


0

As Freddy mentioned in comments, ath9k does not support my device, so the solution is install ath10k driver.


0

The explanation and the solution can be found at DHCP on Server 2012 R2 does not understand Fedora 25.


-1

You can do a few things from the terminal: nm-connection-editor and add a new connection with wireless, or use nmtui for the configuration of your wireless adapter. Apart from that check whether you have such a device with nmcli dev status


0

My problem was when to tried this steps the interface name not to change. I found the problem because of it not change... I did Two mistakes; 1 - I forget to link the file, sudo /etc/udev/rules.d/70-persistent-net.rules I does it with sudo ln -s /dev/null /etc/udev/rules.d/70-net-setup-link.rules 2 - Since Ubuntu 16.04 and Linux Mint 17 on the file, ...


2

As you can see here, you should add the option macaddr in /etc/config/network in your desired interface. For example: config interface 'lan' option ifname 'eth0.1' option proto 'dhcp' option macaddr 'xx:xx:xx:xx:xx:xx' After that, restart the network service with /etc/init.d/network restart or reboot the device.


0

I know this is late, but I ran into the same issue and I solved it by using htb and tc classes. Try this: tc qdisc add dev eth0 root handle 1: htb tc class add dev eth0 parent 1: classid 1:1 htb rate 100mbit tc filter add dev eth0 parent 1: protocol ip prio 1 u32 flowid 1:1 match ip dst 192.168.0.101/32 match ip src 192.168.0.102/32 tc qdisc add dev eth0 ...


Top 50 recent answers are included