Skip to main content
1 vote
Accepted

What package do I need to install to get PDF support in the Lyx document processor?

To export as PDF, LyX uses pdflatex, which is in the texlive-latex-base package. Installing that and re-configuring LyX should enable the option.
Stephen Kitt's user avatar
1 vote

Compiling Lyx 2.2 on Debian

Per this answer from the LyX mail archive installing libqt5x11extras5-dev libqt5svg5-dev libice-dev qtbase5-dev resolved the issue for me on Ubuntu 21.04.
Rasmus's user avatar
  • 113
1 vote

Compiling Lyx 2.2 on Debian

./configure QTDIR=/usr/share/qt5 && make instead of ./configure && make worked for me
Andrea Araldo's user avatar
1 vote
Accepted

Compiling Lyx 2.2 on Debian

QTDIR shouldn't really be necessary, but try setting it to /usr/share/qt5. You could build the Debian source package instead: sudo apt-get install devscripts dpkg-dev build-essential sudo apt-get ...
Stephen Kitt's user avatar

Only top scored, non community-wiki answers of a minimum length are eligible