New answers tagged

0

Identified this as an issue with the ISO itself. Downloaded latest ISO & tested for a month. So far no issues.


1

It’s up to you to create the group and set it up for KVM. sudo addgroup kvm will create the group, sudo adduser ${USER} kvm will add you to the group, and creating a file in /etc/udev/rules.d containing KERNEL=="kvm", GROUP="kvm", MODE="0660" will ensure that members of the kvm group can access the KVM device node. (Name the file 40-permissions.rules ...


1

If you choose not to run virt-install with sudo then you have to specify a connection string to use the system libvirtd instance, rather than creating a VM under your user account. virt-install --connect qemu:///system ... or sudo virt-install ...


1

Edit your QEMU.xml to use the Intel HD audio adapter to work around bug #761031. Open Boxes, perform a full shut down of the virtual machine, and note the auto-assigned name given to the virtual machine. Open up the Terminal and type EDITOR=gedit virsh edit YOURBOXNAME. If you’ve modified the name after installing, you can find the file in ~/.config/...


1

This worked for me: Once you are are in emergency mode run xfs_repair -L /dev/dm-0 && reboot Log in and in a terminal run sudo xfs_fsr /dev/mapper/centos-root sudo xfs_fsr /dev/dm-0 reboot Not 100% sure what the issue is but all my centOS VMs regardless of version does this. I was working on this issue for a week.


0

The 2d graphics performance was substantially improved when I moved the qcow2 disk image to an SSD. I moved it back to HDD and it was slow again. Tested with other Android-x86 installations as well (both 32-bit and 64-bit). Confirmed. No clue why.


1

What eventually solved the problem was running dhclient ens3 on a guest. Now working on assigning static ip address to the guest, will update the answer later. Update. To assign static ip on Ubuntu 18.04, you need to edit /etc/netplan/[file that's there] to look something like this: network: version: 2 ethernets: ens3: dhcp4: ...


1

To see which kernel modules are loaded use the lsmod command. You can use grep to pipe the output of lsmod to filter something more desirable. e.g. # lsmod | grep net vhost_net 24576 10 vhost 45056 1 vhost_net tap 24576 1 vhost_net This host is using vhost_net kernel module - I happen to have 10 ...


0

I just solved same problem on Debian Buster. Apparmor was denying access to my compiled qemu binary. You can check if apparmor is enabled on your system using command: sudo aa-status If your output contains following lines then apparmor is surely enabled and needs to be configured to allow access to your compiled binary: ... 22 profiles are in enforce ...


1

When you installed the libvirt service, there will create the virbr0 automatically, it is a virtual network switch. all the virtual machines will connect to the virbr0. by default, virbr0 use NAT mode, can provide Internet access by NAT mode. by default, virbr0 assigned address 192.168.122.1, and it can provide DHCP service for other virtual interface who ...


0

On Debian Stretch: systemctl restart libvirtd didn't do the job. Libvirt actually restarted its service but all qemu processes and the OS's inside kept running. This worked: systemctl stop libvirt-guests # stops VMs systemctl restart libvirtd # starts VMs agains


1

/dev/sdc1 : start= 63, size= 92164842, Id=83 /dev/sdc2 : start= 0, size= 0, Id= 0 /dev/sdc3 : start= 0, size= 0, Id= 0 /dev/sdc4 : start= 92164905, size=884603160, Id= 5 /dev/sdc5 : start= 92164968, size= 33559722, Id=82 /dev/sdc6 : start=125724753, size=851043312, Id=83 Try this: $ dd if=/dev/null of=disk.img seek=$((...


0

Alternative # Using a named pipeline # Step 1. qemu configuration $ qemu-system-x86_64 \ -some options like above \ -serial pipe:/tmp/guest # Step 2. To get a log $ mkfifo /tmp/guest.in /tmp/guest.out $ cat /tmp/guest.out $ printf "id\n" > /tmp/guest.in $ printf "pw\n" > /tmp/guest.in $ printf "cmd\n" > /tmp/guest.in Link


0

The problem seems to be that the End of Interrupt isn't communicated properly. For libvirt, make sure eoi is enabled: <domain> … <features> <apic eoi='on'/> … On the command line for KVM that translates to -cpu …,+kvm_pv_eoi This seems to work for us with -M q35, host cpu passthrough and default config otherwise (RTC ...


Top 50 recent answers are included