New answers tagged

0

modprobe --remove-dependencies -f btbcm should remove the dependencies. -D just lists the dependencies of btbcm, not the modules using it.


0

A possible fix to get rid of the boot errors is blacklisting mt76x2u kernel module. For that you can add /etc/modprobe.d/no-xbox-wireless-adapter.conf file with the following contents: # Blacklisting mt76x2u because it gives errors on boot. # mt76x2u is used by Xbox Wireless Adapter. blacklist mt76x2u Then you need to regenerate initramfs to generated new ...


3

I had to do this for an assignment, so I figure I'll share my solution here. The base WSL2 kernel does not allow modules to be loaded. You have to compile and use your own kernel build. How to build and use a kernel in WSL2: sudo git clone https://github.com/microsoft/WSL2-Linux-Kernel.git sudo apt install build-essential flex bison libssl-dev libelf-dev ...


0

Check your WiFi MTU, using ip link also notice your WiFi interface's name. The MTU (Maximum Transmission Unit) is the size of the largest packet that can be sent in a single network transmission. If a packet exceeds the MTU of a link, the data must be split into multiple packets (fragmented). These multiple packets must be sent over the link, received, ...


1

Your module isn’t reporting the address of the probe point, but its hash: %p outputs a hashed address to prevent leaking information about the kernel memory layout To see the actual address, use %pK or %px.


4

You can add a configuration file /etc/modprobe.d/vboxdrv-includes-vfat.conf with a "soft dependency" command: softdep vboxdrv post: vfat The man page modprobe.d(5) documents the syntax: softdep modulename pre: modules... post: modules... The softdep command allows you to specify soft, or optional, module dependencies. modulename can be used ...


3

You could append one line defining such a dependency to modules.dep echo "${module1}: ${module2}" >> "/lib/modules/$(uname -r)/modules.dep" (Note: running depmod later may destroy your change, and you'll have to reapply) Reference: https://linux.die.net/man/5/modules.dep


0

i've solved this issue and managed to map PCI memory to userspace via the driver. I've changed the pfn input of the remap_pfn_range function I was using in my custom .mmap The original was: io_remap_pfn_range(vma, vma->vm_start, pfn, vma->vm_end - vma->vm_start, vma->vm_page_prot )) where the pfn was the result of the buffer pointer return from ...


1

Thanks to the comments I was able to find a solution. update-initramfs -v -u This updates the archived kernel modules, the -v is for the verbose option. Takes a few seconds but once done, I can restart my OS and my new driver gets called right away, instead of the older archived version :).


Top 50 recent answers are included