Hot answers tagged

9

As of 1.5.11, IBus uses dconf. Here is (a snip of) its configuration obtained by: dconf dump /desktop/ibus/ [general] use-system-keyboard-layout=false preload-engines-inited=true embed-preedit-text=false use-global-engine=true version='1.5.11' engines-order=['xkb:us::eng', 'hangul', 'sunpinyin', 'm17n:ru:kbd'] preload-engines=['xkb:us::eng', 'm17n:ru:kbd', '...


5

For newer versions see Koterpillar's answer. IIRC ibus uses gconf to store its settings so you should be able to use either gconf-editor or gconftool (CLI) to get/set those settings.


2

If you run ibus-setup and check "use system layout" (if I remember correctly), it will not override the system settings. You mentioned that xmodmap is obsolete, but you may still be able to use it. You can also use setxkbmap or xkbcomp, which are not obsolete.


2

You can configure and use the composeKey: Under gnome Desktop : From the system settings choose keyboard >> keyboard layouts >> option then Select position of compose key extend it and choose (eg: Caps Lock) To get the accented character press : [composeKey] + [accent character] + [letter] e,g: Caps Lock + " + o = ö Caps Lock + " + u = ü Caps ...


2

You need ibus-anthy and ibus-unikey for those two languages so: yum install ibus-anthy ibus-unikey To set IBUS up follow these Fedora 17 guides (it should be pretty much the same thing in Fedora 18): japanese , vietnamese.


1

Under Fedora 30 (Gnome 3.30, X11), reloading Gnome Shell seems to work for me: Launch quick run with <Alt> + <F2> Type r then <Enter> Wait for the shell to reload Somehow it even makes things work in some already running programs, which makes no sense to me...


1

You can't map a key to a special character in a font. Input doesn't know anything about font, only characters. Most characters are present in Unicode, and you can set a compose combination to any Unicode character. In ~/.XCompose, you can either put the character in quotes or write the hexadecimal code for the character with U before it: <Multi_key> &...


1

Inspired by the Arch wiki, I added export QT_IM_MODULE=ibus to ~/.xprofile, which fixed it. I was initially thrown, because "normal" ibus input worked without this fix. In any case, I've edited the wiki to be a little clearer.


1

In Centos 7 you can select alternative input methods from a GUI using im-chooseror from the command line with imsettings-list to show available input settings and imsettings-switch to switch between them.


1

While in the middle of posting this question, I found the answer haha. I first entered the following into a terminal: $ ibus engine xkb:us::eng I then got the list of engines to find what I needed to change it to (output cropped for brevity): $ ibus list-engine language: Estonian xkb:ee::est - Estonian language: Slovak xkb:sk:qwerty:slo - Slovak (...


1

Press CTRL+ALT+F1 and login w/o a graphical interface to your system. Then reinstall/delete or w/e causes the problem (check logs files).


1

SuperMagic provided the correct answer in a comment: I've never seen this behavior, but there does appear to be a predictive spelling package ibus-typing-booster installed perhaps by default. My installation had no config for this, so it does nothing. Try removing it (there appear to be no dependent packages) and see if that fixes it. This is ...


Only top voted, non community-wiki answers of a minimum length are eligible