50

ssh -D 8080 name@myserver.com export http_proxy=socks5://127.0.0.1:8080 https_proxy=socks5://127.0.0.1:8080 youtube-dl "youtube.com/watch?V=3XjwiV-6_CA"


43

You're looking at it the wrong way. The no_proxy environment variable lists the domain suffixes, not the prefixes. From the documentation: no_proxy: This variable should contain a comma-separated list of domain extensions proxy should not be used for. So for IPs, you have two options: 1) Add each IP in full: printf -v no_proxy '%s,' 10.1.{1..255}.{1.....


42

What is possible depends on what the firewall allows. If the firewall allows arbitrary traffic on port 443 Some firewalls take the simple way out and allow anything on port 443. If that's the case, the easiest way to reach your home server is to make it listen to SSH connections on port 443. If your machine is directly connected to the Internet, simply add ...


27

There is no central authority who assigns an official meaning to environment variables before applications can use them. POSIX defines the meaning of some variables (PATH, TERM, …) and lists several more in a non-normative way as being in common use, all of them in uppercase. http_proxy and friends isn't one of them. Unlike basically all conventional ...


18

info wget says: `no_proxy' This variable should contain a comma-separated list of domain extensions proxy should _not_ be used for. For instance, if the value of `no_proxy' is `.mit.edu', proxy will not be used to retrieve documents from MIT. So the variable should contain a list of domains, not IP ranges. You'll need to set up proper ...


17

Youtube-dl doesn't support a SOCKS proxy. There's a feature request for it, with links to a couple of working proposals. Youtube-dl supports HTTP proxies out of the box. To benefit from this support, you'll need to run a proxy on myserver.com. Pretty much any lightweight proxy will do, for example tinyproxy. The proxy only needs to listen to local ...


12

Not exactly a correct solution but it might solve the problem for you. If you assume that accessing anything from the outside of the proxy will be using DNS-names and not directly using IP-addresses, you can set it like: export no_proxy=0,1,2,3,4,5,6,7,8,9 As far as I know, no top domain ends with a number so if it does, it must be an IP-address.


12

Here's a slightly simpler (one-line) approach based on janmoesen's solution. export no_proxy=`echo 10.1.1.{1..255} | sed 's/ /,/g'` which has been further improved based on Cory Ringdahl's input: export no_proxy="`echo 10.1.1.{1..254},` 10.1.1.255" sed chokes on all the arguments passed from the expansion of 10.1.{1..255}.{1..255}, either in his code ...


11

As mentioned previously this is not really load balancing, but it's possible. Try something like: frontend http-in bind *:80 # urls acl host_foo hdr(host) -i www.foo.com acl host_bar hdr(host) -i www.bar.com acl host_zoo hdr(host) -i www.zoo.com # clusters use_backend foo_cluster if host_foo use_backend bar_cluster if ...


9

I would advise to use a solid proxying tool for all (or most) of your proxy needs. $ proxychains4 yaourt -S application proxychains-ng works well - but be sure to configure proxychains.conf before using.


8

cntlm provides a solution, along with some configuration. The basic steps to follow are: Install cntlm. Edit its configuration file at /etc/cntlm.conf, the comments included makes it easy enough. Add a proxy server (or two). Specify your user name and NT domain name in the appropriate places, and remove the password entry. Start the cntlm service, eg via ...


8

1) Squid is a special proxy for http and https traffic. As it knows this protocol it can offer some advanced features like caching, filtering, rewrite rules, dns resolving. All web browsers know how to handle http proxies as it's part of that protocol spec. Additionally Squid can act as a transparent proxy where you don't configure your web browser to use ...


8

I've found a solution: adding openssl enc -aes-128-cbc -a -d to the mix. However, as mentioned in the accepted answer, this option is probably not very secure. First, put the username password combo (or base64 encoded equivalent) into here, echo "<put it here>" | openssl enc -aes-128-cbc -a It will prompt for a password twice. This password is the ...


7

There is no standard and both uppercase and lowercase versions are used depending on the application (also see HTTPS_PROXY, ALL_PROXY, NO_PROXY). For example: curl ENVIRONMENT VARIABLES Curl reads and understands the following environment variables: http_proxy, HTTPS_PROXY, FTP_PROXY They should be set for protocol-specific proxies. General ...


7

You can edit /etc/sudoers with the visudo command and add this line Defaults env_keep += "http_proxy https_proxy ftp_proxy" This pass the current user environment variables to the command excecuted under sudo, is the same as sudo -E some_command but automatically, you need this because yaourt internally uses sudo pacman and not sudo -E pacman This is the ...


7

Using base64 is useless, it's just a simple transformation. Using encryption with a key that's stored alongside the encrypted data is also useless because it's still just a simple transformation. If you're worried about someone getting access to your configuration files, then you need to encrypt with a key that isn't in your configuration files, and that ...


7

You can use lsof to find out the list of processes runing on 8080 lsof -i :8080 You can get more detail about the process throught : ps -ef | grep put_the _PID_here


6

No. /etc/hosts is used to modify the "hostname -> IP address" mapping. It can not be used for "protocol layer" filtering. If you want to limit specific pages then you need to use something like a proxy server. This can be programmed with specific rules to permit/deny certain pages. Then configure your browser to use that proxy. A simple example of ...


5

youtube-dl works well with proxychains on ubuntu. Make sure ur tunneling via command line. ssh -D 8081 ubuntu@yourSSHserver next install proxychains on your localhost not the ssh server ur conncted to. sudo apt-get install proxychains edit your proxychains config file sudo nano /etc/proxychains.conf edit the port number on the last line socks4 127....


4

Not having root privileges prevents you from listening on ports below 1024 on typical Linux systems. Thus, Squid should work OK as non-root listening on 8080 as long as the system you are on hasn't blocked incoming traffic on that port via a firewall or iptables. Not sure how many file descriptors Squid uses typically but if your admin has set a limit for ...


4

Edit "/etc/apt/apt.conf" and add below entry: Acquire::http::Proxy "http://username:password@proxyhost:port/"; Reference Link


4

If you do— $ sudo netstat -lnp | grep :8080 you'll get something like tcp 0 0 192.168.0.1:8080 0.0.0.0:* LISTEN 12345/processname The number before processname is the PID of the process listening on that port.


4

It's a known bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1177909. Currently nobody is working on it.


4

Could you try to add an additional slash at the end of you ProxyPass, like: ProxyPass http://127.0.0.1:8080/ ?


3

It seems to be related with environment variables. If you set the proxy in your profile (as environment variables), then probably when issuing sudo, these variables don't get loaded. If you succeed doing so with su, then probably you're using su - (that's the way to load the environment variables of root). To get loaded these variables (for a normal user) ...


3

To enable logging, the manual states that: 2.1.3 Logging When it encounters a difficulty, Polipo will print a friendly message. The location where these messages go is controlled by the configuration variables logFile and logSyslog. If logSyslog is true, error messages go to the system log facility given by logFacility. If logFile is set, it ...


3

Unfortunately, the impression I get (from the DD-WRT forums) is that you can only block domains under Access Restrictions in the DD-WRT setup. I've decided instead to set up a dedicated proxy server with DansGuardian installed on it, which will allow me a fine level of control, and block any requests that don't go through the proxy on the router using ...


3

I had the same issue, here's what worked for me: Open the global proxy configuration file /etc/syconfig/proxy and add the following line: HTTP_PROXY="http://myusername:mypassword@myproxy.example.com:8080" Source: https://www.claudiokuenzler.com/blog/515/use-opensuse-zypper-behind-with-http-proxy-authenticiation#.WYnT92fwvIU EDIT: UPDATE You also need to ...


3

Did you try the following syntax ? http_proxy=http://address:port/ wget --proxy-user=USERNAME --proxy-password=PASSWORD http://url


3

I use this tool, which is basically a couple of scripts to configure settings for different applications from single point. PS: I wrote and maintain that tool.


Only top voted, non community-wiki answers of a minimum length are eligible