New answers tagged

0

There are various things that are able to cause this kind of kernel panic. Since you are using grub2, I strongly suggest you run the grub shell commands manually(You can always refer to commands in your /boot/grub/grub.cfg file) Typically, you have commands like this: set prefix=... set root=... # you can test if values above are set correctly ...


0

To insatll grub on a GUID Partition Table with bios mode you need to create a bios_boot partition. GUID Partition Table (GPT) specific instructions On a BIOS/GPT configuration, a BIOS boot partition is required. GRUB embeds its core.img into this partition. The BIOS boot partition is only needed by GRUB on a BIOS/GPT setup


1

I went to the UEFI Settings and then Boot → UEFI Hard Disk Drive BBS Priorities. It had "Windows Boot ..." as the top priority. I changed it to "opensuse-secureboot". Then I went back to the general boot order and moved "UEFI Hard Disk:opensuse-secureboot" to the top. I now am presented an OpenSuse-themed menu upon boot where I can choose between OpenSuse ...


0

something like "v-fat" This must be the ESP I mention below! The way you describe it, now, after reading again. I think Johan is pointing in the right direction. In the BIOS menu you can choose between "legacy bios" (=MBR) and "UEFI". You can even activate both at the same time. But that alone won't be enough. When you "create a GPT" (simply or not) ...


1

It seems like this is a feature of KDE. It'll restart applications that were previously open in the last session. Go to: System Settings > Startup and Shutdown > Session Management and select something other than "Restore previous session". You'll probably want to re-enable hibernation.


0

While 3 will work as a backwards compatibility (and easier to remember) method to get to text-only mode, the "correct" way to do it is to append rd.systemd.unit=multi-user.target Note that this is different than what @stephen-harris mentioned above (missing the rd. which is required in for the initrd). This is useful in case you are testing customer ...


0

Well to my surprise I found that running: grub-mkconfig -o /boot/grub/grub.cfg before running update-grub fixed the problem I had. This seems inexplicable since it seems that update-grub looks as though it is calling grub-mkconfig. Anyway now my edits to 40_custom etc are being picked up. Thanks to all for helpful responses.


0

You can add a custom menu to /etc/grub.d/40_custom, it will be added to /boot/grub/grub.cfg file after update-grub. explained here : Configuring GRUB v2: The configuration file is /boot/grub/grub.cfg, but you shouldn't edit it directly. This file is generated by grub v2's update-grub(8), based on: The script snippets in /etc/grub.d/ The ...


2

update-grub uses grub.cfg - it re-generates it. To the regeneration, it uses list of your kernel/initrd images in /boot configuration in /etc/default/grub and the configuration generator scripts in /etc/grub.d. To change grub.cfg permanently, you can do one of these: Not using update-grub any more (painful) Editing the files/configs above (need a little ...


0

You can edit the /boot/grub/grub.cfg by hand. It is a normal text file. Remove the entries you do not want. Be sure you pick the grub.cfg on the partition you had mounted when you ran update-grub.


0

If you can gain access to a system's console there almost no limit to what you can do to the system if the system does not have full disk encryption (and even then there are other things to be concerned about, bios for example). Situations where someone can access the console (like accessing the grub boot loader) or access the hardware requires different ...


0

after researching from various different sources, I managed to learn a bit about the boot process, the BCD store and grub. I found a solution. I learned that grub mbr, the sort of stage 1 grub was installed on the main internal disk (C:). however stage 2 was written on the external one (say E:). Grub was unable to find its stage 2 when E was disconnected ...


0

Make sure you change the default UEFI boot entry from Windows Boot Manager to kali, either permanently in the BIOS boot preferences or manually via a BIOS hotkey like F10 or F12 (depends on the manufacturer) on startup. With grub, you should be able to boot both OSes.


0

If you don't know how to do what you want to do, Kali is most probably not the Linux distribution you are looking for. Usually Kali is used as an image stored on an external device that you use to boot your machine or as a virtual machine you start from your main OS (you can use Virtualbox which is free). Be it as it may be, if you still want to continue ...


0

Nothing you do in installed software should ever prevent you from getting into the bios menu except flashing the bios. Hard power off your machine (usually press and hold the power button for up to 10 seconds). Your bios will be accessable when you next power on. What you've done is a common mistake, grub will not work if you remove /boot/grub which by ...


Top 50 recent answers are included