42

To plagiarize myself, you can set up a profile with your desired settings (instructions adapted from here): Run terminator and set up the layout you want. You can use Ctrl+Shift+E to split windows vertically and Ctrl+Shift+O (that's O as in oodles, not zero) to split horizontally. For this example, I have created a layout with 6 panes: Right click on the ...


24

It's the (awkward) shift+middle-click combo that brings up Terminator context menu for me when putty_paste_style = True. This is in contrast to the docs, both the terminator_config manpage and the online manual, which state middle-click alone will bring up the Context Menu. $ terminator --version terminator 1.91 $ cat /etc/lsb-release DISTRIB_ID=Ubuntu ...


13

After spending a decent amount of time looking around, I finally found two solutions starting with the best one mentioned first. I present them for the sake of completeness: One has to make sure to have the following line in the terminator configuration file: always_split_with_profile = True under the [global_config] section. The same issue was brought up ...


10

I was able to use CTRLSHIFTC and CTRLSHIFTV for Copy-and-Paste with XTerm by adding XTerm*vt100.translations: #override \ Shift Ctrl <Key> C: copy-selection(CLIPBOARD) \n\ Shift Ctrl <Key> V: insert-selection(CLIPBOARD) to my ~/.Xresources and reloading it with xrdb -merge ~/.Xresources. Documentation of this feature can be found in ...


10

Terminator doesn't support this. In fact, Terminator, such as many other terminal emulators (e.g. gnome-terminal, xfce4-terminal, mate-terminal, roxterm, sakura, tilda...) uses the VTE widget for terminal emulation and the VTE widget does not support this. You might want to take a look at how fonts are defined, and whether you can take an existing font and ...


10

In zsh, you don't need to hardcode escape sequences as it has several builtin ways to set the background and foreground colours. You can use echoti setaf to set the terminal ansi foreground colour and echoti setab to set the background one (setaf and setab being the names of the corresponding terminfo capabilities) Assuming your terminal supports 256 colours ...


7

Looking at ~/.config/terminator/config, for some reason it was using <Primary> instead of <Ctrl>. After deleting the keybindings section, the original shortcut Shift+Ctrl+I for new window works.


7

If you are using Terminator then Ctrl-Shift-F allows you to search in the scrollback buffer without needing to run screen or tmux


7

Why not just apt-get install xfonts-terminus ? The Terminus fonts are already available pre-packaged for Mint, see xfonts-terminus


6

Run cd /home/downloads; exec bash as the custom command. (The exec builtin ensures that bash will be a child of the terminal emulator; without it, it might end up being a grandchild.) You can run terminator -e 'cd /home/downloads; exec bash' on the command line. You can't use aliases in the custom command because your aliases are defined by ~/.bashrc, but ...


6

Have you tried purging the package and then reinstalling it? apt-get purge terminator Then delete configuration files located in your home directory rm -rfvI /home/your_user_name/.config/terminator This should remove all the config files. Now reinstall. apt-get install terminator


6

printf "\033[48;5;226mhello\e[m\n" printf "\033[48;2;255;255;0mhello\e[m\n" The more standard variant of the second (RGB) form (which includes an unused "color space identifier" after the 2) is not supported in older versions of the VTE library (as e.g. libvte-2.91 used by Terminator 1.91 on Debian 10).


5

Are you searching for terminal multiplexer tmux. https://github.com/tmux/tmux


5

Confusingly there are two terminal emulators out there called Terminator. One is a Java-based, the other is based on Gtk+ and is suited for the GNOME desktop (sometimes this one is also referred to as gnome-terminator). Your link and the tag applied to the question contradicts as for which one you're referring to. I'll be talking about "gnome-terminator" ...


5

This is what the script tool is for. It will save an entire terminal session - inputs and outputs: $ script sessionlog.txt [ do stuff ] $ exit $ ls sessionlog.txt


5

Titles can be set using Window title: Ctrl+Alt+W Tab title: Ctrl+Alt+A Terminal title: Ctrl+Alt+X more info: https://terminator-gtk3.readthedocs.io/en/latest/gettingstarted.html#setting-titles note: you may run into issues with Ctrl+Alt+A hiding the window instead. Right click inside the terminal and go to preferences>keybindings and change hide_window ...


4

Back when I was using terminator this is the rc file that I used to open a bunch of terminals and run applications. Save it to .config/terminator/config. [global_config] title_hide_sizetext = True enabled_plugins = LaunchpadCodeURLHandler, APTURLHandler, LaunchpadBugURLHandler [keybindings] [profiles] [[default]] font = DejaVu Sans Mono 9 ...


4

I still want to know why my locale settings got so weird after only enabling the en_US locales during installation, but I was able to resolve the issue by adding export LC_ALL=en_US.UTF-8 export LANG=en_us.UTF-8 to my ~/.bashrc


4

I ran into the same problem and worked around it by installing the version of psutil listed in the error. sudo pip install psutil==2.2.1


4

You virtually answered your own question. Just run: terminator --command='/bin/zsh -o ignoreeof' See: info zsh Invocation for details on how to invoke zsh.


4

Sounds like mismatched UTF-8 settings between your terminal and the application locale. The section sign isn't part of the ASCII character set, so it's represented as two bytes in UTF-8. Your terminal probably sends it as such, but the application side doesn't realise it's supposed to represent just one character and prints as only one. The command line ...


3

I had the same problem for activating virtual environments with Terminator. The trick is to do everything with just "one" command: bash. Taking advantage of its -i option (interactive) and using a custom --rcfile in which PROMPT_COMMAND is set to whatever we want to execute. The result would be like this: command = "bash --rcfile <(cat ${HOME}/.bashrc; ...


3

Try this patch. I found it on the bug report @Sparhawk provided and the user said it worked. I assume you know how to use the patch command. It also worked for me. (I have the same issue.) Click here for a comprehensive patch manual. === modified file 'terminatorlib/window.py' --- terminatorlib/window.py 2011-08-22 20:05:38 +0000 +++ terminatorlib/window....


3

I suspect that you may not get this to work as I doubt that Terminator will accept synthetic events and I don't think that multiple terminal per window model is compatible, but If you want to try the best source is the README.Debian.gz from the debian package. I have included the relevant portion below, but It would probably be much simpler to just use ...


3

Given your description of the symptoms, you've evidently installed node in a location which is not on your system's default command search path. There's nothing wrong with that, you just need to add that location to the PATH environment variable. That's what you did wrong: you did that in the wrong file. Unfortunately, a lot of tutorials tell you to set ...


3

I encountered a problem similar to the OPs issue (the OP tries unsuccessfully to run the npm start command in a Terminator Custom Command) when I attempted to run jupyter notebook in a Terminator Custom Command. After some additional googling I started to think that probably this had to do with my ~/.bashrc not being loaded by Terminator on building the ...


3

Simply add --new-tab switch to the configured keyboard shortcut : terminator --new-tab


3

As I already mentioned in the comment, at this moment the terminator package is not available in the EPEL8 repository. However, for what I can see in this ticket request, there are some effort to add the last version of terminator to EPEL8 repository. In the comments we can see that mattrose worked on a python3 terminator version. I did a few tests of his ...


3

The direct colour and indexed colour ITU T.416 control sequences for foreground are SGR 38:2 and SGR 38:5. The control sequences for background are similarly SGR 48:2 and SGR 48:5. Read § 13.1.8 of ITU T.416. % TERM=rxvt-256color setterm -7 --background "137" | hexdump -C 00000000 1b 5b 34 38 3b 35 3b 31 33 37 6d |.[48;5;137m| 0000000b % If ...


2

I am using MC 4.8 and the following works for that version: create a ~/.config/mc/skins directory copy (or link) the .ini file defining the skin into ~/.config/mc/skins edit .config/mc/ini adding a line containing skin=solarized to the section Midnight-Commander.


Only top voted, non community-wiki answers of a minimum length are eligible