Hot answers tagged

8

I have just successfully formatted a completely blank floppy in a USB drive. This required a proper format, and not just writing a filesystem to the disk, because there were no sectors on it yet. This is done with the ufiformat program, which is specifically designed to work with USB floppy drives. $ sudo ufiformat -f 1440 -v /dev/sdd format on device=/...


7

A floppy device file is a file. Any command that reads files will work on it. cmp /dev/fd0 image.fat Pass the -l option if you want a list of all differing bytes; for human consumption, this is mostly useful in the form cmp -l /dev/fd0 image.fat | wc -l to know how many bytes differ. Run cmp -s /dev/fd0 image.fat if you don't want any output, just a ...


7

If the floppy drive is not in use anyway, the better solution may well be to simply disable the floppy module. You can do this as follows: echo blacklist floppy > /etc/modprobe.d/00-disablefloppy.conf


5

As no formatting program seems to exist, I wrote the following shell script which sends appropriate FORMAT UNIT commands to format all 80 tracks of a floppy disk. The device da0 is formatted unless a different device is supplied as an argument. The CDB has been taken from the UFI specification. #!/bin/sh set -e exec >&2 drive=${1:-da0} numblocks=...


3

(This is from memory — I haven't had a floppy drive in nearly two decades.) After formatting a floppy, it doesn't have a filesystem on it — so you need to create one before mounting it. E.g., to put a FAT filesystem on it, you'd do mkfs.vfat /dev/fd0 (plus any options for label, etc.) Or you could put ext2 on it with mkfs.ext2 /dev/fd0; ext3/4 is likely not ...


3

After I tried all your suggestions yesterday, I finally found an entry in my BIOS, which said: Floppy Legacy: Disabled. Changed it to 1.44 MB, now everything is fine.


3

sudo gedit /lib/udev/rules.d/80-udisks.rules (in my Xubuntu 16.04 - 80-udisks2.rules) search strings and replace them with 0 to 1 # PC floppy drives # KERNEL=="fd*", ENV{ID_DRIVE_FLOPPY}="0" # USB floppy drives # SUBSYSTEMS=="usb", ATTRS{bInterfaceClass}=="08", ATTRS{bInterfaceSubClass}=="04", ENV{ID_DRIVE_FLOPPY}="0" Create folger sudo mkdir /...


2

Current Debian kernels do still provide the floppy driver, and find /lib/modules -name floppy.ko should show where it lives on disk. find /lib/modules/$(uname -r) -name floppy.ko will determine whether the currently installed version of the currently-running kernel is built with the floppy driver as a module. To determine whether it’s installed in the ...


2

Unload the floppy device driver and blacklist it: modprobe -r floppy echo "blacklist floppy" >/etc/modprobe.d/no-floppy.conf depmod If something keeps polling /dev/fd0, you may have to try the first command a few times, or perhaps use fuser -c /dev/fd0 to determine the process accessing the floppy device, and temporarily stop it while you remove the ...


2

Another option is to use superformat, which will format the floppy and create a DOS file system with the appropriate parameters (using mtools’ mformat); for example, superformat /dev/fd0 hd to format a 1440K disk. However even fdformat should be able to verify your formatted floppy without problem, so there’s something else wrong somewhere...


2

I was able to disable floppy module from loading by adding this two files: /etc/dracut.conf.d/nofloppy.conf omit_drivers+="floppy" and /etc/modprobe.d/nofloppy.conf blacklist floppy


1

Not elegant, but you can disable it with a kernel line boot option modprobe.blacklist=floppy in either your grub append line or extlinux.conf append line


1

IIRC, the contents of disks 2-13 are entirely package (.cab) files. Disk 1 will have some cab files as well, but it's mostly the OS kernel and installer program. What I would do is try to expand the size of disk 1 (possibly using gparted?), then copy the .cab files from each of disks 2-13 into the newly embiggened disk 1. I believe there is also an index ...


1

I did the recompile for a Fedora 23 environment facing the same problem. But to be exact: Your problem is not the missing EXT or XIA filesystem which are both handled by the configure script (opting it out, if the current environment does not have it), but the fdmount command expects EXT2 filesystem to be present and therefore demands the corresponding ...


1

Your title states you're using fedora. Yet, you're using apt. That isn't possible, dnf is the package manager. You could do this: yum install e2fsprogs-devel But it does not have ext_fs.h. It's not clear what you're trying to achieve and I'm assuming the software hasn't been updated in ages. No guarantees that installing that package will yield the ...


1

Remove the line from /etc/fstab and the gui will correctly mount it. If you also want to be able to mount it from the command line, then add the "user" option to the options list.


1

Are you sure about your figure? I was thinking that a 1.44MB floppy was a disk composed by 80 tracks, each track containing 18 sectors of 512 bytes and that you can write on the two sides. The 1.2MB got only 15 tracks. So based on this logic, you have (80 * 18 * 2) == 2880 sectors on 1.44MB floppy and (80 * 15 * 2) == 2400 on 1.2MB floppy. I'm not sure if ...


1

Try: fdformat /dev/fd0u720 mkfs.msdos /dev/fd0 after creating a symlink from /dev/sdh to /dev/fd0


1

I think you need PXE installation (boot using network) for it. For that you need to setup PXE server on some other system/laptop. Refer my answer for more information about PXE Configuration.


1

The key here is that if each drive can read its own disks, but not disks from the other drive, then one or both of them has misaligned heads. This is a very common problem with floppy drives, especially if they've been dropped. Essentially it means that one drive is writing the data in the wrong spot, so other drives can't read it. As the same heads are ...


1

Because a floppy device is effectively seen as a file, you can also compare hashes (like SHA1 or MD5) of the floppy device (/dev/fd0) and of the disk image.


Only top voted, non community-wiki answers of a minimum length are eligible