New answers tagged

0

You can use the 'ping' command to check the values added in /etc/hosts are working fine or not. echo "1.1.1.1 abc.com" >> /etc/hosts ping abc.com


4

There are three ways to get mail out of php. mail() speaking to /usr/lib/sendmail or similar mail() speaking SMTP to a MTA (mainly used on windows) phpmailer which is a PHP object that speaks SMTP directly, and similar TCP enabled PHP code The 3 options you list are all variants option 1. Postfix and ssmtp both provide a sendmail binary which php calls ...


2

The solution I found was to add dns=dnsmasq in the [main] section of /etc/NetworkManager/NetworkManager.conf


0

Both packages’ descriptions follow a typical format used for related packages: they share a common section, The Berkeley Internet Name Domain (BIND) implements an Internet domain name server. BIND is the most widely-used name server software on the Internet, and is supported by the Internet Software Consortium, www.isc.org. and a package-specific ...


0

nptd The quote mentions ntpd, the reference NTP daemon. The full message includes a list of if-up.d script hooks in Debian. There is no hook script for ntpd (nor chrony). The only NTP-related scripts are for ntpdate and openntpd. If ntpd does not receive a response from a server, I believe it will resend a packet 64 seconds later. What is the minimum ...


0

You have a typo in /etc/bind/named.conf.local where you're missing a leading / from the database path: file "etc/bind/zones/db.example.home.local";


2

According to the fr. zone, creation-site-pro.fr has two nameservers creation-site-pro.fr. 172800 IN NS ns.xzave.net. creation-site-pro.fr. 172800 IN NS ns.kimsufi.com. Of these two, ns.xzave.net. doesn't exist (xzave.net. isn't even a registered domain) and ns.kimsufi.com. seems to be refusing queries. While your Debian server might be ...


1

As Stephen Kitt wrote that these packages have different descriptions: libbind9-161: This package delivers the libbind9 shared library used by BIND's daemons and clients. libdns1104: This package delivers the libdns shared library used by BIND's daemons and clients. You can always recheck what is inside a deb package. libbind9-161 package ships libbind9....


0

I solved the email issue by Configuring Postfix to not use ipv6. belos is way to do that. add below line in your /etc/postfix/main.cf inet_protocols = ipv4 and restart postfix using below command systemctl restart postfix i find above solution at below thread https://www.virtualmin.com/node/53447


2

Squid is not a DNS proxy and does not accept DNS requests. Looking at the documentation for the directives you highlight it's quite clear these are for internal settings and have nothing to do with external client access: positive_dns_ttl negative_dns_ttl dns_nameservers udp_incoming_address In explicit response to your last sentence/question, there are ...


3

As for using aplicational timeouts in some utilities, when there are connectivity issues, it is not always guaranteed the application will stop on it's own with some outside "coercion". I would use an external utility to kill it after some time just in case, for the problematic situations where it hangs. As in: timeout 5 dig +short +time=5 +tries=1 myip....


0

If you care about a particular name being associated to a particular IP address, then there are two options: either do it manually, or if you're using DHCP to assign IP addresses, configure dynamic DNS updates, and let either the clients themselves, or perhaps more securely, the DHCP server, update the DNS information automatically as the clients renew their ...


0

I got the same issue and fixed it by running sudo dpkg-reconfigure resolvconf and reboot source: https://askubuntu.com/questions/784994/resolv-conf-did-not-reset-after-vpn-disconnection


2

Bind is the service responsible for reverse lookup, so that's where you have to go looking first. You mention 192.168.21.0/20, but that actually covers 192.168.16.0-192.168.31.255 and since you say you have a 21.168.192.in-arpa.arpa it sounds like bind is misconfigured. You will need to configure bind to include: zone "16/20.168.192.in-arpa.arpa" { ...


0

The fix is simple: you need to reference resolved as a source of DNS resolution in /etc/nsswitch. Add "resolve" to the hosts directive, making it first in the list. So the hosts entry in /etc/nsswitch should look as below: hosts: resolve files dns myhostname Let's see what happens after we make the change to /etc/nsswitch:


Top 50 recent answers are included