Hot answers tagged

31

To view the content of that file you could rename it - e.g. test - place it under ~/.config/dconf/ and then have dconf read/dump the settings from that file. By default, dconf reads the user-db found in $XDG_CONFIG_HOME/dconf/: A "user-db" line specifies a user database. These databases are found in $XDG_CONFIG_HOME/dconf/. The name of the file to open ...


29

Gnome 3 uses DCONF to store the preferences in a single binary file: ~/.config/dconf/user. As per the Gnome docs, it is recommended to save only the settings that you need and restore them with either dconf or gsettings. However, gsettings is only able to restore the value(s) for one single key at a time (plus, the value must be quoted) and that makes it a ...


23

Method #1 - Using dconf Background You can use the dconf tool to accomplish this, however it's a mult-step process. DESCRIPTION The dconf program can perform various operations on a dconf database, such as reading or writing individual values or entire directories. This tool operates directly on the dconf database and does not read ...


11

It's all there (except the part with saving the current settings to that text file): On startup, dconf consults the DCONF_PROFILE environment variable. If set, dconf will attempt to open the named profile, aborting if that fails. If the environment variable is not set, it will attempt to open the profile named "user" and if that fails, it will ...


11

As you've found out, you can do this via tweak-tool: and indeed, the changes are now done in the dconf database so if you prefer doing it in terminal you need to toggle dynamic-workspaces to false and set the desired num-workspaces so either dconf write /org/gnome/mutter/dynamic-workspaces false dconf write /org/gnome/desktop/wm/preferences/num-workspaces ...


9

Thanks to @don_crissti's help and the answer they pointed me to. In order to change Gnome Terminal keybindings a path must be provided for the schema (as it is relocatable). So we need to define both a schema and a path: GSETTINGS_SCHEMA=org.gnome.Terminal.Legacy.Keybindings GSETTINGS_PATH=/org/gnome/terminal/legacy/keybindings/ SCHEMA_PATH=$...


8

I had the same problem, in my case I was running "sudo gedit" from a user account; therefore when it tried to save dconf changes it realized that the user was not root, and thus it raised those errors. I solved it by running gedit as a "root": sudo -i gedit & where sudo -i will login into a user acount.


7

I have the same problem. A quick workaround could be to use feh: feh --bg-scale <imagefile.jpg>


5

You may want to check if the following folders are owned by root: ~/.cache/dconf ~/.dbus If they are, try deleting them. According to other sources I found, they should be owned by yourself, but if you have run graphical programs with sudo they might have been created by root instead. Deleting them is apparently safe, as they are automatically recreated as ...


5

This has got on my nerves for a long time. I finally solved it using gksudo -l <command>, which runs the command in a login shell - similarly to XAVI's answer but without the need to type in the command after sudo.


4

Save custom keyboard shortcuts You can save/backup/export custom shortcuts/keybindings using just dconf and sed Export dconf dump / | sed -n '/\[org.gnome.settings-daemon.plugins.media-keys/,/^$/p' > custom-shortcuts.conf # Export The difference with the usual answer is that this will hold on the file the path to the dconf settings, making easier to ...


4

KDE doesn't use dconf. In KDE, settings are stored in simple text files rather than a database. The GUI for changing these settings is systemsettings, although individual application settings are usually set within the application.


4

Im assuming you mean the profile of Gnome terminal, i.e., the color and size of the fonts in the terminal, background color etc, and not the styling of the GTK window and widgets of the terminal itself. In Ubuntu 16.04 the GTK version has switched to 3, so gconftool-2 won't work any more, you need to use gsettings. heres the bash script I use to recreate my ...


4

You can try : gsettings range org.gnome.Evince auto-reload and you get : type b


4

I've found the answer. This problem turns out not a specific DE problem. It's the behavior of the app itself which is gnome-calculator. I've found two methods(or workarounds) for doing this: Using wmctrl So, the basic command is this: wmctrl -xa gnome-calculator || gnome-calculator To make it work in dconf command, warp it in shell command and apply it ...


3

I needed to add a dash when switching users in the console. So su - $ALTUSER instead of su $ALTUSER. The dash - is an alias for the -login option of su.


3

There is a partial answer here: The command to use is 'gsettings` and the actual settings to use you can find by using: dconf watch / in the terminal, while you adjust the settings. You get a bunch of statements like this: /org/gnome/desktop/wm/preferences/theme 'elementary' /org/pantheon/desktop/gala/behavior/hotcorner-bottomleft 'custom-command' /...


3

This does not actually answer my question (I still do not know the keybindings syntax for a right mouse click), but this did solve my problem, so I'm leaving this here for anyone who stumbles across it in the future: gsettings set org.cinnamon.desktop.wm.preferences resize-with-right-button true Apparently there is a setting for holding alt, right-clicking ...


3

I found the corresponding settings saved in .kde/share/config/kioslaverc.


3

Another solution which doesn't need feh is the following. It seems that the desktop wallpaper is stuck with the login background. So, you can change the login background and the only thing you need after that is logging out and in again (not restarting). Changing the login background is done via update-alternatives (if anyone knows a better way, please ...


2

Search for keybindings like so: gsettings list-recursively | grep keybindings Set a keybinding like so: org.gnome.desktop.wm.keybindings close "['<Alt>F5']" Note that keyboard tweaks overlapping bindings will break the latter. For instance, switch-applications-backward ['<Alt><Shift>Tab'] will be overridden by layout switch "Left Alt" + ...


2

I don't have a MATE environment to test on but in general, this type of thing can be set using gsettings. Try this: gsettings set org.mate.panel.toplevel:/org/mate/panel/toplevels/bottom/ size 45 That should set the value you want. For more details, see http://wiki.mate-desktop.org/docs:gsettings.


2

It has to be [''] instead of [] - Thanks and reference to the user zdenek from the ask fedora platform who helped me to figure it out and find the solution : How to make app folders settings permanent? The command is : gsettings set org.gnome.desktop.app-folders folder-children ['']


2

You can set system-wide dconf settings by storing them in a text file under /etc/dconf/db/local.d and running dconf update. If you've set up things on a user's account, you can print out the settings in text form with the dconf command line utility. dconf dump / prints out all known settings but you should only retain the settings that you modified.


2

Installing dbus-x11 worked for me. apt install dbus-x11 I can now change preferences and see no errors in cli at start-up.


2

According to this topic: dbus not accessible via kdesu/sudo, but recompiling dbus helps, I have to recompile dbus. So this is what I did on my Archlinux system # installs arch build system sudo pacman -S abs # download the abs dbus (do it with the root user) abs core/dbus # copy the files in my HOME cp -r /var/abs/core/dbus/ ~/abs # compile dbus cd ~/abs/...


2

Ubuntu I use ubuntu 18.04, (also done this in 17.10) and as of how @cezanee-vahid said, you can find the CSS file here: /usr/share/gnome-shell/theme/gdm3.css and by changing this file you don't need to restart gnome or do anything else, they will be changed by locking computer (or better to say will be reloaded). so for changing clock size you only need to ...


2

Not sure if this is a little too late but you can customize the values in /usr/share/gnome-shell/theme/gdm3.css and that does the trick. Just find the screen-shield-clock class and make your changes. One simple thing I did to make it a little nicer is set the font-weight to 300 and it improves the look a million times.


2

I'm a little late to the party, but I found the solution to a very similar problem I was having. Look in /etc/dconf/db/local.d/locks/screensaver and see if your key is listed. Anything listed in this file is locked, and cannot be changed at all. Also check /etc/dconf/db/local.d/00-screensaver, as that file forces global settings, which might also be ...


Only top voted, non community-wiki answers of a minimum length are eligible