7

Nemo uses GLib, so you should have access to the .hidden feature that it provides. Create a file named .hidden in the parent directory containing the files or directories that you want to hide, then in this .hidden file list everything you want to hide, e.g. Documents Videos Music All files listed in .hidden will be hidden by default (use Ctrl+H to unhide)...


7

I was wondering the same thing and finally found the answer: Visually, the two modes have nearly identical behavior, which is why it's confusing. As you noticed in both modes, the window you're dragging will take up the full, half, or quarter of the screen. But when you use the modifier key (Ctrl by default) to switch to snapping mode, the window you ...


4

SOLVED - I disabled temporarily IPv6 system-wide It seems to be a DNS routing issue. I was able to use the hotspot on my phone to troubleshoot and the problems went away. sudo sysctl net.ipv6.conf.all.disable_ipv6=1 disables IPv6 until reboot.


2

There is a slightly better, still hacky, workaround. Set your display resolution higher than maximum then use the Double UI scaling to scale it back up to a sensible size. This is pretty much bug free, except possibly for the mouse pointer and for using external displays, both of which are fixable within settings. First, determine which display device you ...


2

I had this problem too, and I found out a bit more about the problem. It is related to an update of python-pillow. It breaks the imtools.py file. I found the fix here - https://github.com/linuxmint/cinnamon/issues/8495


2

Cinnamon, like GNOME from which it was forked, will restart the session when you type 'r' into the Alt-F2 window. Its just telling it to re-execute itself, so it's not invoking a new command, but telling the cinnamon window manager to re-execute.


2

The lesson you learned here is to keep your root separate from your /home. Also, do you mean you are backing up your system in the same drive? Don't do that. Use a separate disk/partition for backup. If, as you said, don't mind reinstall your system, keep those things in mind.


2

According to its man file, Nemo has a --geometry command line option. Examples noted in the source file https://github.com/linuxmint/nemo/blob/master/src/nemo-main-application.c include: nemo --geometry=+100+100 nemo --geometry=600x400 nemo --geometry=600x400+100+100


2

Debian 8 and 9 use systemd as the default init system, so the commands needed to disable the GUI interface immediately & persistently are: systemctl set-default multi-user.target systemctl isolate multi-user.target The first command sets the text mode as the new default system state (so it will take effect on next and subsequent boots), and the second ...


2

It looks like your service is masked. To unmask it, run: systemctl unmask lightdm.service and afterwards, run: systemctl daemon-reload


2

The error is because of Python 3.6 code: os.execvp("/usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py", ("",) + tuple(sys.argv[1:])) You need to change "" to " ", because it treats "" as empty. For more info you should visit this link. Here you will find the files which need the above modification (to replace "" with " ").


1

(From the Cinnamon menu) Preferences --> Keyboard, then click the Shortcuts tab.


1

Solutions as presented by Archwiki - this is a mere recitation. In short the nm-applet package cannot be removed as it is essential part of cinnamon but you can suppress loading it by creating a custom cinnamon configuration. cp /etc/xdg/autostart/nm-applet.desktop ~/.config/autostart/nm-applet.desktop And append the line X-GNOME-Autostart-enabled=false ...


1

You can make your screen "blink" by refreshing it. for (( i=1 ; i<=5 ; i++ )) do xrefresh -solid blue xrefresh -solid red xrefresh -solid green sleep 0.01 done This should get your attention and get you in the mood for some epileptic dancing. Tune it up or down to your liking or just use part of your screen (-geometry option).


1

So i found the answer (Just like egmont said), i had to change The fonts as following:


1

dbus-send --type=method_call --print-reply --dest=org.Cinnamon \ /org/Cinnamon org.Cinnamon.Eval string:'global.reexec_self()' For the gnome equivalent, see How to restart Gnome... (Ubuntu). Modified for this case (Fedora+Cinnamon) with some help from comments following ALT+F2,"r"


1

Since posting this question, and with the help of the discussion following the earlier posted answer, I found the following answer in the Cinnamon source code https://github.com/linuxmint/cinnamon/blob/master/src/cinnamon-global.c#L1130 /** * cinnamon_global_reexec_self: * @global: A #CinnamonGlobal * * Restart the current process. Only intended for ...


1

What am I doing wrong? You are erroneously expecting the keyboard map that is applied by the loadkeys program to the built-in terminal emulator in the kernel that handles kernel virtual terminals, to apply to X11 programs. You are configuring the wrong keyboard mapping. Configure your XKB mappings. Further reading https://unix.stackexchange.com/a/480705/...


1

It turns out logout will not close all processes running on user behalf. Logging on Linux console (Ctrel-Alt-F1) as root and issuing killall -HUP -u mcon resolves the issue. Note: the above command will not terminate all processes having effective uid "mcon" (in particular systemd, dbus-daemon and several others resist), but it seems enough to cure the "...


1

I had this issue on a brand new Linux Mint 19.1 install, I searched all possible system keybindings, to no avail - then, I found out that Ctrl-Alt-A was hijacked by Terminator, even if it was set to use Ctrl-Shift-Alt-A. Re-configuring Terminator to use a different shortcut and then restarting it did the job.


1

First, find the keyboard shortcuts menu. I don't have linux mint available, but according to this blog post it's a matter of going to Menu → Keyboard → Shortcuts: Find 'Custom Shortcuts' in the left bar, and add one with the command xdotool type '¯\_(ツ)_/¯'. In 'Keyboard Bindings', bind it to a key (combination) of your choice. Of course, there are many ...


1

Thanks @Andrew F and @Inquisitive Lurker This is how you do it on Cinnamon 19: Menu Preferences System Settings Login Window ( + enter credentials) [Users] tab Under ["Automatic login": username*] -> Remove entered login Close window (there is no "save") Reboot


1

The Templates directory for your locale can be found by typing on the terminal: xdg-user-dir TEMPLATES Any files stored in that directory appear as menu entries of the new file context menu. The menu entry text is derived from the filename by removing the file extension, if that file has one. For example, the following command creates a menu entry ...


1

It's actually more like Run/View/Ask. :) Go to Edit > Preferences > Behavior tab. In the Executable Text Files section, you should find the options you're looking for. It's a global setting, so it can't be applied to just a single file type. Also, setting to view by default apparently prevents executing the files from within Nemo.


1

I have a similar situation, where I bind the system's screenshot shortcuts to my scripts, so when I invoke the shortcut gnome-screenshot will take the screenshot, save it to a file and then open it with Gimp. #!/bin/bash SSFile=~/Images/screenshot_window.png # This command takes a window screenshot and saves it to a file gnome-screenshot -w -f $SSFile ...


1

I'm a little late to the party, but I found the solution to a very similar problem I was having. Look in /etc/dconf/db/local.d/locks/screensaver and see if your key is listed. Anything listed in this file is locked, and cannot be changed at all. Also check /etc/dconf/db/local.d/00-screensaver, as that file forces global settings, which might also be ...


1

What you are asking is in fact possible with a simple hack. In my case, I wanted to bind Super+2 to "either switch to emacs if possible, otherwise open it". To get this working in Cinnamon, first sudo apt install wmctrl (or whatever other method to install packages on your Linux distro), then, with emacs (or whatever application you want to bind) open, do ...


1

I also struggle with knowing which window has focus (irrespective of how it got i). I have switched on the glow feature of oxygen theme in KDE's plasma. I now have a different glow around active and inactive windows. I also set a matching title bar colour. Green for active, and red glow / gray title bar and border for inactive (but the borders are very thin)...


1

The self-answer by the OP didn't work for me on Xubuntu 18.04. E.g. in xfce4-panel's Whisker Menu I still had the dashed lines. Instead, the answer from AskUbuntu worked for me. But I didn't edit the system theme file (this would require root access), instead creating ~/.config/gtk-3.0/gtk.css to contain the following: scrolledwindow undershoot.top, ...


Only top voted, non community-wiki answers of a minimum length are eligible