23

Silly me! I have xflux with fluxgui activated, each time I would like to modify the settings xflux will be in my way. All commands worked, just that xflux would revert it back. Those who want to change their gamma/brightness: Use xrandr to list your outputs: $ xrandr Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192 DVI-0 connected ...


9

Actually, all of these interfaces are capable of backlight control (and more), as long as both, graphics card and the monitor support the Display Data Channel. DDC is based on I²C, so you have to install and load appropriate kernel modules to make it work. # Debian sudo apt-get install i2c-tools sudo modprobe i2c-dev # RHEL sudo dnf install i2c-tools ...


8

Building on @M132's answer, ddccontrol appears unmaintained and hasn't added configurations for any new monitors since 2006. Fortunately, there is a newer tool: ddcutil, that is much more robust and actively developed. After installing one of the prebuilt packages or building from source, it can be used to query and set brightness (among myriad other ...


5

Try: find /proc /sys | grep -ie brightness -e light -e lux -e lumin On this laptop (a MacBookPro), it reveals (among other things): /sys/devices/platform/applesmc.768/light which is neither over PCI or USB. You could try the same after sudo modprobe -a tsl2550 isl29003 isl29020 apds9802als apds990x bh1770glc bh1780gli which are drivers for various ...


5

You might want to give this a try: $ sudo echo 5 > /sys/class/backlight/acpi_video0/brightness Change the value between 0-15 I believe to make it brighter or dimmer. You might need to change these as well: $ sudo echo 950 > /sys/class/backlight/intel_backlight/brightness $ sudo echo 5 > /sys/class/backlight/acpi_video0/brightness $ sudo echo 5 &...


5

You can try xrandr tool. First run xrandr --verbose and look for a line with resolution like LVDS1 connected 1024x600+0+0. The name of your display (LVDS1 in this example) is needed here. Now you are ready to set brightness: xrandr --output LVDS1 --brightness 0.4 xrandr sets software, not hardware brightness so you can exceed both upper and lower limits: ...


5

You can do that via GNOME Settings Daemon which is responsible for configuring the screen brightness (and many other session-wide parameters). To access the brightness settings you'll have to use the corresponding gsd helper: gsd-backlight-helper (use --help to see all options). To get the current brightness level, run: /usr/lib/gnome-settings-daemon/gsd-...


4

At the heart of backlighting is this Linux Kernel parameter that's exposed to you through here under /sys. You can manipulate it by setting the value to something between 1 and 15. For example: $ sudo echo 5 > /sys/class/backlight/acpi_video0/brightness Set's the brightness to 5. Manipulating this Kernel parameter is abstracted away so that when you're ...


4

There's xbacklight – "adjust backlight brightness using RandR extension". However, it fails with my HDMI monitor, so I fall back to using software modification: xrandr --output HDMI2 --brightness 0.7


3

I was hoping there was some interactive program for adjusting xrandr's settings (gamma/brightness in particular), but couldn't find anything. So I wrote this shell script which allows some interactive adjustment of brightness/gamma, as well as saving/restoring the settings. Save the file to irandr.sh, do a chmod u+x irandr.sh to make it executable, and run ...


3

Files in /sys are not physical files on disk. They are virtual files that let you access information in your active kernel. The practical impact of that is that running chown, chmod, etc. on them is an ephemeral operation, as you have discovered. The entire filesystem view in /sys is generated by the kernel when the system boots, so there's no way to make ...


2

I use xrandr –-output LVDS1 –-set BACKLIGHT 5 Or values other than "5". See http://linux-software-news-tutorials.blogspot.co.uk/2011/07/how-to-change-screen-brightness-of.html


2

Changing the grub command line is the right way to do it, but the problem is that acpi_backlight=vendor is wrong. The correct one is: acpi_osi=Linux It still always worked for me on a lot of laptops.


2

The solution from @RoQ is working fine. Here are the steps : Edit the /etc/default/grub file with superuser privilege Change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=Linux" Update the grub with the following command : sudo update-grub and reboot your computer That's it


2

A few links: http://www.kernel.org/doc/menuconfig/drivers-misc-Kconfig.html (to access data from the sensor the kernel must know about the device!) http://forum.notebookreview.com/dell-latitude-vostro-precision/475324-e6410-owners-thread-91.html I do not know what the ALS is in your particular case, but as @January said, you may start from the lspci -Q ...


2

Neither of the solutions above were sufficient for me. Use the below to find which backlights are available. ls /sys/class/backlight/ In my case there was a folder intel_backlight in that folder. Look for the max brightness file, it will let you know the upper bound you can set your brightness to, in my case this file: /sys/class/backlight/...


2

If someone should stumble upon this but meant to look for a way to set backlight through xrandr: $ xrandr --verbose gives some hints: $ xrandr --verbose Screen 0: ... ... BACKLIGHT: 268 range: (0, 852) Backlight: 268 range: (0, 852) ... There is some property or variable BACKLIGHT; hopefully it can be set. Reading from $ man 1 ...


2

From man xrandr (this is not listed in the -h options, but it works for me): --brightness brightness Multiply the gamma values on the crtc currently attached to the output to specified floating value. Useful for overly bright or overly dim outputs. However, this is a software only modification, if your hardware has support to actually change ...


2

I think I solved the problem. @drs proposed I install xbacklight to make it work but after installing it, I kept getting an error message saying "No outputs have backlight property" A little bit of googling the error led me to 2 files in the /sys/class/backlight directory. The 2 files were /sys/class/backlight/acpi_video0 /sys/class/backlight/...


2

Don't know how to fix it, but do know how to work around making the screen worse when fixing it. Maybe the following will provide some clues as to how to find the culprit. Here's my script for getting/setting the backlight value. I also use KDE and have a slightly less annoying problem. Every time I come back from screensaver/screen off, the display is at ...


2

Usually you can manipulate the brightness by directly interacting with the appropriate interface within /sys/class/backlight/. There are files representing the current brightness, which you can both read from and write to. For example reading in the current brightness could look something like this: [root@vpcs ~]# cat /sys/class/backlight/nv_backlight/...


2

I found the screen brightness solution in a somewhat obscure article. My issue was my laptop couldn't remember brightness settings upon reboot. I'll post the link at the end of my answer. All that was needed was to edit the file /etc/rc.local and add one line. First, back up the rc.local file.  If something goes wrong you can revert to the original file. ...


2

Try this. See if /sys/class/backlight/acpi_video0/ exists. If it does cat /sys/class/backlight/acpi_video0/max_brightness gives the max allowed brightness, and you can set brightness thus (where X is a value 0-'max_brightness'): echo X >/sys/class/backlight/acpi_video0/brightness


2

The issue was a missing driver. After being in contact with advantech they had drivers built for both 32 and 64 bit Ubuntu which were not on their website. The Ubuntu drivers (of the correct architecture) work on Debian enabling brightness control.


2

It doesn't automatically use this configuration, rather you have to load it manually, for example by one of the methods shown in the readme, or your own favorite way of starting something at login. The command you're looking for is nvidia-settings --load-config-only. 4. Loading Settings Automatically The NVIDIA X driver does not preserve values set with ...


2

After adding the following line in your X device configuration Option "RegistryDwords" "EnableBrightnessControl=1" You can use the software xbacklight to adjust the brightness: xbacklight -set 60


2

For now I'm working around this by hardcoding commands to handle the XF86 events in Awesome WM: awful.key({}, "XF86MonBrightnessDown", function () awful.util.spawn_with_shell("xbacklight -dec 5") end), awful.key({}, "XF86MonBrightnessUp", function () awful.util.spawn_with_shell("xbacklight -inc 5") end), I'm still holding out for a solution to handle this ...


2

First, setting the brightness and getting Fn key events are two different things. 1a) Figure out which /dev/input/event* device is for your keyboard. (Look at /dev/input/by-id or /dev/input/by-path and follow the symlinks, look at demsg/syslog, or just test all of them). Run evtest on this device, and press the Fn brightness keys. Do you get key events? If ...


2

You can use xbacklight to control the screen brightness. In XFCE, open the settings and add calls to xbacklight under “Keyboard” → “Application Shortcuts”: something like xbacklight -dec 5 -steps 1 for BrightnessDown and xbacklight -inc 5 -steps 1 for BrightnessUp. A few graphics drivers don't support xbacklight. If it doesn't work on your system, you can ...


2

XFCE backlight buttons First, install xbacklight $ sudo apt install xbacklight Then, check whether you have control over the backlight. $ xbacklight -1 $ xbacklight +5 Should these commands result in a No outputs have backlight property error, then follow these remediating steps before proceeding. Once xbacklight -1 and xbacklight +1 work from the ...


Only top voted, non community-wiki answers of a minimum length are eligible