New answers tagged

0

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) You get this message because it could not find the init script. (Without init, it tries to proceed and then fails due to lack of rootfs). -append 'debug console=ttyS0 init=/bin/init' It should be /init, not /bin/init. Alternatively you can specify the initramfs init with the ...


1

I think perhaps your init script is too minimal for booting. Kernels work with /proc and /sys so it should include : mount -t proc none /proc mount -t sysfs none /sys


0

I have finally managed to let my Yocto Image boot! If anyone has the same trouble booting it, this is how I did it. At first I did the grub-install as usual and added a grub.cfg in /boot/grub/ in the EFI partition (for me its /dev/sda1). After that I added search --set=root --file /vmlinuz instead of set root=(blabla) to the grub.cfg file. Then I copied a ...


0

Make sure to disable legacy mode or at least set priority to uefi mode in the "bios" config. The usb drive should have a efi folder on it. The partition table is not relevant, windows needs gpt to boot in efi mode, linux can boot in efi mode from either a mbr or gpt partition table. The filesystem of the drive should be fat32. You can also check, whether ...


1

When I had this issue, it was caused by accidentally changing the Partition Scheme to MBR instead of GPT. Try creating the Ubuntu USB with Rufus, and make sure the Partition Scheme is set to GPT and the Target System is set to UEFI (non CSM).


0

I hope this helps: There is a simple way to install Ubuntu w/o EFI: After you dd the ISO file on the stick there are 2 partitions on your usb stick. One of them is EFI / UEFI. Insert the stick in your operational Linux machine and invoke fdisk (sudo required). Lets assume your stick is /dev/sdf. You see sdf1 linux and sdf2 EFI on the stick. Use fdisk ...


0

I fixed this problem: in emergency mode~ #pvscan #vgscan #lvchange -ay VolGroup00 #lvscan after that, fsck -f /dev/VolGroup00/LogVol00 # In my case, dev/fedora/home that was all... I am writing on Fedora 30... I apprecitate all you guys...


0

You could add a delay: https://stackoverflow.com/q/43001223/32453 Or possibly could do this in your systemd OpenVPN service file: ExecStartPost=/bin/bash -c 'do_bash_loop_that_waits_till_file_appears_here' And another option: create a systemd .path unit file. Maybe have it fire whenever that vpn.env file is created or changed.


0

If you are on windows, you can try to make a USB with Rufus. Please be sure to select the right setting between BIOS/UEFI (MBR supports everything normally). If these errors keeps coming, try to re-download the ISO and re-try to burn it into you USB stick. I hope it will help.


1

I realised what the problem was... I hadn't seen the page for USB installation so I hadn't done some important steps... In /etc/mkinitcpio.conf move the block and keyboard hooks before the autodetect hook and re-create the initial ramdisk with mkinitcpio -p linux. When installing GRUB, i forgot to add --removable which I think was the really important step....


0

Try setting GRUB_TERMINAL=console, once it is showing this png file!


0

Pfiou found my way alone, it was hard Here are two videos that helped me, for the boot recovery, although I had to do way more than this, like deleting partition and recreating it from diskpart, which wasn't obvious: https://www.youtube.com/watch?v=l_I4K2-Rr_Y And for the D drive not appearing https://www.youtube.com/watch?time_continue=2&v=...


0

You can however convert those fields into unix timestamps. I.e: journalctl --list-boots | awk '{ d2ts="date -d \""$3" "$4" " $5"\" +%s"; d2ts | getline $(NF+1); close(d2ts)} 1'


0

Apparently I'm actually right, it's not waiting for IPv6. I posted this issue on the project's Github and someone marked it as an RFE: https://github.com/systemd/systemd/issues/2037 Check this for a solution (disabling IPv6 DAD) that temporally fixes the issue: http://serverfault.com/questions/766253/ensure-systemd-wait-for-ipv6-before-start-service-unit


1

A suggested solution from https://askubuntu.com/questions/248/how-can-i-show-or-hide-boot-messages-when-ubuntu-starts... ...for just a (usually) black screen, try: GRUB_CMDLINE_LINUX_DEFAULT=quiet #Don't show Ubuntu bootup text GRUB_CMDLINE_LINUX="console=tty12" #Don't show kernel text


1

I ran into this issue today but was able to fix it and save my install by following these steps: Download a live CD and boot on the affected machine. Open terminal fdisk -l and cat /etc/fstab to see what devices are mounted where mount the correct devices to the corrects parts of /mnt mount --bind /dev /mnt/dev mount --bind /proc /mnt/proc mount --bind /sys ...


0

As it says, it can't mount the root device. There are many possible reasons for this. One is that you don't load the initrd that is supposed to prepare for mounting the real root. You should also check the root parameter on the kernel command line. The 1,0 in unknown-block(1,0) indicates that /dev/ram0 should be used. So either you want to use another root ...


0

In the GRUB boot menu, edit the boot settings, find the line that loads your actual kernel (it starts with the word linux) and remove the options quiet rhgb to get a more verbose boot display. That might give you more clues about what the system is trying to do after it starts the Network Manager Script Dispatcher Service, since that might be the failing ...


1

There might be multiple lists: one for kernel modules loaded within initramfs (i.e. modules necessary for basic I/O and accessing the root filesystem) and another list loaded once the root filesystem has been mounted. For Debian and related Linux distributions like Ubuntu, there's /etc/initramfs-tools/modules for modules to be loaded in initramfs (in the ...


1

Ubuntu 15.04 and forward be default uses something called systemd, which is a program (of sorts) that automates startup services and procedures. You can make your own and add it to the list of startup services with only a little bit of effort. Basic Systemd Service This is a barebones .service file that could be used to launch my python gui server (could'...


0

I had this exact same issue (Centos 7) with MBR boot - did not matter what i tried in terms of disks, partitions, versions of Clonezilla etc - in the end i purchased the PartedMagic ISO that was referenced earlier in the thread - and although it used CLonezilla - it obviously performed some magic at the end of the process as the cloned disks boot with no ...


0

Try first upgrading dnf, rpm and friends, sometimes it gets stuck in there. Try erasing the offending package (if it's Python, tread carefully... it is used all over the place, and can erase a lot of other things). If you have the package downloaded already, perhaps going to a raw "rpm -Uhv --force package.rpm" (essentially, install or reinstall) fixes the ...


1

I felt unhappy about the same problem on my laptop maybe longer then this question stays open. There is a solution: Disable backlight control in radeon driver by adding radeon.backlight=0 to kernel boot parameters. But. The problem here is that you might need another module to control the backlight. This means that instead of acpi_backlight=video you ...


-1

Welcome to SE. Have a look here. I am not sure if this will work for f30(you missed your Fedora version), but the problem seems to be similar.


3

Thats the new Plymouth theme. You can easily change the theme using plymouth-set-default-theme --list plymouth-set-default-theme <one from list output> - R Source: https://fedoramagazine.org/howto-change-the-plymouth-theme/


2

On a very low level, the video memory is not automatically cleared when it is written to. Unless Fedora boot process explicitly clears the screen or changes the video mode, whatever it puts on screen will appear "on top" of what's already there.


0

See here https://forums.linuxmint.com/viewtopic.php?f=46&t=296423&p=1648791#p1648791 & there is a link there to Ubuntu Forum ... The "OS Boot Manager" is hard coded to load the Microsoft EFI file and will always run before any other local EFI files. ...


1

No need to reinstall GRUB. Since you managed to access /etc/grub.d/40_custom, use the same method to access /boot/grub/grub.cfg, find the exact same login/password details in that file, and comment them out (or just delete them). They will be between lines like: ### BEGIN /etc/grub.d/40_custom ### # This file provides an easy way to add custom menu entries. ...


44

This is the result of Hans de Goede’s work on flicker-free boot in Fedora. Hans developed a new Plymouth theme which takes the firmware bootsplash and adds the Fedora logo to it, until boot finishes and the desktop environment takes over. This works because bootsplash logos are now exposed as an ACPI resource, which you can see in /sys/firmware/acpi/bgrt on ...


1

Because it didn’t work, I tried to reinstall grub manually, but I have the same results. You've not actually said what you did here, so my suggestion might be something you've already tried. But to re-install grub manually, try the following: Boot into Linux mint Live USB and open a command prompt. Mount your Linux root partition and any partitions ...


0

Since the system runs OK with a Live USB, please reinstall the OS on a replacement drive (SSD or HDD).


0

In order to make a fresh install, you need to boot from the USB stick. For that, you need to force it from BIOS, as if you are loading GRUB, the BIOS is already booting from hard drive instead of USB-stick.


1

Though it was a question 2 years ago, I still googled here. And I finally get a better solution from NFS ROOT WITH SYSTEMD [Match] Name=eth* KernelCommandLine=!nfsroot


0

I changed my secure boot settings (honestly I just added a password to allow all bootable drives to appear). If you also had this problem, reboot into the recovery partition (command-R when the apple appears on boot-up), and go to Utilities > Secure Boot Settings or something like that — the top one anyway.


1

This worked for me: Once you are are in emergency mode run xfs_repair -L /dev/dm-0 && reboot Log in and in a terminal run sudo xfs_fsr /dev/mapper/centos-root sudo xfs_fsr /dev/dm-0 reboot Not 100% sure what the issue is but all my centOS VMs regardless of version does this. I was working on this issue for a week.


0

The setserial package will restore the serial settings at boot time. Once installed, simply edit the file /var/lib/setserial/autoserial.conf ###PORT STATE GENERATED USING AUTOSAVE-ONCE### ###AUTOSAVE-ONCE### # # If you want to configure this file by hand, use # dpkg-reconfigure setserial # and change the configuration mode of the file to MANUAL. # If you ...


Top 50 recent answers are included