26

Edit your /etc/systemd/logind.conf , change #NAutoVTs=6 to NAutoVTs=1 Create a /etc/systemd/system/getty@tty1.service.d/override.conf through ; systemctl edit getty@tty1 Paste the following lines [Service] ExecStart= ExecStart=-/sbin/agetty --autologin root --noclear %I 38400 linux enable the getty@tty1.service then reboot systemctl enable getty@tty1....


24

You can do it two ways: Open System Settings => Users => Click icon Automatic Login Edit /etc/gdm/custom.conf, add theses lines: [daemon] AutomaticLoginEnable=true AutomaticLogin=mz2


20

This page describes how to enable it. Edit the LightDM configuration file and ensure these lines are uncommented and correctly configured: /etc/lightdm/lightdm.conf [Seat:*] pam-service=lightdm pam-autologin-service=lightdm-autologin autologin-user=username autologin-user-timeout=0 session-wrapper=/etc/X11/Xsession greeter-session=lightdm-greeter LightDM ...


13

According to the passwd man page: -d This is a quick way to delete a password for an account. It will set the named account passwordless. Available to root only. so you can do this (as root): passwd -d mz2 then you can login without a password


9

here is the correct answer for Debian 9 Jessie, for all of you who need help the correct way. Add Auto Login to Debian First you need switch to the LightDM (Desktop Manager). Switch to LightDM** sudo dpkg-reconfigure lightdm Add the Autologin account** sudo groupadd -r autologin sudo gpasswd -a YOURUSERNAME autologin Edit the LightDM Config Files ...


8

I just want to add to this discussion that the accepted answer pertains to virtual terminals. In my case, I had to edit a separate service file which is used for serial terminals. The file is found at /lib/systemd/system/serial-getty@.service and the same procedure of adding --autologin <user> to the appropriate line does the trick. [Service] ...


7

I'd like to add a slightly more thorough answer, especially given the comment about breaking his system from @Keelan. First if you wish to only have one TTY that is running the program, and not be able to log in to any other tty, THEN edit your /etc/systemd/logind.conf, and change #NAutoVTs=6 to NAutoVTs=1. Doing this will keep you from logging in on the ...


6

In Debian 9 and 10 with Xfce, all I had to do was add this to /etc/lightdm/lightdm.conf: [Seat:*] autologin-user=david Despite what the other answers say, my user does not need to be in the autologin group and I didn't need to do anything with PAM. (Source: https://wiki.debian.org/LightDM#Enable_autologin)


6

If you want to continue with an interactive session, the usual way is to use expect to do the login: #!/usr/bin/expect spawn telnet mymachine -l myusername expect Password: send password\r expect -- {$ } interact


6

There are a few different important points here. But the first one is, Kali is not a good first Linux distribution to start off with. If you're not familiar with account permissions, and especially if you don't want to use the command line, then Kali isn't right for you. I'd recommend Ubuntu instead. Anything you can do in Kali, you can also do in Ubuntu (...


5

The problem is the command you're using to do the diff. Every time that command runs the results of it, whether there's a difference or not, will trigger the mail command. Example Here we're going to simulate the 2 files using 2 echo commands like so: $ diff <(echo 1) <(echo 2) 1c1 < 1 --- > 2 That seems OK, but what happens when the echo ...


4

I haven't used xdm in a long while but as far as I know autologin is not supported by xdm (and, as per one of the devs, not needed).


4

I rewrote script. The most tricky part was to disconnect from ssh by exiting from fish as exit inside ./.config/fish/config.fish didn't work. It starts tmux only if parent of the fish is ssh. Here is part of my ./.config/fish/config.fish file: if status --is-login set PPID (echo (ps --pid %self -o ppid --no-headers) | xargs) if ps --pid $PPID | ...


4

In Gnome, you can follow these steps. Click .. Activities - Show Applications - Settings - Users. Here you will see your users details for login. Make the password - None. Automatic Login - ON. Then restart the PC. Problem solved.


4

Assuming systemd treats ttyAMA0 as a serial port the same way it would treat ttyS0 on a PC, you need to edit the command started by the serial-getty@ttyAMA0.service. (You could check if systemctl status serial-getty@ttyAMA0 shows it is active.) The base version is in /lib/systemd/system/serial-getty@.service and inside it we find the command that starts ...


4

Assuming you still want to interact with that telnet session after sending the password, you'd need to feed it input from your local terminal: (echo password; cat) | telnet -l user host Depending on how your telnet implementation tries to interact with the local terminal, you may find that you need to do: saved=$(stty -g); stty raw -echo (echo password; ...


4

ttyv8 "/usr/local/bin/startx" xterm on secure Close, but wrong. The manual for ttys gives an example of how to do exactly this. You need to specify your actual X server with a window= setting and specify the initial X client to run in the second field of the record:# terminal emulate/window system ttyv0 "/usr/local/bin/xterm -display :0" xterm ...


3

For Question 1: Just edit /etc/gdm/custom.conf with your favorite editor. Then, under the [daemon] section, add 2 lines so it looks like the code below (change username to the username you want to use): [daemon] AutomaticLoginEnable=true AutomaticLogin=username


3

You need to configure your gdm3 , PAM for autologin : Edit /etc/gdm/custom.conf file. # Enable automatic login for user [daemon] AutomaticLogin=username AutomaticLoginEnable=True Put the following pam configuration into /etc/pam.d/gdm-password: auth sufficient pam_succeed_if.so user ingroup nopasswdlogin Then create user and group nopasswdlogin.


3

Not possible. Someone, or something has to supply the password for decryption. Obviously it can't be on your home directory (as that is encrypted). It should not be on your hard disk at all, as that would be pointless: An attacker could extract it from there. So I don't see a way to make this automated (i.e, not requiring you) while preserving that only ...


3

The autologin as such shouldn't be any more insecure than logging in manually - you would need to trust anyone with physical access to the computer, but again, that's the same issue no matter how you start the X session. However, whatever applications you are running on login may be a security issue - e.g. if you were to do something like "xhost +" in your ...


3

I solved it using the Debian wiki page and this page on LinuxServe -- especially the comment! when I do /usr/sbin/lightdm --show-config I get two files: /etc/lightdm/lightdm.conf and /usr/share/lightdm/lightdm.conf.d/01_debian.conf These I edited so that in /usr/share/lightdm/lightdm.conf.d/01_debian.conf it says: greeter-session=lightdm-greeter session-...


3

How about a system where user cannot close the browser? I recently made a system where it is not really possible. The added bonus is that it is pretty fast. Essentially it is in i3 window manager with virtual consoles disabled and browser started in kiosk mode. You can read about full setup here: How to configure kiosk with Wayland / Xorg? But of course it ...


3

I'm using the following way: On ttyv0 my user automatically log in. My ~/.login checks the tty. If it's ttyv0 will run startx. After end of startx (close the xorg session) asks about halt/reboot. Explanations: 1. Automatically login: to /etc/ttys: ttyv0 "/usr/libexec/getty autologin" xterm on secure and to /etc/gettytab: autologin::al=MYUSER 2. &...


2

I'd recommend you to still use a regular user, but to configure sudo without password. Anytime you need to do a root command, you can just do: # sudo command If you want to have a terminal opened with sudo shell, do # sudo bash Note this is still giantic hole in the security of your system :-) As root do: # visudo and add this line: yourusername ALL=...


2

I think you just need to edit this file (/etc/lightdm/lightdm.conf) and add the following line: autologin-user = root


2

I found this thread which I think is your issue. The thread is titled: systemd: autologin to tty1 problems, sounds like your issue. note: As of systemd 30, only 1 getty will be launched by default. If you switch to another tty, a getty will be launched there (socket-activation style). You can still force additional agetty processes to start using ...


2

Usual warnings of root login is dangerous, do not use unless you are expert. Linux Mint Rebecca 17.1 uses nemo desktop as do others. root login text has been moved to: /usr/share/mdm/defaults.conf line 185. those who don't know how, this is what to do. Open Terminal and type sudo passwd root you will be prompted for a new root password. Next type, sudo ...


2

Linux Mint 16 uses the Mint-X theme by default which only displays the password box for chosen non-root users. In order to enable the User entry field (from which you will be able to specify root) do this. From Menu ==> Administration ==> Login Window ==> Theme choose Clouds and logout.


2

Unless you use autologin together with XDMCP, the security implications are the same as leaving an unattended X server running without any screen locking mechanism active.


Only top voted, non community-wiki answers of a minimum length are eligible