63

Try this, maybe it can help: autoreconf --install (See the manpage, there is a --force option also)


62

Try: DIR="$HOME/.bin-libevent" ./configure CFLAGS="-I$DIR/include" LDFLAGS="-L$DIR/lib" (I'm sure there must be a better way to configure library paths with autoconf. Usually there is a --with-libevent=dir option. But here, it seems there is no such option.)


36

You should do sudo apt-get install build-essential libtool


30

I believe the automake process involving a Makefile.in is something like this: Makefile.am | \'/ +--------------+ | automake | +--------------+ | \'/ Makefile.in | \'/ +--------------+ +--------------+ | ./configure |<-- | autoconf |<-- configure.in +--------------+ +--------------+ | ...


23

The macros in the error message you posted are defined by automake and libtool; it looks like you need to install those packages. Then try autoreconf --install


18

it's just a convention that signifies the given file is for input; in my experience, these files tend to be a sort of generic template from which a specific output file or script results.


9

I was having a similar problem and discovered that after running sudo yum install libevent-devel I was able to successfully make and install tmux. EDIT: If you are installing this on a Red Hat machine, you will also need to visit the channels selection for your server on the Red Hat Network and add the RHEL Server Optional channel. This will give you ...


8

If that's a from a configure.ac file, then it's not a pure shell script, but is an Autoconf script using M4, where [] are quote characters.: To fully understand where proper quotation is important, you first need to know what the special characters are in Autoconf: ‘#’ introduces a comment inside which no macro expansion is performed, ‘,’ separates ...


8

The macro AC_PROG_MKDIR_P is a feature test macro. It expands to shell code that tests for the best mkdir -p-capable command available. It uses MKDIR_P and ac_cv_path_mkdir (a "cache variable") to figure out what command to use. You may set the value of MKDIR_P to the command that you want to use for creating directories. The command that you use must be ...


6

I had the same issue on RHEL 5.4 and actually found libevent is installed but there is no libevent.so symlink, only the real version of the library: /usr/lib64/libevent-1.1a.so.1 /usr/lib64/libevent-1.1a.so.1.0.2 So, ln -s /usr/lib64/libevent-1.1a.so.1 /usr/lib64/libevent.so works pretty well for me without the need to install or alter anything. No idea ...


6

They are input files for the m4 macro preprocessor. Among other things, these files contain macros marked by @, that get expanded by m4.


5

Try this.. sudo apt-get install automake autoconf libtool autoreconf -i This worked for me.


5

Generally, the solution is "don't try to install from source into directories managed by your packaging system". You can install your custom-compiled code into /usr/local, for example, and having anything that depends on it look to /usr/local for libraries and include files using appropriate invocations of your build system (e.g., setting CPPFLAGS/CFLAGS/...


3

For anybody else looking: While automake and libtool are very likely candidates, some systems won't install gettext automatically. This is also required.


3

Before the configuration and compilation of tmux (or any program) you need to tell it where it can find the libraries it needs. If you have installed some library in a non-standard location, you can use the environmental variable LD_LIBRARY_PRELOAD to tell, where some libraries are located. I your case: $ export LD_LIBRARY_PRELOAD=$HOME/.bin-libevent/lib ...


3

configure is essentially a shell script bootstrapped from M4 macros, so you can use $* to grab all the arguments to ./configure. As per the autoconf manual you should do this right after AC_INIT, e.g.: AC_INIT([My Program], 1.0, ...) config_flags="$*" AC_DEFINE_UNQUOTED([CONFIG_FLAGS],["$config_flags"],[Flags passed to configure]) This will #define ...


2

There's an error in that tutorial: in the shell, variable expansions use braces, not parentheses, so you need to write ${CPPFLAGS} and not $(CPPFLAGS). You can leave the braces off, even. Also, if you replace $HOME by its value, the $ must go ($ followed by a variable name means “take the value of”). export CPPFLAGS="$CPPFLAGS -I/home/xxx/include" Oh, and ...


2

Link local addresses are an important part of IPv6. Disabling them will break IPv6.


2

The configure script will most often use the wording checking whether because this is the default wording in the default autoconf macros. If a project's configure script says checking if, then this means the same thing and is probably produced by a custom test macro that the developers have written themselves (or borrowed). As an example, when configuring ...


2

It turns out this was caused by bash being cross-built. Fortunately the problem didn't affect building bash itself natively on the ARM platform, so once I build a native build, run all the tests, install the new bash binary and reboot then the problem disappears.


2

You need to install Data::Serializer from CPAN: cpan Data::Serializer


2

If there's a makefile in the subdirectory, you probably need to invoke that makefile instead. make -C path/to file


2

Though the bash autoconf version (2.63) is a little old (Sept 2008), it supports the --program-transform-name and --program-suffix features. Sadly the bash build process does not use these features as detailed by the documentation, nor does it use parameters to allow build-time processing of the man pages. Since the number of files and changes is small, I ...


1

Autoconf of course caches the results and if you use it correctly, you rarely run configure. My schilytools project (> 4000 source files, approx. 770000 lines of code) currently need approx. 800 autoconf tests. Running all tests takes 28 seconds on a 2.7 GHz Intel laptop, 2-3 hours on a HP-9000 pizza box from 1995, 4-6 hours on a Sun3/60 from 1996 and ...


1

Any answer will be at least a little bit speculation IMO, as what constitutes "innovation" differs from person to person (and whether it's a good thing!) Because autoconf is designed to be language- and architecture-agnostic for the most part, there's a lot of inertia keeping the desire to change low: you have to consider that some configure scripts are ...


1

dumpdef writes the list of macros with their definition into a file. In standard m4, that file is standard error, so the only way to get at it is with a redirection that's external to the m4 script. GNU m4 provides the debugfile macro to redirect the output to a file which can be read back with input, but you can't rely on a specific implementation of m4 in ...


1

Typically, if you're targeting a specific BSD version, you'd use that BSD's make (sometimes known as bmake, bsdmake or pmake). This has various predefined rule sets for particular kinds of targets you'd like to build. For example, on NetBSD bsd.prog.mk is typically used for building a program; you simply declare the program's name and source files, and it ...


1

So you want to build a 64bit version of ffmpeg? Are you sure your compiler isn't making 64bit binaries by default anyway? If it's not, the usual thing to do is to edit your CFLAGS, CXXFLAGS and LDFLAGS. You'd probably use something like this:- CFLAGS="-m64 -O3 -fPIC" CXXFLAGS="$CFLAGS" LDFLAGS="-melf_x86_64 -O3" ../ffmpeg/configure --enable-static It's ...


1

I was pretty confused when getting these errors, because I had everything installed and autoreconf --install wasn't helping. The problem was just corrupted aclocal.m4 and deleting it before autoreconf solved the problem.


1

There's a gist at https://gist.github.com/ryin/3106801: #!/bin/bash # Script for installing tmux on systems where you don't have root access. # tmux will be installed in $HOME/local/bin. # It's assumed that wget and a C/C++ compiler are installed. # exit on error set -e TMUX_VERSION=1.8 # create our directories mkdir -p $HOME/local $HOME/tmux_tmp cd $...


Only top voted, non community-wiki answers of a minimum length are eligible