New answers tagged

0

To get it work for me, I used a combination of the above answers: #with audio for skype (0=redirect locally), works for for listening and speaking xfreerdp /microphone:sys:alsa /sound:sys:alsa /multimon /u:xyz /audio-mode:0 /v:pc-xyz From Ubuntu 18.04 to a Windows 10 Machine Using a local USB Headset (Rapoo Wireless, with it's own USB Plug, not Bluetooth) ...


0

I have experienced the same bug in Debian 10, and it appears not to be resolved in any upstream (backport / testing / compiled from source) bluetooth components. However, you can work around this by causing a software reconnect so you can use your headphones in the correct mode. Unfortunately you have to do this every time you turn on the headphones. You can ...


0

I figured it out a fix for the Sony WF-1000XM3 that might potentially work with other devices: The Sony WF-1000XM3 have an internal volume setting. Windows, Android, and iOS are all apparently smart enough to manipulate this automagically. Not the case with Manjaro/Arch and apparently other Linux distros. The workaround is simple: Connect your headphones to ...


0

flite : http://www.festvox.org/flite/ echo 'Hello world' | flite


0

My snippet for playback volume control #!/bin/bash inc() { playback_input=`pactl list sink-inputs short | awk '{print $1}' | head -1` pactl set-sink-input-volume $playback_input +5% } dec() { playback_input=`pactl list sink-inputs short | awk '{print $1}' | head -1` pactl set-sink-input-volume $playback_input -5% } mute() { ...


0

After analyzing the log a lot and not getting close to solving or solving a problem in a desperation to reinstall the pulse audio, as Debian sid offers a "purge" option, I believe this tag was deleted in some conflicting situation pulseaudio -k sudo apt remove pulseaudio sudo apt purge pulseaudio sudo apt install pulseaudio pulseaudio -D


1

In modern notebooks, the speakers are often disabled (by the hardware controller) when you plug in your headphones. This is not Linux specific, but a feature of the machine itself. This is, for example, the case with my ThinkPad T490s.


0

It looks like Cendio ThinLinc would solve your need. It has audio support through PulseAudio. It is based on open source (TigerVNC and others). You can use it for free up to 5 users. : ) www.cendio.com


1

If you look at the source code for aplay.c/arecord.c, you'll see a table for formats like static const struct fmt_capture { void (*start) (int fd, size_t count); void (*end) (int fd); char *what; long long max_filesize; } fmt_rec_table[] = { { NULL, NULL, N_("raw data"), LLONG_MAX }, { begin_voc, end_voc,...


1

1. Software switching support Check, if your sound card supports software switching for the front audio panel. Some older motherboards don't support software switching at all. Some sound cards have connectors for both variants on the motherboard: software and hardware switching. In this case, make sure from your motherboard manual, that you use the connector ...


0

I actually had the same problem, after a months of digging this thing i found solution. echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf echo "options snd-hda-intel dmic_detect=0" | sudo tee -a /etc/modprobe.d/alsa-base.conf echo "blacklist snd_soc_skl" | sudo tee -a /etc/modprobe.d/...


0

To purge only the APE tag from an MP3 file, use the erase mode from newer versions of apetag available at GitHub apetag -m erase -i file.mp3 (This preserves the ID3 v1 tag if any.)


1

Yes. Use module-null-sink for the "virtual sink", module-loopback with channel map twice to connect the mic source to the one channel, and the .monitor source of your output sink to the other (enable remix for this one). Details for parameters in the Pulseaudio modules documentation.


1

There is a command-line tool amixer which should allow you to perform the necessary tasks. First, run amixer controls to get a list of control options. You will likely get output like numid=XX,iface=MIXER,name='Master Playback Switch' ... numid=YY,iface=MIXER,name='Capture Switch' You can get the status of the control option with $ amixer cget name='...


0

Guess: Your SPDIF hardware only has 48 kHz in hardware (it's the default for most SPDIF hardware), and when you set it to 44.1 kHz, resampling happens in some place that's vulnerable to underflow, and hence the crackling/distortion. OTOH, with 48 kHz and, say, Pulseaudio, Pulseaudio will do the resampling, and apparently with a large enough buffer that ...


0

LoudGain seems to be the perfect tool: https://github.com/Moonbase59/loudgain It uses the well-known mp3gain commandline syntax but will never modify the actual audio data. Just what you ever wanted: The best of mp3gain, ReplayGain 2.0 and Linux combined. It reduces gain to -1 dBTP (instead of 0 dBTP, according to EBU recommendation). Almost a security ...


Top 50 recent answers are included