New answers tagged

1

The main repository is missing in your sources. You need to add at least deb http://deb.debian.org/debian buster main to /etc/apt/sources.list (see Example sources.list) and reload the package index with sudo apt update in the terminal or choose "Reload Package Information" (Ctrl + R) in synaptic.


0

change http into https. ex:-https://kali.cs.nctu.edu.tw/kali kali-rolling/main


1

The solution is pretty simple, Microsoft keeps their updated GPG signing key in this file: https://repo.skype.com/data/SKYPE-GPG-KEY So, one can do for example: curl -s https://repo.skype.com/data/SKYPE-GPG-KEY | sudo apt-key add - Note: You should not implicitly trust any key (or file for that matter) and inspect the file thoroughly, see this answer for ...


0

I wouldn't know whether this is true for (all of) its derivative distributions, but packages on Arch Linux only have that short description; which is mentioned in the Arch Wiki page on PKGBUILD files (the scripts used to build packages): pkgdesc The description of the package. This is recommended to be 80 characters or less [...] and in the Arch package ...


2

The repository seems to be out of order: there should be a pool directory here, alongside dists. This is being tracked in this issue. See also this Ars Technica article on the outage.


3

For the benefit of anyone who will encounter this problem. Here's what I did to fix this daunting accident. Since my network-manager had also been removed there is no way sudo apt-get update, sudo apt-get update --fix-missing, sudo apt-get -f install nor sudo apt-get upgrade works no matter how many times I tried. Thankfully, I found my thumb drive with ...


6

Yes, you can, apt install will install the latest available package (according to its local indexes, so run apt update beforehand), upgrading if a previous version is already installed. Quoting the man page: install is followed by one or more packages desired for installation or upgrading. Basically, apt install package will result in the currently-...


0

The exact cause of the issue is still unknown right now, but as @tripleee suggested, using a VPN/proxy resolved the issue: I used AirVPN with a server also in the Netherlands and this resolved the issue, so it seems it is related to my IP address.


0

By running apt policy I noticed that Basil Gello had 1 set on the machine on where it doesn't ask me to downgrade these packages and 500 set on the one that prompts about downgrading them. I simply reran the setup steps for Basil Gello's repo and now this prompt doesn't show anymore.


1

Use this apt option to turn those warnings into errors: apt-get update -o APT::Update::Error-Mode=any You can also set that in conf files if you wish.


2

Newer versions can use apt download pppoe It will be downloaded into the current directory. (For ubuntu-based distributions whose version >=18.04)


1

For context, current best practices for third-party repositories are documented in the Debian wiki page on third-party repository usage and in this “How to properly use 3rd party Debian repository signing keys with apt” blog post. Eventually they should be extended to Debian’s own repositories, see this issue for example. Assuming you trust your current ...


1

The package lists are indeed “ingested”, into caches stored by default in /var/cache/apt: pkgcache.bin and srcpkgcache.bin. To force apt to only look at the indexes you’ve restored, the simplest option is to delete those caches: sudo rm /var/cache/apt/*pkgcache.bin. apt will then re-create them, using the local information, the next time it’s run with ...


0

FYI, in 2021, the below is not valid anymore. deb-src http://archive.ubuntu.com/ubuntu/ xenial main restricted universe multiverse Use apt-add-repository instead: apt-add-repository http://archive.ubuntu.com/ubuntu/


0

Installing pulseaudio worked, likely due to an upgrade of some package. I only did an upgrade of my packages, rebooted and then ran this command which ran through without removing any packages; it also installed "rtkit": sudo apt-get install pulseaudio/buster-backports libpulse0/buster-backports libasound2-plugins. I then rebooted and checked that ...


3

I don’t think there’s a way to get a single apt invocation to both show the URLs and download the files, but if you want to curl the files anyway, you can ask apt to list the URLs instead of downloading the files: $ apt download --print-uris libvirglrenderer0 'http://deb.debian.org/debian/pool/main/v/virglrenderer/libvirglrenderer0_0.7.0-2_amd64.deb' ...


4

Comment or delete the deb cdrom: line at the top of /etc/apt/sources.list to get rid of the error message and remove all duplicate entries in /etc/apt/sources.list.d/wine.list to get rid of the warning messages.


0

I am using Debian 10 buster and I had the same issue with wine32. Seems the approach mention above was working since some update of Debian 10.9. I resolve it that way: $dpkg --print-architecture && dpkg --print-foreign-architectures amd64 i386 $sudo apt remove wine && sudo apt purge wine $sudo apt remove wine64 && sudo apt purge ...


1

Since you seem to be running Debian 10, the simplest fix for this is to remove the Jessie repositories: sed -i.bak /jessie/d /etc/apt/sources.list{,.d/*.list} Those repositories are no longer being updated, and there’s little reason to use any package from them.


2

The http://mirror.kku.ac.th/kali mirror is outdated, providing the old version mpack_1.6-8.2. You can choose a different mirror from Kali Mirrors. Use the following commands: printf "%s\n" "deb http://mirror.easylee.nl/kali/ kali-rolling main non-free contrib" |\ sudo tee /etc/apt/sources.list sudo apt update sudo apt install mpack


Top 50 recent answers are included