Questions tagged [apt]

For questions about the use, design, function etc. of APT (Advanced Packaging Tool), the standard software package management system for Debian and its derivatives.

Filter by
Sorted by
Tagged with
0
votes
0answers
17 views

apt-cacher-ng with https package, release does not have release file

I have setup an apt-cacher-ng and configured it to works with https. On most https/http package apt update works. Into apt-cacher-ng server conf i added PassThroughPattern: .* and for each https ...
0
votes
1answer
15 views

Manage manually compiled ViM (Debian)

I installed ViM by compiling the source code from GitHub and then I used checkinstall to install it on my system. Now I'd like to install another program with the apt package manager (which is vifm), ...
1
vote
1answer
21 views

apt certificate chain uses insecure algorithm

we host a local mirror for Ubuntu and Debian packages. root@apt-mirror:~# dpkg -l | grep mirror ii apt-mirror 0.5.4-1 all ...
-1
votes
0answers
26 views

E: Type 'Usage:' issue

I'm trying to install anaconda3 via apt-get but each time I try I get the following errors. E: Type 'Usage:' is not known on line 1 in source list /etc/apt/sources.list.d/sublime-text.list E: The ...
2
votes
1answer
175 views

Debian default installation package list?

I am trying to understand how APT works, and here is where I got stuck - who determines what packages are installed, on day-one? It seems that one of the rules is, based on the current snapshot of ...
0
votes
1answer
7 views

libcups2-dev won't install because of libcupsimage2-dev

I'm running Raspbian and want to install Splix, for which I need libcupsimage2-dev, so I installed it using apt-get, which yielded an error saying it has a dependency on "libcupsimage2-dev" which won'...
-2
votes
0answers
17 views

apt install / recommended packages separated by pipe [duplicate]

When I tried to install docker-ce on my Linux distro, I got the following message: Recommended packages: aufs-tools cgroupfs-mount | cgroup-lite pigz Does it mean: 1/ (A and B) OR (C and D)? 2/ A ...
1
vote
1answer
44 views

What is the apt/dpkg equivalent of `pacman -Qs`?

Pacman/Rosetta suggests using aptitude or apt-file to perform local package query, however neither are provided in my environment (termux). apt search -a --installed package-name* The above command, ...
0
votes
1answer
26 views

`Package has no installation candidate` on Debian but not on Ubuntu

I'm using Docker with the php-fpm image, which uses Debian Buster as its OS. I'm a bit confused as why these two packages: php-smbclient and php7.3-sybase are not able to be installed, as they are ...
3
votes
2answers
39 views

Print first word of the output

I've been looking around and haven't found what I'm trying. I have to say I'm petty poor with grep, sed and awk though. I have an alias: alias upgradable='apt list --upgradable' and it gets me ...
0
votes
1answer
19 views

Where to download cryptsetup-luks-devel package?

How to download and install cryptsetup-luks-devel package for Debian? I can't find it. When I google I get this package only for CentOS.
0
votes
0answers
41 views

Can an “apt upgrade” automatically install a dependent package that replaces an installed package?

Our team has gotten off into a dark corner of how apt updates work, and we could use some help finding our way out. The context here is a set of deployments from a local repository. We have a package,...
0
votes
0answers
39 views

Ubuntu 18.04 LTS: Manually uninstalled Virtualbox and now can't install again

I recently installed VirtualBox, but I accidentally didn't sign the kernel modules while installing. This resulted in VirtualBox running, but I was unable to run a VM. First, I tried signing the ...
0
votes
2answers
38 views

Clarification of some Ubuntu commands

So just wondered what happens when I run these commands (specifically on Ubuntu): # Add NVIDIA package repositories wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/...
0
votes
1answer
36 views

Debian Tor Node - Can't update to newer version

I run a tor node on debian. Nyx says that my version (0.2.9.16 (git-9ef571339967c1e5)) is obsolete. But when I try to do apt update && apt upgrade, nothing happens, all packages seem up to ...
1
vote
0answers
78 views

E: Unable to correct problems, you have held broken packages

Recently, I botched my system and had to reinstall because I was mixing ubuntu and debian repositorys together during an upgrade from debian 9 to 10 (in this post). I have learned an important lesson. ...
1
vote
1answer
10 views

Question about pinning version of Debian package

I added a pinned configuration like below: Package: cinder* Pin: version 2:13.0.7* Pin-Priority: 1001 The version of the package installed is 2:13.0.5-0ubuntu1~cloud0. When I execute the command apt ...
1
vote
1answer
20 views

Software Center says that an app is installed, but when i check it, there is no trace of the package

New Copy of Ubuntu Eoan, and I go to download a game I like to play in my free time from the software center, OpenArena to be exact. I quickly cancel it because I have to go somewhere and don't want ...
0
votes
2answers
40 views

How to get a list of which packages were installed with apt-get by a user and not by dependencies?

Say I'm running a Debian based distro and I want to know what packages I ran apt-get install <package-name> to install, but I didn't want to include any packages that were auto-installed as ...
0
votes
0answers
38 views

what should be the 99default-release for for bullseye

I got the following error which I fixed - The value 'buster' is invalid for APT::Default-Release as such a release is not available in the sources Can't call method "policy" on an undefined value at ...
1
vote
2answers
54 views

Unable to install Python3 packages on Debian based OS

I am using Kali Linux (based on Debian) and below is the output of the uname -a command Linux kali 5.3.0-kali2-amd64 #1 SMP Debian 5.3.9-3kali1 (2019-11-20) x86_64 GNU/Linux I want to install the ...
-1
votes
0answers
14 views

Policykit -1 error, cant install something

OS: Debian 9.11 Hi! I am not able to install something to this computer. This happened after apt-get upgrade. I get the following errors when I am trying to install something: root@nginxproxy:/etc/...
0
votes
2answers
43 views

Mint - apt-get install -f wants to remove 447 packages

I don't often have to mess with -f so I am a little bit at a loss as to why it is trying to remove so many packages, but I do believe allot of these packages I very much use, apache2, aptitude, ...
0
votes
2answers
129 views

Error while installing or upgrading with apt

I was trying to upgrade debian 9 to 10 but when I tried to run sudo apt-get update, sudo apt-get upgrade and sudo apt-get full-upgrade, they all got this error message: optiplex@optiplex:~$ sudo ...
3
votes
1answer
112 views

Should the Debian Repository URL end with “/”?

This may not be a problem because it will work regardless of whether the URL ends with /. I just wonder if it has a standard specification? The following are from the official Example sources.list. ...
1
vote
0answers
60 views

Comfortable way to keep Debian Buster up to date?

So far I have only used Debian (and other Linux distributions based on Debian) for testing purposes and on non-productive systems. On these systems, I occasionally carried out updates manually via the ...
0
votes
1answer
36 views

Using DVD ISOs with Rolling Releases

I'm using Kali Linux for pentesting exercises. Often I find that I need to install a small utility from the repositories. Because Kali is a rolling release, and I'm not updating the OS regularly, ...
1
vote
1answer
29 views

Apt database out of sync

[Linux Mint 19.3] Not sure what happened, but I have a bunch of packages that have become conflicted with the apt database. After running apt update, (done with 3 different mirrors, including the ...
1
vote
0answers
27 views

What update commands should I use on Mint 19.3?

historically, to update my system, I used sudo apt-get update sudo apt-get dist-upgrade snap refresh but I see that now the newer apt command is recommended in Debian-based distros instead of apt-...
1
vote
1answer
48 views

How can I see when a package was released/updated using `apt`?

I want to install the "file" package using apt, since my Docker container is missing the file command. Before installing, I'm checking the package details (see below). How can I see the date these ...
1
vote
0answers
58 views

How to prevent apt upgrade from downgrading my kernel?

I needed to manually install (through apt) a specific kernel version that supports newer USB-C features for USB development -- specifically version linux-image-4.18.0-25-generic in the Ubuntu apt ...
0
votes
0answers
11 views

How to fetch previous packages after apt-get dist-upgrad / 'Smart Upgrade' via Synaptic

I did an update via Synaptic recently and, against my habit & experience (1), I did a Smart Upgrade which is the same as apt-get dist-upgrade if i'm not mistaking. Now, I want to roll back that ...
-2
votes
1answer
82 views

GPG: Unsupported Binary Format

Getting this error on running following command sudo apt-get update Error: GPG error: http://ubuntu-cloud.archive.canonical.com/ubuntu precise-updates/grizzly Release: Detached signature file '/var/...
0
votes
0answers
25 views

How Do I Revert KDE Neon To Kubuntu?

I have KDE Neon on my laptop at the moment, but due to various reasons, the rest of my computers in the house are now running Kubuntu. I'd like to make everything the same so I am wondering how to go ...
2
votes
1answer
39 views

APT complains of broken/unmet dependencies for my package, but they are available in my repository. How to fix?

I manage an apt repository, for package PACKAGE, which has dependency (DEPENDENCY<<1.2). Both PACKAGE and DEPENDENCY are available in my repository. We just released a version of DEPENDENCY (...
0
votes
1answer
21 views

Setting file capabilities in deb package fails

So, there is my piece of software, that has to be distributed via deb-packages, it contains a small custom server. That server requires ability to listen on a priviledged port, because explaining to a ...
0
votes
2answers
647 views

pip not working and apt cannot reinstall python using kali 2019.4 on vmware

I installed kali 2019.4 from kali.org on a vmware machine. However, pip does not seem to be installed and I can't find the answer on how to install it. Note: I am forwarded to the internet by a proxy. ...
0
votes
1answer
30 views

Error while installing Atom Editor

I got this error while installing Atom on PopOs. What is happening here? sudo dpkg --install atom-amd64.deb (Reading database ... 215577 files and directories currently installed.) Preparing to ...
3
votes
1answer
100 views

How do I set mirrors in /etc/apt/sources.list with a Debian preseed file?

I'm building a custom ISO image of Debian 10 stable ("buster") using preseeding, and my custom preseed.cfg file works perfectly except for one thing: I'd like it to configure /etc/apt/sources.list ...
2
votes
2answers
37 views

Verbosity in aptitude command-line mode via its configuration file

This is related to a question I asked about 3 years ago. Since then things have changed a bit apparently. One of the obvious ones is that aptitude itself has changed from whatever version it was to ...
0
votes
0answers
44 views

How to install xev if it is not present

I'm teaching myself about xmodmap and some of the tutorials say that you can get the keycode of a key by using xev. When I try to run the command, I get -bash: xev: command not found Running apt-...
0
votes
1answer
25 views

Cannot locate “php-phalcon” package in APT, after cURL'ing the .deb file

In Debian 10, I follow the instructions here to a tee, I cURL the DEB file, then I enter apt install php-phalcon or php7.0-phalcon. Neither work! I don't know what's wrong It says: Unable to locate ...
3
votes
1answer
71 views

Why isn't installing with apt/yum to a home directory a mainstream feature?

This is a history related question of a sense, tightly related to the use cases of Linux. Am open to closing it if it's off topic. Why is the default to always use sudo when installing with package ...
1
vote
1answer
27 views

Will apt-get upgrade interrupt server operation?

I am running a Raspberry Pi that is providing DNS, DHCP, file sharing, and other services to my home. I want to run apt-get upgrade but do not want to interrupt other users and am unsure what happens ...
0
votes
1answer
25 views

Removing a program installed via apt and a .deb

I installed browsh via apt install (I followed the instructions below): sudo apt install ./browsh_1.6.4_linux_amd64.deb rm ./browsh_1.6.4_linux_amd64.deb (This is after I used wget to grab the .deb ...
0
votes
2answers
414 views

How to install apt-get and dpkg

I try to install apt-get on CentOS 7 (Core), but I received bash: dpkg: command not found when I tried to extract Debian files. How can I install both of them?
0
votes
1answer
89 views

How can I fix a broken package in Debian?

I am attempting to renew an SSH cert on my ReadyNAS, which runs Debian. I suspect that a firmware upgrade a few months back that updated Apache and potentially other packages may have broken my Let's ...
1
vote
0answers
21 views

Proxy Config for apt - Excluding Whole Subnets

When apt is configured to use a proxy it is possible to bypass the proxy for certain IPs using the "DIRECT" keyword. For example: Acquire::http::Proxy::"10.10.10.1" "DIRECT"; Is there a way to do ...
3
votes
1answer
73 views

Problems with apt in Raspbian where /var content has been removed or corrupt

Apparently on a production server there has been some problem and someone has deleted the contents of the /var folder. This has caused several errors that I have been solving with various services ...
1
vote
1answer
92 views

debian repo: unable to fetch

I've been trying to install pgAdmin4 from postgresql repositories, but I keep getting following error: Err:1 http://deb.debian.org/debian buster/main amd64 python3-werkzeug all 0.14.1+dfsg1-4 404 ...