4

After a long search, I actually managed to find an answer. This might be helpful for others looking for something like this out there! What you need: pacmd list-sinks This command has a line like this: muted: no And this no indeed does change to yes, when I mute my device. Perfect. I managed to strip the output using this command, should anyone need it: ...


3

1. Software switching support Check, if your sound card supports software switching for the front audio panel. Some older motherboards don't support software switching at all. Some sound cards have connectors for both variants on the motherboard: software and hardware switching. In this case, make sure from your motherboard manual, that you use the connector ...


3

You are seeing the pulse plugin control, which only has a single volume control. Try using F6 to access the hardware control(s) of your sound card(s). However, since you are now running Pulseaudio as your main audio system (possibly you rebooted for the first time because of the cleaning, and it's the consequence of some update you did a longer time ago?), ...


3

Alternatively, for those like me who don't have PulseAudio or want to only use amixer, one solution is: amixer get Master | sed 5q | grep -q '\[on\]' returning 0 if unmuted and 1 if muted.


2

Based on the comment about muting left or right channel: The combined jacks (headphone + mic), and also the headphone jacks have several rings, which are assigned to ground, left, right and mic. There are several different standards. If somewhere, either in the extender cable and/or in the front jack, these assignments are mixed up because of an error ...


2

Guess: The laptop BIOS is lying to ALSA, and giving it a wrong headphone jack codec node which always detects "connected". Look at your analog codec with cat /proc/asound/card*/codec\#* and use hdajackretask from package alsa-tools-gui to correct this if it is true. Also see here for background information. I don't know why it happened "suddenly", and ...


1

In modern notebooks, the speakers are often disabled (by the hardware controller) when you plug in your headphones. This is not Linux specific, but a feature of the machine itself. This is, for example, the case with my ThinkPad T490s.


1

Found this page following up post by Manjaro user with same Realtek ALC294 ALC294 Analog - Audio card detected, but no sound internaly or headphones Also found this page from ubuntu user indicating cause of problem No sound output - Ubuntu 17.10 - ASUS Zenbook 13 All 3 appear to be same problem caused by windows 10 shutdown Web search results show no other ...


1

The asym plugin is a PCM plugin; it is not possible to apply it to ctl devices. This configuration has never worked. If you did not get this error before, then it probably got overridden by a later definition somewhere else. Remove that ctl asym definition. You'll have to select the respective sound device in alsamixer (as you probably already did).


1

This is one of the mixer settings, so removing modules won't help. In alsamixer, use left and right arrows to move the red highlight to Loopback, then up and down arrows to enable and disable it. If this doesn't work for some reason, you can also use amixer to display and set the mixer controls from the command line. Make sure to select the right card with ...


Only top voted, non community-wiki answers of a minimum length are eligible