Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
Search type Search syntax
Tags [tag]
Exact "words here"
Author user:1234
user:me (yours)
Score score:3 (3+)
score:0 (none)
Answers answers:3 (3+)
answers:0 (none)
isaccepted:yes
hasaccepted:no
inquestion:1234
Views views:250
Sections title:apples
body:"apples oranges"
URL url:"*.example.com"
Favorites infavorites:mine
infavorites:1234
Status closed:yes
duplicate:no
migrated:no
wiki:no
Types is:question
is:answer
Exclude -[tag]
-apples
For more details on advanced search visit our help page
Results tagged with Search options user 21109

SSH (Secure SHell) is a protocol for securely running commands on a remote computer. Use this tag for questions about configuring, using and trouble-shooting SSH client and server software.

3
votes
You can use netcat for this. Here's an example setup: On machine A, your ~/.ssh/config looks like this: Host machinec.whatever.domain.com ProxyCommand /usr/bin/ssh machineb /usr/bin …
answered Mar 27 '13 by Jenny D
5
votes
SSH normally does print out error messages. There are two ways to disable it: In your .ssh/config, a line containing Loglevel QUIET will disable all messages. Using the option -q, or aliasing ssh to ssh -q, will do the same thing. So make sure that none of those mechanisms have been used. …
answered Jan 27 '14 by Jenny D
8
votes
An option in the config file is applied the first time it matches. Since you don't have any ProxyCommand in the host entry, the one in your * entry will be used. There are two ways to get around this …
answered Aug 26 '14 by Jenny D
54
votes
on Linux, you can instead use pkill -o -u YOURUSERNAME sshd to kill your oldest SSH session. Continue doing that until your current session is the only one left. You might also want to set … ServerAliveInterval 15 in your .ssh/config to send a keepalive message every 15 seconds when no data has been sent. man ssh_config for more information. …
answered May 2 '14 by Jenny D
2
votes
There are two possible issues here: Something may already be listening on port 1500 Port forwarding may be disallowed in the SSHD config on the target server To find out if something is already li …
answered Sep 10 '13 by Jenny D
13
votes
Four ways: To just connect once to a system with a new host key, without having to answer questions, connect with the following option: ssh -q -o "StrictHostKeyChecking no" this.one.host.name To … permanently remove the warning for all systems, edit your ~/.ssh/config file to add the following lines: Host * StrictHostKeyChecking no To permanently remove all warnings for this one server, edit …
answered Jan 23 '14 by Jenny D
4
votes
sshd logs there, check your syslog config for where authpriv messages go. Check the SSH public key returned by the server. Do this by running the command ssh-keyscan hostname > hostname-lan.pub on the … lan , and ssh-keyscan hostname > hostname-wan.pub on WAN. Then compare the two files (diff hostname-lan.pub hostname-wan.pub). If you're reaching the same server, there should be no difference …
answered Jan 27 '14 by Jenny D
1
vote
points to port 8080 (or some other unused port). Add a line to /etc/hosts so that the name of the repository server points to 127.0.0.1. On your own server, start an SSH tunnel. It should do … forwarding of port 8080 on the target system to port 80 on the repository server. ssh -R 443:repository.example.org:80 theserver …
answered Mar 21 '14 by Jenny D
5
votes
Here's the culprit: drwxrwxr-x 2 emerg wheel 4096 Apr 10 11:51 .ssh/ You're allowing anyone in the group wheel write access to your .ssh directory. This means that any member of that group could … replace your authorized_keys file - so SSH refuses to trust the file. Fix your permissions and the problem should go away. …
answered Apr 10 '14 by Jenny D
7
votes
In order for public key authentication to work, the SSH daemon needs to be sure that the key in the authorized_keys file can't be tampered with by anyone other than the owner (and root, of course … ). This means that the write permissions of the user's ~/.ssh directory, and all directories leading up to it from / must be restricted so that only the owner (and root) can write to them. So if your …
answered Apr 9 '14 by Jenny D
4
votes
In addition to all the previous answers, here's one that relies on SSH keys with restrictions on what can be done when logged in with that key. On server A On this one it's less important if you … bkpuser, create an SSH key without a password. On server B Enable PubkeyAuthentication in sshd_config. Create the user bkpuser. Set a very complicated password, or disable password login for that …
answered Apr 6 '14 by Jenny D
4
votes
Instead of scripting your own, I'd recommend using pssh. It's got built-in features for passing the password to ssh, parallellizing the process, error handling and so on. It's a good wheel, no need to invent another one. …
answered May 2 '14 by Jenny D
5
votes
detached screen sessions. Note that this command doesn't work if the session is password protected. To combine this with actually seeing the screen: ssh root@server "screen -dr -X … ./run_script && screen -RD" (But you really should not allow ssh logins as root, it's very bad practice from a security standpoint.) …
answered Jul 2 '15 by Jenny D
7
votes
If running the script is the only thing you want those other users to be able to do, then I'd go with using ssh keys. Each user should have their own ssh key, so you won't get into a hassle when … somebody no longer needs access. The public part of the key should be put into ~scriptuser/.ssh/authorized_keys and in front of the actual key, you should add the text command="/path/to/script …
answered Jan 7 '13 by Jenny D
1
vote
Given your description of the solution, you must have made some error with the group permissions when you set the chroot up. Since you've deleted and re-created everything, it's hard to figure out exa …
answered Oct 13 '14 by Jenny D

15 30 50 per page