I have been following [this doc](https://www.vagrantup.com/docs/getting-started/up.html) on Vagrant.

I installed VirtualBox and Vagrant, then created a folder and ran `vagrant init` and `vagrant up`. When I typed `vagrant ssh` I got this message:

    The private key to connect to the machine via SSH must be owned
    by the user running Vagrant. This is a strict requirement from
    SSH itself. Please fix the following key to be owned by the user
    running Vagrant:
    
    /media/***/Vagrant/.vagrant/machines/default/virtualbox/private_key

I have read some article related to this problem. I think I have to add the key to my system or something about verifying the key. But I am not clear about the most solutions. Anyway, it would be nice if someone could give me a solution for this.

Also when I try to access my virtual running os from VirtualBox UI it ask for username and password. But while I was setting up vagrant and VirtualBox I did not insert any username or password. So I don't know why it is asking for username and password.