1 of 3

Unable to install skype on LMDE,how to resolve these dependencies?

I have downloaded "multiarch" .deb file for latest skype and unable to install it on latest version of LMDE (linux mint debian edition Xfce x86_64). e.g

1) step one :

sudo dpkg -i skype-debian_4.1.0.20-1_i386.deb 

output:

 dpkg: dependency problems prevent configuration of skype:
 skype depends on libqt4-dbus (>= 4:4.5.3).
 skype depends on libqt4-network (>= 4:4.8.0).
 skype depends on libqt4-xml (>= 4:4.5.3).
 skype depends on libqtcore4 (>= 4:4.7.0~beta1).
 skype depends on libqtgui4 (>= 4:4.8.0).
 skype depends on libqtwebkit4 (>= 2.1.0~2011week13).

2) step two (trying fix broken) :

sudo apt-get install -f

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libapache2-mod-php5filter
Suggested packages:
  php-pear
The following packages will be REMOVED:
  libapache2-mod-php5 php5-cli skype:i386
The following NEW packages will be installed:
  libapache2-mod-php5filter
0 upgraded, 1 newly installed, 3 to remove and 3 not upgraded.
1 not fully installed or removed.
Need to get 0 B/2,663 kB of archives.
After this operation, 44.9 MB disk space will be freed.

Here my main concern is the way its removing my LAMP related files e.g:

The following packages will be REMOVED:
libapache2-mod-php5 php5-cli skype:i386

I need a way to install skype without upsetting other installed applications.

The sudo apt-get install -f just removes and does not fixes the dependencies.

I ll appriciate if someone write step-wise commands for the installation of skype and while keeping LAMP intact, and explain why the apache and skype are colliding .