3 of 4 added comments and output from lspci after switching driver

Bad wifi with MacBook Air mid 2012

I have a MacBook Air mid 2012 with i7 CPU. The one with Ivy Bridge.

I have connectivity problems with wifi running Arch Linux which I keep updated regularily. Throughput and response time performance decrease a lot when I move away from the AP (tried several networks with similar results).

Strangely I don't experience the same issues with OS X. I have tried switching between Mountain Lion and Arch Linux while staying in the exact same position. OS X performs perfectly while Linux can't even ping the router.

Are there any settings that I am missing? Should I use some particular driver? I have tried to read up on and fiddle with iwconfig.

Any suggestions are welcome, I'm quite new at this level of Linux configuration.

lspci gives me

02:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)

Trying to change power with iwconfig gives me:

-> % sudo iwconfig wlan0 power off
Error for wireless request "Set Power Management" (8B2C) :
SET failed on device wlan0 ; Operation not supported.

Addition: I installed the broadcom-wl driver. The connection seams to be a little bit more stable. But there is still a long way to go compared to OS X.

lspci now reports

02:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)
Subsystem: Apple Inc. Device 00e9
Kernel driver in use: wl