1 of 2

Try disabling the 'Enable Automatic Login' in the 'Auto Login' tab from 'Login Window Preferences'.

If that does not work then you have to edit the '/etc/mdm/mdm.conf' and set

AutomaticLoginEnable=false