The Stack Overflow podcast is back! Listen to an interview with our new CEO.
2 of 2 Added additional information.

This is an awful answer, but its provided for completeness. The kernel was updated today. The old Fedora kernel was 4.9.13-200.fc25.x86_64. The new kernel is 4.9.13-201.fc25.x86_64.

After the kernel updates, I manually delete the old kernel from /boot using rm. This is a standard procedure for me on Linux (I always perform it to remove unwanted cruft). In this case, I ran:

su -
cd /boot
rm -rf *4.9.13-200*
rm -rf .*4.9.13-200*

After manual removal, I regenerate the Grub menu and then reboot. This is also a standard procedure for me on Linux.

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

After the reboot, the old name was no longer present:

$ dmesg | egrep -i '(bulldozer|skylake)'
[  0.065941] Performance Events: PEBS fmt3+, Skylake events, 32-deep LBR, full-width counters, Intel PMU driver.
[  1.096957] systemd[1]: Set hostname to <skylake>.

So, something affected the hostname used by systemd, but I am not sure what it was.

I tried regenerating grub.cfg previously, so I'm not convinced its the answer. I'm guessing a package triggered the correction, and after the reboot I observed things were as expected.