I've seen several times people with unmet dependencies, which apt-get doesn't tells straightforward what's the problem, like this one:

    The following packages have unmet dependencies:
     libgl1-mesa-dri:i386 : Depends: libdrm-intel1:i386 (>= 2.4.38) but it is not going to be installed
                            Depends: libdrm-nouveau2:i386 (>= 2.4.38) but it is not going to be installed
                            Depends: libdrm-radeon1:i386 (>= 2.4.31) but it is not going to be installed
                            Depends: libdrm2:i386 (>= 2.4.38) but it is not going to be installed
                            Depends: libglapi-mesa:i386 but it is not going to be installed
     libgl1-mesa-glx:i386 : Depends: libdrm2:i386 (>= 2.3.1) but it is not going to be installed
                            Depends: libglapi-mesa:i386 (= 9.2.1-1ubuntu3) but it is not going to be installed
                            Depends: libx11-6:i386 (>= 2:1.4.99.1) but it is not going to be installed
                            Depends: libxcb-dri2-0:i386 (>= 1.8) but it is not going to be installed
                            Depends: libxcb-glx0:i386 (>= 1.8) but it is not going to be installed
                            Depends: libxcb1:i386 but it is not going to be installed
                            Depends: libxdamage1:i386 (>= 1:1.1) but it is not going to be installed
                            Depends: libxext6:i386 but it is not going to be installed
                            Depends: libxfixes3:i386 but it is not going to be installed
                            Depends: libxxf86vm1:i386 but it is not going to be installed

I know that walking through all dependencies `apt-get install libgl1-mesa-dri:i386 libdrm-intel1:i386` until I hit something is available, but in this case it will be a painful job due the amount of packages. Is there an easier way to do this?