# Short answer
It's a bug.

# Full answer
It looks like the "correct" visualisation is the one on the left, where the **bold font** are **not** rendered. For what I could understand ([here](https://github.com/seebi/dircolors-solarized#bold-settings) is the reference) the bold attribute was used, originally, to set the *highlighted* version of the 8 base colours.

> *Historically, there has been a one-to-one correspondence between the bolded versions of the 8 default ANSI colors and the bright versions of the 8 default colors. Back in the day, when a color program demanded the display of bold text, it was probably just easier for terminal emulators to display a brighter version of whatever color the text was (and expect the user to interpret that as bold) than to display a typeface with a bold weight.*

Basically, what is happening here is that, in order to use the full *Solarized* palette, with the *orange*, *purple* and all the levels of *grey*, the colours are called with the *bold attribute*, which in turn refers to the *alternative* 8 colours of the ANSI palette.

*Terminal* understands this correctly, and shows the *orange* and the *comment grey* in *normal* typesetting, whereas *tmux* adds an unnecessary *bold* font to them. In conclusion, the right side is correct whereas the right one is not.

# Further question
Is there a way to *disable* the bold rendering of *tmux*?  
I still have to do some research about it, and I will update this answer as soon as I find something.