3 of 4 comment formatting, Grammar

java upgrade problem on centos 6.5

I want to upgrade my jdk on a CentOS server, after some simple searches I found some solutions.

From this link, you can see that the instructions are simple: jdk 7 installation guide for centos

-install your chosen jdk from rpm package or from source

-possibly choose some alternatives

-check that the new version installed (java -version)

The first two steps above, I easily completed, but in check version step I get this error:

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

I have also checked alternatives --config java and symbolic links.

I have also tried which command to find out what java is actually running and this was the link directions.

/usr/bin/java -> /etc/alternatives/java -> /usr/java/jdk-1.8.0_40/bin/java

the weird thing is that when I run /usr/bin/java -version it is OK and it returns the version but when I run java without any prefix I got that error.

So what could the problem be?