I have been using Jessie for a few months now, and I had a problem booting my computer a few weeks ago.

I had this error on boot:

    early console in decompress_kernel

    Decompressing Linux... Parsing ELF... done.
    Booting the kernel.
    Loading, please wait...
    fsck from utils-linux 2.25.2
    /dev/mapper/fabienm-root: clean, 12578/262144 files, 179719/1048576 blocks
    Gave up waiting for /usr device. Common problems:
    - Boot args (cat /proc/cmdline)
      - Check rootdelay= (did the system wait long enough?)
    - Missing modules (cat /proc/modules; ls /dev)
    ALERT! /dev/mapper/fabienm-usr does not exist. Dropping to a shell!
    modprobe: module ehci-orion not found in modules.dep

    BusyBox v1.22.1 (Debian 1:1.22.0-9+deb8u1) built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    /bin/sh: can't access tty; job control turned off
    (initramfs)

If I select the `3.16-2-amd64` kernel in Grub, that boots "correctly?" and produces this log:

    early console in decompress_kernel

    Decompressing Linux... Parsing ELF... done.
    Booting the kernel.
    [    0.000000] tsc: Fast TSC calibration failed
    Loading, please wait...
    [    6.300000] systemd-fsck[173]: /dev/mapper/fabienm-root: clean, 12578/262144 files, 179719/1048576 blocks
    [    8.700000] [drm:cpt_set_fifo_inderrun_reporting] «ERROR» uncleared pch fifo underrun on pch transcoder A
    [    8.700000] [drm:cpt_serr_int_handler] «ERROR» PCH transcoder A FIFO underrun
    [    9.000000] systemd-fsck[432]: /dev/sdb1: clean, xxx/xxx files, xxx/xxx blocks
    [   11.200000] systemd-fsck[553]: /dev/mapper/fabienm-var: clean, xxx/xxx files, xxx/xxx blocks
    [   11.600000] systemd-fsck[560]: /dev/mapper/fabienm-home: clean, xxx/xxx files, xxx/xxx blocks
    [   11.700000] systemd-fsck[564]: /dev/mapper/fabienm-usr: clean, xxx/xxx files, xxx/xxx blocks
    [   11.900000] systemd-fsck[578]: /dev/mapper/fabienm-tmp: clean, xxx/xxx files, xxx/xxx blocks
    [FAILED] Failed to start LSB: VirtualBox Linux kernel module.
    see 'systemctl status virtualbox.service' for details.
    [  OK  ] Started LSB: Start or stop the inetd deamon..
    [  OK  ] Started LSB: KernelNFS server support.
    ...

Once I booted with this working kernel, I can look at /proc/cmdline:

    $ cat /proc/cmdline 
    BOOT_IMAGE=/boot/vmlinuz-3.16-2-amd64 root=/dev/mapper/fabienm-root ro quiet

This kernel works well with all Debian packages except for Virtualbox, which requires `3.16.0-4-amd64` kernel to work.

Does someone has a clue how to enable the `3.16.0-4-amd64` kernel to boot on Jessie?