Questions tagged [yum]

Yellowdog Updater Modified (yum) is an interactive, rpm based, package manager.

Filter by
Sorted by
Tagged with
1
vote
2answers
38 views

how to open running yum command if the terminal is closed mistakenly

I ran the command yum install without -y parameter, and after I hit enter the terminal is closed mistakenly and now the yum is lock and I cannot do any further operation. While searching I ...
0
votes
1answer
642 views

yum install dependency problem

I want install ansible on server without internet and I have this error : Error: Package: 1:openssl-devel-1.0.1e-60.el7.x86_64 (@local-repo) Requires: openssl-libs(x86-64) = 1:1.0.1e-60....
3
votes
1answer
4k views

Centos 7 gcc 8 installation

GCC 8 is out for a white and I would like to test on CentOS 7, but no devtoolset-8 yet in yum. I found https://cbs.centos.org/koji/packageinfo?packageID=7198 but this is cbs; Can I have it as a ...
1
vote
2answers
113 views

How query custom installed rpm package

How query custom installed rpm package Generally if i need to query rpm based package I use following commands rpm -qi package rpm -ql package # to get installed binaries of package rpm -qf ...
1
vote
1answer
3k views

Download all RPM packages from CentOS repo?

I have a server that should contain all the RPM packages downloaded from CentOS repository so that I can reach that server from another server which hasn't got internet access and get the up to date ...
0
votes
1answer
988 views

yum get rid of “unfinished transactions remaining”

yum xxx ... There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them. I don't want to finish the transaction, how do I just nuke it? ...
2
votes
0answers
260 views

REPO Error: HTTP Error 403 - Forbidden during firefox-compat install from AWS EC2 instance

tmp]$ sudo yum --enablerepo=epll install firefox-compat Loaded plugins: priorities, update-motd, upgrade-helper Could not retrieve mirrorlist http://repo.lambda-linux.io/2018.03/epll/x86_64/os/mirror....
-1
votes
1answer
2k views

How to install tmux on Centos?

When I execute yum install tmux, it gives me an error: Setting up Install Process No package tmux available. Error: Nothing to do Any idea on how to solve this issue?
0
votes
0answers
42 views

How can yum etc. have failed dependencies?

Isn't the purpose of yum et al to find the dependency tree and install them in one go? Why does it sometimes seem to do just that and other times just give a simple error? If the wrong version is ...
0
votes
0answers
1k views

No packages in any requested group available to install or update When I install the “X Window System”

I want to install the X Window System in my remote CentOS 7.2(I use ssh login to the server) , but get bellow error: [root@localhost ~]# yum groupinstall "X Window System" Loaded plugins: ...
0
votes
1answer
36 views

How do we update the Kernel for a Oracle Linux OS while leaving the OS Version same?

I have tried to update the kernel for an Azure VM running Oracle Linux 7.2. I wanted to update the kernel version that was showing 3.10 and when I ran the yum update command, it upgraded all the ...
1
vote
1answer
549 views

yum install fails with 401 Authorization required [closed]

I am running Red Hat Linux 6.2 Trying to install nfs packages using yum Following is the repository list repo id repo name ...
-2
votes
1answer
1k views

How to Install telnet through a file?

I need to install telnet in a remote server (Centos 7), but when I use yum install, the process is stuck in finding mirrors (probably because the server lacks accessibility). I had the same problem ...
0
votes
1answer
118 views

What should I use for install in this distro?

I don't know how should I install apps with this distro: $ cat /proc/version Linux version 3.10.0-714.10.2.lve1.5.19.3.el7.x86_64 (mockbuild@buildfarm02.cloudlinux.com) (gcc version 4.8.5 20150623 (...
1
vote
2answers
413 views

How to update Firefox offline to a specific version on Centos 6.9

I'm trying to install a specific version of Firefox (52.8) on Centos 6.9. I've used "yumdownload --resolve firefox...x86_64". It created a folder the firefox rpm as well as 5 or six other dependencies....
0
votes
3answers
216 views

Why does rpm -i <package> fail on a dependency that I have installed?

I tried installing the following package: [root@localhost ~]# rpm -i libmicrohttpd-0.9.22-1.el7.centos.x86_64.rpm But I got an error for failed dependencies: [root@localhost ~]# rpm -i ...
1
vote
1answer
594 views

Issue with elrepo-kernel: packages are not available

I am having quite a problem with yum and elrepo. Let me start from the very beginning. There is a local machine with CentOS 7: $ uname -a Linux vt001.localdomain 3.10.0-327.36.3.el7.xppsl_1.4.3....
2
votes
2answers
197 views

yum stopped wokring on my ec2 instance

I have an EC2 instance on which I was trying to install spark.I removed the required system python version from the system by mistake and nothing relying on python seems to work now including yum and ...
1
vote
0answers
30 views

unable to install phpmyadmin in RHEL 6

I am using red hat 6.0 Linux.Currently php 5.3.2 is installed.I want to install phpMyAdmin in it.for that php5.5 is required. I already installed epel ,remi repository in my system. I am trying to ...
1
vote
0answers
436 views

What's the difference between the `php71` and `php71w` in the yum repos?

I use yum list *php71*, there shows: ... php71-php-zstd.x86_64 0.4.14-1.el7.remi ...
0
votes
1answer
983 views

No package available of `libc-client-dev` and `libkrb5-dev` in CentOS 7

I install the libc-client-dev and libkrb5-dev in my CentOS 7.2 Server: [root@localhost ~]# yum install -y libc-client-dev libkrb5-dev Loaded plugins: fastestmirror Loading mirror speeds from cached ...
1
vote
2answers
2k views

How to locate a package installed by yum?

I use yum list php-imap list the php-imap: # yum list php-imap Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirrors.zju.edu.cn * epel: ftp.cuhk.edu.hk * extras: ...
0
votes
3answers
222 views

How to identify the package manager used to install software in CentOS?

On my CentOS 7.2 Server: [root@localhost data]# which php /usr/local/bin/php [root@localhost data]# ll /usr/local/bin/php lrwxrwxrwx. 1 root root 29 Jun 25 08:13 /usr/local/bin/php -> /usr/local/...
0
votes
1answer
392 views

The CentOS7.2 yum can not find the `libc-client-devel`

The CentOS7.2 yum can not find the libc-client-devel. # yum install -y libc-client-devel Loaded plugins: fastestmirror base ...
0
votes
1answer
216 views

How do I install 32 bit package in a 64 bit SUSE machine using zypper?

If I have to install a package( 64-bit ) I use - zypper install -y MozillaFirefox which is same as zypper install -y MozillaFirefox.x86_64 for a 64 bit machine. If I use zypper install -y ...
-3
votes
2answers
5k views

yum Package Install on RHEL reports “This system is not registered with an entitlement server”

I download Red Hat Enterprise Linux today, and when I try to install a package, I get: [root@localhost yum.repos.d]# yum install openssh Loaded plugins: langpacks, product-id, search-disabled-repos, ...
4
votes
1answer
352 views

yum update shows three exclamation marks

yum update Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile gitlab_gitlab-ce/x86_64/signature | 836 B 00:00:00 gitlab_gitlab-ce/x86_64/signature | ...
1
vote
1answer
46 views

How to recover from a major mistake that breaks yum

I was attempting to update my CentOS 7 system tonight and kept getting an error from python-urllib3. I tracked down the error to a directory that should not have been present. So, I went to remove ...
13
votes
2answers
2k views

Accidentally deleted yum.conf

I don't know what I was trying to do but I basically deleted yum.conf. I found an old config for yum on github but it still doesn't work. What do I do? I am using Centos 7.
5
votes
1answer
4k views

CentOS python3 package difference between python36 and python36u

I'm seeing 2 packages for Python 3 with the same name, when using search: $ yum search python36 And I'm not sure what's the difference between them? Why have 2? python36.x86_64 : Interpreter of the ...
1
vote
1answer
2k views

Can't find php-zip extension for php 7.1 on CentOS 7

I am attempting to install Magento 2.2.5 on a new CentOS 7 server with PHP 7.1. I can't seem to find how to install and/or enable the php-zip extension. The issue I'm trying to resolve is this (via ...
0
votes
0answers
164 views

devtoolset-1.1 install fails with Centos 7 docker container after working for months

This was working until recently. yum -y install wget gmp-devel rpm-devel mpfr-devel rpm wget -O /etc/yum.repos.d/slc6-devtoolset.repo http://linuxsoft.cern.ch/cern/devtoolset/slc6-devtoolset.repo ...
1
vote
1answer
231 views

How to access the “Software Update Preferences” GUI on a RHEL 7 server?

I have numerous RHEL 6 servers and we configure automatic updates using the "Software Update Preferences" GUI, however I cannot locate the same GUI on a newer RHEL 7 server. This is the GUI that I am ...
0
votes
1answer
99 views

Error running vlc on Redhat Enterprise Linux 7

I have installed vlc using following commands- #> yum install vlc #> yum install vlc-core When i try to run vlc, i am getting the following error- [0000000001bce288] core demux error: ...
0
votes
0answers
67 views

Missing cc1 executable on Amazon Linux

I've been trying to build Tensorflow on Amazon Linux (2016.09). I'm struggling with not being able to get cc1 to install with GCC. Here's what I've tried: Installing gcc Installing gcc-c++ Installing ...
0
votes
1answer
168 views

YUM and dependencies, how do they work

I would like to install gcc on a RHEL 7.4 server and i don't have internet connection on it. For that, i have mounted a RHEL 7.4 iso and configured a yum repository file named LocalRepo to install ...
1
vote
1answer
68 views

Cannot build RPM packages from SRPM using mock

I've successfully built the SRPM and after that step I'm trying to build the RPM from the SRPM. Following is the directory from where I am building the RPM. THe Source RPM are in the following ...
-1
votes
1answer
24 views

How to install Samba on Redhat 6, getting error [closed]

I'm having trouble installing Samba (and really any other programs and services) on my Redhat 6 server. I keep getting this error: I've been having this trouble when using the yum command. So I've ...
-3
votes
1answer
337 views

How to install OS packages using yum?

I need to install below packages: gcc: gcc-c++-4.4.7-3.el6.x86_64 Flex: flex-2.5.35-8.el6.x86_64 Bison: bison-2.4.1-5.el6.x86_64 Glib: glib2-devel-2.22.5-7.el6.x86_64 & glibc-devel-2.12-1....
1
vote
1answer
78 views

Using 'rpm -i' to install a package on CentOS6 but getting dependency error, even though I have installed the dependency, why?

Operating System = CentOS 6 I'm trying to install a package as follows: rpm -i package_name.rpm But I get the following error: error: Failed dependencies: sqlite >= 3.7.15 is needed by ...
1
vote
1answer
470 views

Unable to update bind in CentOS 7?

I am trying to update bind in centos using this command. $ sudo yum update bind Getting this error Transaction check error: file /usr/libexec/setup-named-chroot.sh from install of bind-chroot-32:...
4
votes
3answers
1k views

Centos 7, I thought “yum install ___” was supposed to get all the dependencies, too?

I want to install Trillian onto my CentOS 7 box. I went to www.trillian.im/get/linux/6.1/linux.html and downloaded the rpm package trillian-6.1.0.5-1.fc25.x86_64.rpm. It was my understanding that ...
0
votes
1answer
464 views

How do I repair a bad update in Fedora 28?(edited) [closed]

I was updating my laptop when an electrical blackout happene. I restarted and try to use again sudo dnf update, but this happened: The downloaded packages were saved in cache until the next ...
0
votes
1answer
55 views

`dnf` & `yum` list packages by popularity? [closed]

How do I use dnfor yum to list all packages, sorted by popularity (assuming that this is an available feature)? I don't have a rigorous definition of popularity, but a standard metric such as number ...
0
votes
0answers
18 views

How do i roll back install and uninstall of yum?

I am doing some installs and some installs and run into a dependency hell after a while because i have many repositories enabled.I am unable to fix the problem. Can i do something so that i can ...
1
vote
1answer
60 views

Creating a yum repo for network machines

We've got a RHEL 7.4 server that is registered and would like to make it a yum server for other non-internet connected servers. This particular server is allowed to be connected, but we would like to ...
1
vote
2answers
459 views

file: Compiled magic version [534] does not match with shared library magic version

I am running Amazon Linux centos however the version of the file which gets installed is 5.30. I require a later version. file: Compiled magic version [534] does not match with shared library magic ...
-1
votes
2answers
366 views

What is the difference on a system level between installing python packages with yum as opposed to pip?

I'm wondering what the difference is between pip, the Python package installer, and yum? As a means of providing some context to my question: I assume the first answer will be because PIP is only ...
0
votes
1answer
2k views

yum install openssl-devel fails

Running yum install openssl-devel leads to dependency checking errors and do not install it. I guess there is a problem in my repositories however I don't know what is wrong with my installed version ...
1
vote
1answer
8k views

CentOS 7 - No packages marked for update

With yum update I'm not able to update packages. I have tried every possible solution which is provided like yum clean, yum repolist, etc but none of this seems to solve this problem. sudo yum update ...