Skip to main content

Questions tagged [yum]

Yellowdog Updater Modified (yum) is an interactive, rpm based, package manager.

Filter by
Sorted by
Tagged with
0 votes
0 answers
8 views

`yum clean all` differs regarding handling disabled repositories

I'm porting some old build scripts from CentOS 7 to Rocky 8. I've noticed that the following command cleans all repository caches on Rocky 8, as opposed to just the caches of the one enabled ...
liori's user avatar
  • 630
0 votes
0 answers
12 views

Keep only essential packages centos,Almalinux

In an attempt to learn more about Centos,Almalinux and its packages, I want to remove all non-essential packages, so I can install what I need, when I need them and know what they do. When using ...
yassir's user avatar
  • 1
0 votes
0 answers
17 views

Why the yum repolist cannot refresh/download the metadata cache during the period of "Repodata is over 2 weeks old"

Enviroment: CentOS 7.4 with yum-3.4.3-154.el7.centos.noarch Question: Why the following yum repolist cannot refresh the metadata cache for so many years with much more longer time than its defualt ...
lylklb's user avatar
  • 313
0 votes
0 answers
30 views

How to install an RPM file on CentOS into a custom location

On a CentOS 7.8 machine I install locally present RPM files usually with sudo yum localinstall /path/to/file.rpm Now I want to install a large RPM which yum lists as 1.1GB when it would install it. ...
halloleo's user avatar
  • 589
1 vote
2 answers
47 views

Finding CentOS 7 Compatible Packages

I noticed that pkgs.org and similar platforms stopped hosting CentOS 7 packages. Is there any other place to download CentOS 7 compatible RPM packages?
yildizabdullah's user avatar
0 votes
1 answer
19 views

versionlock dependencies?

I'm on Rocky Linux 8.9. I've issued the command dnf versionlock rubygem-rdoc-6.3.3-141.module+el8.6.0+1002+a7dba0ac.noarch There are a lot of dependencies for this package. Do I have to also ...
Sarah Duncan's user avatar
0 votes
1 answer
26 views

How to check some yum configuration variables in RHEL 5

We could use the yum-config-manager to check the yum configuration variables in RHEL 6 and higher ... But in RHEL 5, there was no the yum-config-manager program, and also neither the yum-debug-dump ...
lylklb's user avatar
  • 313
0 votes
1 answer
21 views

The doubt about the mechanism forcibly refreshing status with the yum repolist

I have noticed that there would be an additional "refreshing status" process every time running with the yum repolist for a long time interval... Notes: here "a long time interval" ...
lylklb's user avatar
  • 313
0 votes
1 answer
29 views

yum and dnf incompatible for listing all history transactions

I've noticed that yum history info "*" and dnf history info "*" are different. yum shows the complete transactions themselves. But I don't know how to do this in dnf as it errors ...
Evan's user avatar
  • 1
0 votes
2 answers
34 views

Why the 3rd column of some packages in the yum list output were "installed" under the RHEL 6/7

In fact, there might be the following two sub-questions within the above problem title: 1) Whatever the development design of the rpm package structure could result in the null output of the repoquery ...
lylklb's user avatar
  • 313
0 votes
0 answers
16 views

Custom package security metadata (RPM)

I'm extremely new to packaging RPM's. I have an internal yum repository that I have RPM's for internal SSL certificates, but a few other programs/utilities that are simple enough to package that I can'...
Mose's user avatar
  • 123
0 votes
1 answer
34 views

circular dependency between yum-utils and yum-config-manager

I'm trying to build a docker image in a corporate environment. RUN yum-config-manager --nogpgcheck --add-repo http://repo.mycompany.com/rhel8-x86_64/latest/RPMS.all && \ yum-config-manager --...
mdarwin's user avatar
  • 103
0 votes
0 answers
55 views

Facing fatal errors while running "yum update" command on CentOS 7/Cloudlinux 7

I am in desperate need of help with an issue that i'm facing while updating my system with the "yum update" command. My server is CentOS 7 converted to CloudLinux 7. I've been trying to find ...
Klavorton's user avatar
0 votes
1 answer
36 views

Understanding yum error

Here is the error message I get when I try to do a yum update. Error: Package: 389-ds-base-snmp-1.3.10.2-9.el7_9.x86_64 (@rhui-REGION-rhel-server-optional) Requires: 389-ds-base = 1.3.10.2-9....
shottypop's user avatar
-2 votes
1 answer
56 views

Force dnf install yum

I have the problem with dnf that I cannot install yum. dnf install yum I want to be able to solve this problem in any way, it may be by deleting files, or making it detect files that are already ...
ArtEze's user avatar
  • 55
0 votes
0 answers
29 views

YUM can't resolve dependency even though yum finds the dependent package

This is driving me crazy. Yum is telling me that it can't resolve a dependency even though it finds the dependent RPM. Yum says that sri-mcstools = 3.0_3_ge35b2fd-master is required and that it's ...
shrewmouse's user avatar
0 votes
1 answer
43 views

Create rpm for self-compiled glibc

I have successfully compiled glibc-2.28 and want to know how to package it into an rpm that is identical(except code) to a centos package as created for centos 7 distro. If I had a template for how ...
Steve H's user avatar
  • 15
0 votes
1 answer
115 views

Centos7 not able to download yum-downloadonly

I am on centos 7 and need to only download a package without its dependencies, yum-downloadonly seems to be the right tool, but when I do commands like sudo yum install yum-downloadonly or sudo yum ...
ConnoK0lan's user avatar
0 votes
0 answers
92 views

Does "yum clean all" remove symlinks?

I am running confluent upgrade playbooks to upgrade the version. My OS is RHEL 7 and I have installed Python 3.9 and created a symlink to it from /usr/bin directory. When running the confluent ...
adbdkb's user avatar
  • 103
0 votes
0 answers
123 views

Can --skip-broken parameter in yum command uninstall existing packages installed in machine

As per the document https://www.man7.org/linux/man-pages/man8/yum.8.html, following is the description for --skip-broken parameter: --skip-broken Resolve depsolve problems by removing packages that ...
Gaurav Ramrakhyani's user avatar
0 votes
1 answer
407 views

Cannot update kernel on AlmaLinux 8.9

I want to update kernel on AlmaLinux 8.9 because cifs is not working and it complains about OS version. mount.cifs [...] mount error: cifs filesystem not supported by the system Current kernel seems ...
adrianTNT's user avatar
  • 603
0 votes
0 answers
533 views

fixing offline yum RHEL7 missing dependancy, libnsl, local repository and --skip-broken

On a RHEL 7.9 system that is off network, a reposync is used to transfer ~200gb worth of repo data to it, including EPEL. That local repository on the system is working fine as far as i can tell. ...
ron's user avatar
  • 7,162
0 votes
1 answer
2k views

latest yum/dnf packages not showing on RHEL 8

We have several RHEL 8.8 instances in AWS which have the BaseOS and AppStream RHUI repositories available. However, we cannot see updated versions of several packages which were flagged in a recent ...
asmox's user avatar
  • 3
1 vote
1 answer
1k views

How do I install liblzma-dev with YUM / dnf

Building a Docker image. Trying to build samtools. What I installed: FROM rockylinux:8 RUN dnf -y update && dnf -y upgrade && dnf -y --allowerasing install wget libcurl curl git vim ...
Greg Dougherty's user avatar
0 votes
1 answer
44 views

Can't download Docs package in Fedora Container Image

I don't know what I am doing wrong but the Fedora Container image is not installing doc packages. yum install ansible-core-doc Claims to successfully install, but /usr/share/doc/ansible-core-doc/ ...
WesAtWork's user avatar
  • 103
0 votes
0 answers
73 views

How to lock a package to not be updated or reinstalled in CentOS

I've already installed a patched version of a package, and I don't want it be updated or reinstalled in any case. What I have tried but not success: using exclude=package-name* in /etc/yum.conf: I ...
huynp's user avatar
  • 3
0 votes
0 answers
763 views

RHEL8.8 need to download all packages and dependencies for use on another RHEL 8.8 System

I have a customer on RHEL8.8/4.18 and their systems do not have internet. I need to install my co. software via rpm package as well as all dependencies on their system. It sounds easy but, what a day! ...
SSD_Dude's user avatar
0 votes
0 answers
171 views

How does package order affect resolving of dependencies in yum/dnf?

Background / xy-problem: I have some tool that needs libcurl-devel, but won't compile if there is a 32-bit version of libcurl present. Fixing that tool is for another day. Today I want to prevent ...
BlackShift's user avatar
1 vote
1 answer
57 views

Changing yum source through Gnome GUI

This might be a silly question, but it puzzles me. I am using Rocky linux version 9.2. I wonder if there is a way to change the yum install source through gnome gui? that is, without using command ...
FaDA's user avatar
  • 113
0 votes
1 answer
801 views

error: libcurl >= 7.28.0 library and headers are required with support for https

I'm sorry for having written such a long question, but given how many times similar questions have been asked, I felt like I had to give a lot more context. In my system, I get. . . checking for curl-...
Sweet Shell O'Mine's user avatar
1 vote
1 answer
211 views

will DNF [YUM] fail if /var/tmp is a tmpfs file system?

I was considering making /var/tmp a tmpfs mount, similar to systemctl enable tmp.mount in order to meet a security rule requesting /var/tmp be on a separate partition. I did not make that physical ...
ron's user avatar
  • 7,162
0 votes
0 answers
189 views

Unable to add PostgreSQL-12 repository on CentOS 7

While installing the PostgreSQL-12 repository on CentOS 7, I encountered the following problem. I attempted to download and install it, but without success. Any suggestions would be greatly ...
sonu's user avatar
  • 1
0 votes
1 answer
432 views

how do I yum remove an rpm [gssproxy] and not also remove dependencies [nfs-utils]

I was given a security rule that says gssproxy must be removed. When doing so it also removes nfs-utils as a dependency. I need to keep nfs-utils to be able to nfs mount. Is there a way to remove ...
ron's user avatar
  • 7,162
0 votes
1 answer
569 views

How to install PHP obtained from remi's repo and created local repository?

Here is my question, I am trying (forced) to install PHP 8.2 into almalinux 8.6, but in a weird way. The idea is to be able to install it without internet, but with some local repositories which ...
coyote's user avatar
  • 101
0 votes
1 answer
404 views

DNF|YUM - Diable a package upgrade for one specific package version

I'm encountering a problem on a Linux host where upgrading software package X causes package Y to stop working, and where package Y is essential for the users of that Linux host. This Linux host uses ...
Jim Fischer's user avatar
0 votes
0 answers
39 views

Any folders on headless cent os safe to remove in /usr/share/ to regain desperate space?

I have an old web-server running apache that was installed with a small 8GB / drive for some reason. Most things run on /home which is on another volume but there are some oddities I am having with ...
Codejoy's user avatar
  • 113
0 votes
1 answer
71 views

Yum Update Wiped /boot/efi/EFI directory!

During a recent yum update (not upgrade), the /boot/efi/EFI/centos and BOOT was removed. Yes, I can reproduce this error. In order to fix -- I could not boot into the kernel ==> I used the rescue ...
dtx1's user avatar
  • 21
0 votes
1 answer
669 views

AIX 7.1 Python3 Installation: Symbol Resolution Issue

I'm trying to install and run Python 3.9 on one of our AIX Operating Systems. I used yum to install Python 3.9. Current OS Level: root@our_AIX_host:/opt/freeware/libexec > oslevel -s 7100-05-11-...
Jesse C.'s user avatar
0 votes
0 answers
416 views

How to update google-chrome on centos with yum-cron?

I'm managing a medium size Selenium grid based on Linux CentOS 7 - a total of a couple dozens linux VMs. I'm using yum-cron to install updates. Starting recently, google-chrome does not update ...
Aleks G's user avatar
  • 193
0 votes
0 answers
1k views

Cannot install NetworkManager (nmcli) on Amazon Linux 2023

Freshly installed ec2 Amazon Linux 2023 instance. Was trying to inspect machine's network devices and status. However nmcli seems unable to be installed through yum install: $ sudo yum install ...
Rohim Chou's user avatar
2 votes
2 answers
366 views

ec2 Alma 9.2 stuck on old kernel version

# the issue: dnf check-update Last metadata expiration check: 1:35:58 ago on Sun Jun 4 10:26:18 2023. Security: kernel-core-5.14.0-284.11.1.el9_2.aarch64 is an installed security update Security: ...
user1133275's user avatar
  • 5,566
0 votes
1 answer
2k views

yum update does not work (repository problem)

# yum update -y Loaded plugins: fastestmirror, refresh-packagekit, security Setting up Update Process Determining fastest mirrors YumRepo Error: All mirror URLs are not using ft, http[s] or file. Eg. ...
Binti Islam's user avatar
0 votes
1 answer
413 views

How to install newer packages on Oracle Linux?

On Oracle Linux, how to install newer packages? For example, yum install -y wireshark; wireshark --version gives Wireshark 2.6.2, but upstream is at Wireshark 4.0.6. I have Last metadata expiration ...
wjwrpoyob's user avatar
  • 438
-2 votes
1 answer
1k views

RHEL + how to download rpms from RHEL 8.x repos when using RHEL machine 7.x

we are using the server RHEL 7.9 version for downloading rpm's from 7.x line we connected to rhel 7.x repositories , as the following ( VIA subscription-manager ) yum repolist Loaded plugins: ...
yael's user avatar
  • 13.4k
0 votes
1 answer
426 views

How to install pcre2-tools on Rocky Linux

I am on RL v9.1. The package seems to be there (pcre2-tools-10.40-2.el9.x86_64.rpm) but yum doesn't see it: yum install pcre2-tools runner_gitlab-runner 1.4 kB/s | 1.0 kB 00:00 ...
msciwoj's user avatar
  • 371
0 votes
2 answers
612 views

Yum install not recognizing specific version of JDK package on Oracle Linux 7.9

I am trying to install jdk 1.8.0_311 using yum install. However, I am getting an error stating that there is "nothing to do" when attempting to install. I have used yum --showduplicates list ...
Howdy's user avatar
  • 3
0 votes
1 answer
541 views

Installing multiple packages with one yum command AND failing if any of them is unavailable

I want to install multiple packages with one yum command, and fail if any of them is unavailable. However, while yum install -y foobar would fail since there's no foobar package, yum install -y mysql ...
Dániel Szoboszlay's user avatar
2 votes
1 answer
188 views

How do i distribute my commercial application using the yum package manager?

I would like to distribute my commercial application using yum (for ease of use and ease of update) on redhat/fedora/centos systems. The user still has to purchase an account to use the application (...
horseyguy's user avatar
  • 133
0 votes
1 answer
169 views

Adding and mounting a NFS share from RPM installer

I am building an installer for a proprietary SW package that requires an NFS mount to be added, if not already present, to /etc/fstab, and then mounted. I would like to automate this if possible so ...
Ben Froelich's user avatar
0 votes
0 answers
1k views

Receiving "Error: Trying to remove "yum", which is protected" when performing 'yum history undo'

We have a Centos 6.10 machine on i686 architecture. The server is running old software that requires specific versions of certain packages. We have had to restart a machine for the first time since ...
Adam BH's user avatar

1
2 3 4 5
33