Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [yaourt]

A pacman wrapper that adds seamless access to the Arch User Repository (AUR).

0
votes
1answer
810 views

What is this ffmpeg dependency error telling me and how do I fix it?

At some point, I had an error with dependencies and had to remove some forcefully with pacman -Rdd libvpx libx264. I have since reinstalled them, however I get this error upon each yaourt -Syua: ...
0
votes
0answers
155 views

How to solve errors after yaourt -S code aborted accidentally,

When I was installing code with yaourt -S code, something like ctrl d was typed accidentally. Then I try to install yaourt -S code again: gyp: Call to 'pkg-config --libs-only-l libsecret-1' returned ...
0
votes
1answer
615 views

ntp-4.2.8.p10-1 fails after upgrade due to libcrypto.so.1.0.0 (installed 1.1) dependency and wants downgrade to 4.2.8.p9-2. How does that make sense?

Disclaimer: This really is not a major issue critical to the stable operation of my system but I am asking this because I simply can't make any sense of it and I would really like to know what is ...
0
votes
0answers
375 views

Arch Linux - Acquire or Compile missing PHP extensions

I've installed my first Arch Linux setup, and loving it thus far, with the small exception of setting up my dev environment properly. My previous OS was Ubuntu 16.04 on which I ran Nginx, PHP5.6-FPM ...
3
votes
0answers
2k views

Yaourt: how to list dependencies for a package?

How can I list the dependencies for a given package? I thought this should be an easy task for Google, but I only found yaourt -Sq --depends <pkg>, which lists all packages that depend on <...
0
votes
1answer
485 views

How to stop sudo from timing out?

I update my Arch-Linux system using yaourt. When updating packages from the AUR, yaourt doesn't allow itself to be run as root, so it instead asks for sudo privileges every time it installs / updates ...
1
vote
1answer
2k views

How can I install Gimp 2.9 in Arch Linux?

I am trying to install Gimp 2.9 in arch linux. Following instructions from this site (which I can hardly understand), I have attempted to install gimp-devel via yaourt. However, I receive an error ...
-1
votes
1answer
700 views

problem makepkg was unable to build with conky-lua

Since yesterday, i have a problem and i can't install conky-lua. I have the errors belows and i have tried to install others package and change my pkgbuild but nothing change. When I try : yaourt -S ...
2
votes
1answer
2k views

How to force yaourt to install all updates

I'm trying to update my system via yaourt, but I'm getting an error due to a python package installed with pip instead of yaourt. I'm not succeeding in forcing yaourt to install the update, and I'd ...
1
vote
3answers
178 views

finding rar in yaourt

I try to install rar using yaourt, problem is I get +5k results and can't filter out the package containing rar. Neither |grep helps nor |head, the first hundreds of lines are lib'rar'ies. What could ...
1
vote
1answer
108 views

Can't downgrade Linux kernel: not enough free disk space

I'm stuck in an archiso/chrooted environment (booting from a USB flash drive) because my Wi-Fi drivers are incompatible with Linux 4.8.7-1, and cause the system to hang at boot. I'm trying a few ...
2
votes
2answers
797 views

How do you list installed meta packages on Arch Linux?

I'd like to list all meta packages that I installed. Installed with yaourt or pacman operating system is Arch Linux Problem When I install plasma-meta and run pacman -Qg, I can only see plasma. ...
1
vote
2answers
1k views

Yaourt: limiting output (ignoring AUR? RegEx?)

I'm really enjoying yaourt to search for packages, except then yaourt just tries to ddos me, displaying like 1,000+ packages for some searches... How can I effectively limit the output length? For ...
3
votes
1answer
607 views

Tring to install Atom Text Editor on my Arch by using Yaourt

I am currently trying to install Atom Text Editor (atom-editor on Yaourt). However I get the errors below: ==> Downloading atom-editor-arch PKGBUILD from AUR... x .SRCINFO x .gitignore x PKGBUILD ...
1
vote
0answers
511 views

cannot install anything using yaourt on Arch Linux

If I try to install using yaourt I get same error for every package, and it asks me to build package again and again. ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded (cannot ...
5
votes
2answers
5k views

How to use yaourt on arch linux under proxy?

How do I install applications using yaourt under proxy network. For pacman I can simply use: export http_proxy=http://usernm:passwd@link:port sudo -E pacman -S application But how do I do this for ...
1
vote
1answer
906 views

Always answer Yes to replace package Arch Linux [duplicate]

I am trying to build the latest KDE Frameworks git packages. However, I currently have installed the stable non-git packages. In order to install all of the git packages I need to answer 'y' to all of ...
3
votes
1answer
1k views

Arch Linux - make: error while loading shared libraries: libunistring

I keep getting this same error when trying to install various packages: make: error while loading shared libraries: libunistring.so.0: cannot open shared object file: No such file or directory It's ...
3
votes
2answers
2k views

Getting the error invalid option '--asroot' on packages

When trying to install the package kodi-standalone-service however after I get prompted for editing the PKGBUILD then I get this error. makepkg: invalid option '--asroot' Unable to read PKGBUILD I ...
5
votes
1answer
706 views

preserving colors when piping yaourt through sort

Can sort preserve piped in colors? I'm trying to modify yaourt -Qu | sort so I get color output. Tried googling this but I couldn't find a general way nor a special way to do this for sort.
1
vote
2answers
532 views

First KDE Session

I was curious, so I installed kde alongside gnome (which I use primarily, for the matter). I am running arch linux, and I installed kde using yaourt, by the following command: yaourt -Syua # update ...
15
votes
3answers
9k views

How can I responsibly run updates automatically on Arch Linux?

I'm a bit of a newcomer to Arch Linux and still getting used to some of its paradigms. I come with a lot of habits from another distro that was quite a bit more structured and in some ways predictable....
2
votes
3answers
7k views

yaourt curl error: Couldn't connect to server

I'm trying to install some packages with yaourt. For example, when I try to install Google Chrome, I get the following error: $ yaourt google-chrome curl error: Couldn't connect to server I can ...
3
votes
1answer
3k views

yaourt curl error: SSL connect error

I'm trying to install some packages form yaourt. For example : yaourt compiz But it gets me following error: [hamed@localhost ~]$ yaourt compiz curl error: SSL connect error Please tell me what's ...
66
votes
2answers
105k views

How do I unset a variable at the command line?

I have tried the following command to set Proxy on yaourt: export ALL_PROXY=http://proxy.example.com:8080 The question is how to unset the proxy on yaourt? In general, how can I unset the value of a ...
11
votes
2answers
5k views

How to recognize harmful AUR packages

How do I recognize if a package which is installed via yaourt on arch linux could be harmful to my pc? I read in the wiki that I should check every installation I make with yourt. But what exactly do ...
1
vote
1answer
623 views

yaourt -Syu is not working in arch linux

I tried yaourt -Syu and got this error: error: failed to prepare transaction (could not satisfy dependencies) :: Starting full system upgrade... :: nvidia: requires linux<3.11 how could I solve ...
6
votes
2answers
2k views

Make yaourt does not reinstall when already installed

Is there a way to make yaourt does not reinstall when the package (from AUR) already installed $ yaourt -Q jruby local/jruby 1.7.3-1 but somehow $ yaourt --needed --noconfirm -S jruby keep ...
4
votes
3answers
2k views

How to recreate a package file from installed package?

I used yaourt to successfully build and install an AUR package, unfortunately missing the fact that in its default configuration the built package is removed after installation. Since the build took ...
14
votes
2answers
15k views

Check for updates of packages installed through yaourt

Is there anyway to update package installed with yaourt ? yaourt -Syu seems to do the same as pacman -Syu, which only care about package in official repository.
-1
votes
4answers
3k views

Arch Linux: Yaourt/Makepkg Can Not Build Apache

I am using yaourt to automatically compile Apache from source every time there’s an update available from extra. I am doing this so that I can have a custom suexec docroot (/srv/www rather than the ...
7
votes
2answers
5k views

Error updating all ArchLinux packages with -Syu

I am on Arch Linux with Kde. I haven't updated the packages in a while and I'm having a problem while trying to do so: The first thing I tried was: sudo pacman -Syu as the documentation says, and I ...