Questions tagged [x11]

The X window system (commonly X Window System or X11, based on its current major version being 11) is a computer software system and network protocol that provides a basis for graphical user interfaces (GUI) for networked computers.

Filter by
Sorted by
Tagged with
332 votes
12 answers
370k views

How to know whether Wayland or X11 is being used

So I just installed the latest Kali Linux on my laptop which was based on Debian 7 (oldstable). I then dist-upgrad-ed the whole thing to Debian 8. I've always wanted Wayland instead of X11, so I ...
user avatar
  • 3,549
113 votes
2 answers
30k views

How do keyboard input and text output work?

Suppose I press the A key in a text editor and this inserts the character a in the document and displays it on the screen. I know the editor application isn't directly communicating with the hardware (...
user avatar
112 votes
6 answers
192k views

How to get keycodes for xmodmap?

I'm trying to use xmodmap to remap Alt / Super keys on Dell L100 keyboard, and have trouble getting the keycodes. For instance, using xev doesn't give me keycode for Alt FocusOut event, serial 36, ...
user avatar
99 votes
5 answers
34k views

What process created this X11 window?

Given an X11 window ID, is there a way to find the ID of the process that created it? Of course this isn't always possible, for example if the window came over a TCP connection. For that case I'd ...
user avatar
93 votes
3 answers
169k views

Open a window on a remote X display (why "Cannot open display")?

Once upon a time, DISPLAY=:0.0 totem /path/to/movie.avi after ssh 'ing into my desktop from my laptop would cause totem to play movie.avi on my desktop. Now it gives the error: No protocol ...
user avatar
  • 1,251
87 votes
2 answers
64k views

Difference between .xinitrc, .xsession and .xsessionrc

I found three configuration files. .xinitrc .xsession .xsessionrc I know that the first one is for using startx and the second and third are used when using a display manager. But what is the ...
user avatar
  • 1,011
76 votes
4 answers
68k views

Copy file to xclip and paste to Firefox

I'm coping file to xclip cat file.txt | xclip I'm pasting without problem with xclip -o When I want to paste it to Firefox with Ctrl+V it pastes old text (that shouldn't already be in the ...
user avatar
  • 14.6k
73 votes
11 answers
44k views

How to run a script on screen lock/unlock?

I'd like to run a script if the Gnome session is locked and unlocked. Is there a way that I can intercept this and perform certain actions when the desktop is locked or unlocked?
user avatar
  • 35.8k
71 votes
5 answers
42k views

Xfce entered zoom mode. How do I exit?

I pressed something around my mouse pad (keys in the altgr region+mousepad - quite possibly multitouch) and suddenly the whole X11 display zoomed around 10%. That means I can see 90% of the 1920x1080 ...
user avatar
  • 29.9k
68 votes
4 answers
105k views

What is ".xsession" for?

What is the purpose of the .xsession file in the home folder? What should be put in there? The desktop environments don't use that file and for the X startup from the tty there is .xinitrc.
user avatar
65 votes
2 answers
25k views

Copy image from clipboard to file

Is it possible to take an image from the clipboard and output it to a file (using X)? I can do this with text easily: $ xclip -selection c -o > file.text But when I try the above with an image ...
user avatar
  • 783
63 votes
7 answers
98k views

How can I set mouse sensitivity, not just mouse acceleration?

I can't find a single desktop environment that supports setting both mouse acceleration AND mouse sensitivity. I don't want any mouse acceleration, but I want to increase the speed of my mouse. That ...
user avatar
  • 895
59 votes
7 answers
246k views

Why can't I run GUI apps as root: "No protocol specified"?

I installed Debian onto my machine last night. Now, I don't understand why I can't run GUI apps from a terminal when running as root. For example: sudo -i glxgears Generates the following output: No ...
user avatar
  • 2,409
57 votes
7 answers
116k views

How do I scale i3 window manager for my HiDPI display?

I have a Dell XPS 13 9343 2015 with a resolution of 3200x1800 pixels. I am trying to use i3 windows manager on it but everything is tiny and hardly readable. I managed to scale every applications (...
user avatar
  • 1,260
57 votes
4 answers
88k views

How can I set the position that terminal opens at?

I'd like Terminal to open near the bottom of my screen. Is there a way to set the default size and position? I'm using Linux Mint 13, Cinnamon.
user avatar
55 votes
5 answers
98k views

How to send keystrokes (F5) from terminal to a GUI program?

I'm using a Raspberry Pi in combination with Chromium (kiosk mode) to show up some stats. The Pi doesn't have a connected keyboard so I searched for a solution to send keystrokes from the terminal to ...
user avatar
  • 698
55 votes
7 answers
147k views

How do I get my mouse back from QEMU/KVM?

I'm running QEMU/KVM on Debian Testing x64 with this command: kvm -m 1024 -hda win7.img -cdrom win7x86.iso -boot d -net user But when I click inside the virtual machine, QEMU captures my mouse and ...
user avatar
  • 1,361
51 votes
8 answers
67k views

How do I find the window dimensions and position accurately including decorations?

I've been trying to figure out the size of a window for use in a small script. My current technique is using wmctrl -lG to find out the dimensions. However, the problem is this: The x and y figures ...
user avatar
  • 3,650
48 votes
9 answers
94k views

Why does my X11 forwarding attempt fail with "connect /tmp/.X11-unix/X0: No such file or directory"?

On my local machine, I run: ssh -X me@remotemachine.com (For completeness, I have also tested all of the following using -Y with identical results). As expected, this accesses remotemachine.com ...
user avatar
48 votes
9 answers
70k views

Running GUI application as another (non-root) user

Let's say I have 2 user accounts user1 and user2. When I login as user1, and then switch to user2 using su, I can execute command-line programs, but GUI programs fail. Example: user1@laptop:~$ su - ...
user avatar
  • 5,390
48 votes
5 answers
166k views

Why am I getting this message from xauth: "timeout in locking authority file /home/<user>/.Xauthority"?

While attempting to SSH into a host I received the following message from xauth: /usr/bin/xauth: timeout in locking authority file /home/sam/.Xauthority NOTE: I was trying to remote display an ...
user avatar
  • 346k
46 votes
1 answer
17k views

X, Xorg and D-Bus: what is the difference?

In the process of learning to do certain things in GUI programming (e.g., reserving space on the screen for an application), I have to learn more about the Window Manager, usually X11 on Linux (I'm ...
user avatar
  • 3,527
46 votes
2 answers
6k views

How do I find out what program 'owns' a hotkey?

I'm running XFCE 4.12 on top of Gentoo with a 4.2.0 kernel. My PlayPause button on my keyboard used to work as a global hotkey for VLC. Now VLC won't even recognize the key. It does see "Alt + Media ...
user avatar
  • 1,249
45 votes
5 answers
10k views

Can I "drag" a file into a window without a file manager?

(I'm on Arch Linux, using i3 as my wm and xterm as my terminal emulator, though I don't know if any of that is relevant.) Occasionally, a website asks me to drag a file with my mouse from my desktop ...
user avatar
45 votes
2 answers
21k views

What's the difference between Primary Selection and Clipboard Buffer?

I am tweaking in Webkit-browser land in Linux and I come accross the terms "Primary Selection" and "Clipboard selection or buffer" very often. I want to understand what are they and what difference ...
user avatar
  • 3,199
45 votes
3 answers
35k views

What is `/tmp/.X11-unix/`?

I asked Google the same question and didn't like the results I got. What is /tmp/.X11-unix/?
user avatar
  • 3,874
44 votes
4 answers
64k views

Make mouse movements scroll when the middle button is held down

In Windows, I'm used to clicking the center button and it offering a "fast scroll" option up or down. How can I get this behavior on Linux? It currently seems to use the back button upon center click ...
user avatar
  • 1,706
42 votes
4 answers
78k views

X applications warn "Couldn't connect to accessibility bus:" on stderr

It seems like every application from the terminal gives warnings and error messages, even though it appears to run fine. Emacs: ** (emacs:5004): WARNING **: Couldn't connect to accessibility bus: ...
user avatar
  • 523
41 votes
2 answers
26k views

Difference between Xorg and Gnome/KDE/Xfce

I want to learn more about UNIX systems and I think I have a pretty straight forward question. I think I know what X is used for: It gives a standard to applications to present their UI's (among other ...
user avatar
40 votes
10 answers
81k views

ssh returns message "X11 forwarding request failed on channel 1"

When I ssh into a remote server that's not running any type of X11 desktop environment I get the following message. $ ssh user@server X11 forwarding request failed $ ssh user@server ls X11 ...
user avatar
  • 346k
39 votes
3 answers
78k views

How to start a second X session?

I tried to do it with the command startx 1. It seemed to flicker to a different screen momentarily, but then exited. Got the following error: /usr/bin/xterm: No absolute path found for shell: :1 ...
user avatar
39 votes
2 answers
12k views

Why does Shift+Insert paste from CLIPBOARD in some applications and PRIMARY in others?

How do I paste from the PRIMARY selection (eg. mouse-selected text) with a keyboard shortcut? Shift+Insert inconsistently pastes from PRIMARY or CLIPBOARD, depending on the application. Background: ...
user avatar
  • 743
38 votes
1 answer
38k views

Mod, Meta, Super ... keys?

In Window Managers circle there are some technical terms; couple of them are Mod keys and Meta keys. The questions here I am asking are What exactly are those and are they universal across ...
user avatar
  • 3,199
38 votes
5 answers
49k views

How to speed up X over SSH on a slow network connection?

Are there any specific recommendations on speeding up X applications over ssh on a slow network connection? In this specific case, I am accessing a server located in west coast from a laptop in east ...
user avatar
  • 645
36 votes
6 answers
321k views

X client forwarded over SSH "cannot open display: localhost:11.0"

I have enabled X forwarding on remote machine where SSH server is running: # grep -i forward /etc/ssh/sshd_config X11Forwarding yes # On local machine, I have started SSH client with -X flag which ...
user avatar
  • 6,378
35 votes
7 answers
109k views

annoying message "X11 connection rejected because of wrong authentication" while there is no problem at all

I'm having an annoying problem. When I'm logged in to a specific host via SSH, the message X11 connection rejected because of wrong authentication. occurs three times seemingly random about once ...
user avatar
  • 551
34 votes
2 answers
21k views

Record every keystroke and store in a file

I need to record every keystroke and store in a file in the user directory ~, when using my account, I am not sudoer and I cannot install programs (like logKeys) in any way. How could I do so using ...
user avatar
  • 1,041
34 votes
4 answers
30k views

Reattach to lost X11 session

I'm using X11 forwarding over ssh to run Linux apps on my Windows box, and when the network drops it loses everything that was running. Is there anything similar to screen for X11?
user avatar
34 votes
6 answers
31k views

How to get near-perfect screen recording quality?

Someone suggested I direct a copy of the unmodified X display to a file and afterwards convert that file to a general purpose video file. What commands would I use to do this on a Kubuntu system? (...
user avatar
  • 2,060
33 votes
11 answers
24k views

How do I type the degree symbol under X11 (using a default English keyboard layout)?

I'm trying to put in an email the temperature outside in degrees. On my Mac, the degree symbol (°) is Option+Shift+8. But I'm writing the email in Thunderbird on an Ubuntu 10.10 with the default US ...
user avatar
  • 7,740
33 votes
6 answers
8k views

Does an X client necessarily need a window manager to work?

Does an X client necessarily need a window manager to work? Can an X client work with only the X server? If an X client doesn't have a window, does whether it can work need a window manager? If an ...
user avatar
  • 90.7k
33 votes
4 answers
2k views

gitk crashes when viewing commit containing emoji: X Error of failed request: BadLength (poly request too large or internal Xlib length error)

I'm able to open gitk but it crashes as soon as I open a commit whom changes contains an emoji (not the commit message). Error ❯ gitk --all X Error of failed request: BadLength (poly request too ...
user avatar
33 votes
2 answers
115k views

What is DISPLAY=:0? [duplicate]

What is DISPLAY=:0 and what does it mean? It isn't a command, is it? (gnome-panel is a command.) DISPLAY=:0 gnome-panel
user avatar
  • 90.7k
33 votes
2 answers
35k views

How to use keyboard instead of mouse middle-click for copy/paste? [duplicate]

Possible Duplicate: Pasting X selection (not clipboard contents) with keyboard Is there a shortcut for copy-paste under X? I'd like to use the keyboard for pasting.
user avatar
  • 339
32 votes
3 answers
30k views

How to keep gnuplot-x11 graph window open until manually closed?

For example, this keeps the gnuplot-x11 graph window open until a key is pressed: gnuplot -e "plot \"file\" ; pause -1 \"text\"" How to keep it open until manually closed?
user avatar
  • 1,418
31 votes
4 answers
72k views

What is X11 exactly?

I'm reading Wikipedia about X11 and it says that: In its standard distribution it is a complete, albeit simple, display and interface solution which delivers a standard toolkit and protocol stack for ...
user avatar
  • 497
31 votes
4 answers
36k views

Setting the window dimensions of a running application

I'm trying to start an application within Ubuntu (xfce or gnome) and via the command line and was wondering if there's a generic way to set the dimensions of a given window of a given app that is ...
user avatar
  • 441
30 votes
7 answers
208k views

With SSH X11 forwarding (`ssh -X`), get `Can't open display` trying to run X applications

I'm able to login to sever using ssh -X Hostip but when i run the command xclock it give me this error Error: Can't open display: localhost:11.0 I check my Display value using echo $DISPLAY ...
user avatar
  • 3,874
30 votes
1 answer
13k views

What are the differences between xdotool and xautomation?

xdotool and xautomation are two command line X11 automation tools. I've used the former for a while and only recently found out about the existence of the latter, and I'm curious to know what someone ...
user avatar
  • 776
29 votes
2 answers
37k views

How can I run a graphical application in a container under Wayland?

When I used an X11 desktop, I could run graphical applications in docker containers by sharing the $DISPLAY variable and /tmp/X11-unix directory. For example: docker run -ti -e DISPLAY=$DISPLAY -v /...
user avatar

1
2 3 4 5
54