Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [wvdial]

The tag has no usage guidance.

1
vote
1answer
225 views

Ping to any ip does not work on ppp0 from USB 3G modem Huawei using wvdial

I have a Debian OS on a Banana pi and I use a Huawei 3G modem to connect to the internet from it using the wvdial tool. I also have the usb-modeswitch installed and I think the modem is working as a ...
2
votes
0answers
40 views

Debian wvdial parse result to auto set the IP address

I'm trying to get wvdial to work automatically with a Telit LE910 WCDMA modem. My script will start up the connection as needed, then disconnect when not needed to prevent wasted data. One of the ...
1
vote
0answers
133 views

WvDial serial communication not working with uart /dev/ttySAC4, but works with `screen`

I have embedded system based on Samsung Artik 710 board connected to Fibocom G510 cellular modem module via UART (two lines - RX and TX). When I try to communicate with modem using screen - modem ...
1
vote
0answers
306 views

ppp internet not only after restart

I have configured my network to get internet from HUAWEI E3131 usb modem at start. So I have prepared special wvdial.conf and interfaces files: wvdial.conf: root@debian:/home/s# cat /etc/wvdial.conf ...
2
votes
0answers
910 views

Troubles establishing connection with wvdial - Invalid dial command error

I am trying to run internet via HUAWEI E3372 on Debian. It worked on Windows but did not work on Debian.The error is this: ATDT*99# ERROR --> Invalid dial command. wvdial: utils/wvtask.cc:303: ...
1
vote
1answer
322 views

systemd service does not trigger the tmux command upon reboot

I am using a Yocto image based on the linux-mainline kernel. I have systemd on the embedded OS that I have created. Aim I have a UMTS dongle connected to the board which will use usb_modeswitch to ...
0
votes
1answer
66 views

Data and control channels for a modem in Linux?

I have a USB modem detected as a device device file (/dev/ttyACM0). Redirecting AT commands to the device file seems to work as the modem responds. Am going with the following assumption, the upper ...
1
vote
1answer
254 views

vwdial Bad init string on RPI [closed]

I'm trying to get a Huawei E398 3G USB modem to work on my Raspberry Pi 3 When I run wvdial I get the following response: pi@mypi:~ $ sudo wvdial --> WvDial: Internet dialer version 1.61 --> ...
1
vote
0answers
692 views

Start wvdial on boot from crontab

I'm trying to get work crontab, I'm editing crontab with sudo crontab -e. After that I add the line @reboot wvdial at the end of file, theoretically, every boot the computer connect with wvdial ...
1
vote
1answer
820 views

udev rules assign same port name for a modem with 4 ttyUSB ports

I have a dlink DW-157 3g dongle. I am trying to assign the same port to the dongle everytime it boots up by modifying the udev rules file. Since the dongle on boot boots up as a storage media, I have ...
1
vote
0answers
823 views

Wvdial.conf dial errors. Raspberry Pi Model B Huawei E1820 3G Modem

Linux is kicking my butt. I have attempted to use wvdial for the first time to get 3G working on my Raspberry Pi, but things have not gone as expected. First of all, when I do a simple sudo ...
3
votes
1answer
628 views

Is there a way to tell wvdial to wait for the answer of a command?

Some AT commands in wvdial return their answers with a delay. This period of time depends on the command. For instance, when you want to scan for available networks, you can use the AT+COPS=? command. ...
2
votes
0answers
380 views

Verizon LG VL600 USB 4G Modem

I am trying to connect an LG VL600 USB 4G Modem from Verizon on a Debian based machine (tried on Linux Mint and Raspberry Pi). I got it working on Windows 7 Virtualbox VM, so I know the device and ...
1
vote
0answers
1k views

Trying to get a usb modem to run with wvdial

$ sudo wvdialconf Editing `/etc/wvdial.conf'. Scanning your serial ports for a modem. ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud ttyS0<*1>: ATQ0 ...
2
votes
1answer
2k views

3G connection with wvdial gets no IP, exits with code 16

I am trying to establish a 3G connection with Raspbian, a 3G USB dongle, usb_modeswitch and wvdial. I followed this tutorial which has worked well before with a different 3G dongle. My 3G dongle is a ...
0
votes
1answer
256 views

Service that runs once when ppp0 connection shows up

We use wvdial to initiate a cell modem connection. We wrap it with nohup, launched by a cron job that checks if all is well every minute (everything we read said that wvdial and the associated ...
4
votes
2answers
929 views

How can I run a script when internet connection is about to get lost?

I use wvdial (PPP dialer) with a SIM card modem and sometimes this connection is reset by server side. I would like to run a script which greps ifconfig to get a volume of data downloaded and stores ...
3
votes
1answer
4k views

wvdial: The PPP daemon has died: Pty program error (exit code = 9)

I tried to configure AnyDATA ADU890-WH modem to work in Linux, but I have not succeeded. I am client of Czech carrier O2 and using Ubuntu 14.04. I have once managed to connect using Network Center, ...
0
votes
1answer
66 views

Can't access Rasperberry Pi over the internet

I set up an R-Pi 3G Modem combo with wvdial and it's working perfectly. I can access everything on the internet from the Pi. But when I try to access the Pi from the internet there is nothing, zero ...
0
votes
1answer
490 views

BSNL 3G USB modem not connecting

I am using Arch linux (fully updated). I have been trying to get my BSNL 3G usb modem to work to no avail for the past couple of hours. I have already installed modeswitch, wvdial, modem manager, ...
5
votes
1answer
16k views

Linux PPP : how to debug disconnects with exit code = 16?

I'm using pppd and wvdial on my ARM Linux embedded system. I have a CDMA modem connected via a serial port and am connecting to the Verizon network. I am seeing that several times per day pppd exits ...
3
votes
1answer
1k views

Determine 2G or 3G connection

I am using WvDial to dial my USB modem up to my ISP. But how can I tell what network I am connected to: 2G or 3G?
2
votes
1answer
5k views

Troubles establishing connection with wvdial

I have a Huawei cell modem EM680 with which I can establish a connection on my Ubuntu 13.10 box just fine. I plug it in and I can establish a connection using the Connections Manager. I have a box ...
2
votes
1answer
831 views

What is the relationship between wvdial, pon and chat?

I've checked their man pages, but I'm still confused. I just know they are all related to ppp connections. I'm surprised that when I googled "pon wvdial relationship", I get no useful results, so I ...
3
votes
2answers
9k views

getting “bad init string” when dialing with wvdial

I'm trying to dial-up with my Huawei modem EM680 using wvdial. My modem is found properly on /dev/ttyUSB1 but when I execute wvdial I get this: # wvdial --> WvDial: Internet dialer version 1.61 --&...
2
votes
0answers
1k views

Error while trying to connect to internet using wvdial

I am getting error while connecting to Internet through Wvdial . This is the output which I am getting : tusharmakkar08@tusharmakkar08-Satellite-C660 ~ $ sudo wvdial --> WvDial: Internet dialer ...