Questions tagged [uwsgi]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
73 views

nginx - uwsgi - python bad gateway 502 when using port 80

I'm setting up an nginx - python uwsgi server, I have encountered an an issue where i can get it to work when a port (8000) is supplied but when I use port 80, I just get a bad gateway (502) error If ...
0
votes
1answer
104 views

Starting UWSGI via init.d script exits with exit code 1 and says 'failed', but processes are running fine

Before this gets flagged as a duplicate, I read this question; however adding logfile2 did not change anything. I'm currently creating a docker container that runs a Python stack with UWSGI, for this ...
0
votes
0answers
1k views

Nginx connection refused error 111, bad gateway

Please do not hurry to close it as duplicate. I searched through the web and still cannot find the way to make it work. This is my working directory: /var/www/flaskapp myproject.ini myproject.py ...
3
votes
1answer
7k views

Why process killed with nohup

I want to run a process in background without killing it on shell exit, according to Nohup concept the following command should work until I kill it manually: nohup uwsgi --http :8008 --module ...
2
votes
0answers
207 views

systemd uwsgi service fails to run automatically but runs when started from interactive session

I enabled the uWSGI service in systemd but it fails to run at startup, the log shows the following: Wed Nov 22 12:36:10 2017 - your processes number limit is 47903 Wed Nov 22 12:36:10 2017 - your ...
1
vote
1answer
8k views

CentOS7 nginx permission denied for media and static

Hello I have tried to deploy django web server for a week and finally I did it, but now I have a permission denied problem with nginx /var/log/nginx/errors.log /2016-07-12_1.png HTTP/1.0", host: "...
3
votes
0answers
2k views

Help! Failed to start uWSGI Emperor service

I am creating a django application using nginx as my server with uwsgi. However when i entered my domain or ip address to access my site. I got an 502 BAD GATEWAY ERROR. So I decided to look at my ...
2
votes
0answers
666 views

Arch Nginx Uwsgi no app loaded

I am trying to get django working but uwsgi is having problems loading anything. Most likely do to my ignorance. I would love some help troulble shooting. I have been looking at similar posts on the ...
2
votes
1answer
698 views

Large TCP backlog for uwsgi, but no visible connections

In a setup with three docker instances, one running haproxy and two others running a flask-based python application through uWsgi, we run into a situation after about a day where no new connections is ...
0
votes
0answers
2k views

uwsgi , application not found

Ok so I have been trying to find a solution to this for 2 days now but I cannot seem to make much progress. I am running this on a nginx server but that appears to be fine. I copied over a python ...
4
votes
2answers
3k views

FreeBSD: using python3 in uwsgi instead of python2

I have a server with FreeBSD 10.1 installed. I want to deploy a Django site on it using uwsgi+nginx+python3 and got some problems. The site was written for python3, I installed python3.4 then python3 ...
7
votes
2answers
30k views

centos 7 systemd : Active: failed (Result: start-limit)

I want to use uwsgi with my django project I test usgi --ini uwsgi.ini works well And I want to write in systemd to control it And face error Here is my file /etc/systemd/system/mysite....
1
vote
1answer
4k views

Linux- Stop a process running as daemon

I've started uwsgi as a daemon, how can I kill that process? Everytime I kill its pid, and then does ps aux | grep "uwsgi", it again comesin the output. I've also tried pkill uwsgi, but no use. How ...
1
vote
0answers
1k views

Startup commands in /etc/rc.local won't work

I have a Python program and an nginx/uwsgi/django web setup. I want the program to start with the system, as well as the web server. Here's my /etc/rc.local: crawler_dir=/home/mohammed/git/crawler ...
5
votes
5answers
9k views

What's the best way to have uwsgi create a '/run/uwsgi' folder on reboot?

I have set up a Django project to run with uwsgi and nginx and it's all running as expected, except that when I reboot uwsgi will not launch correctly until the /run/ folder is recreated on the fs. /...