Questions tagged [usb-audio]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
3 votes
1 answer
32 views

alsamixer / amixer supported usb audio class 2 controls

I am currently developing a usb soundcard that is usb audio class 2 compliant. In my current setup I have audio and mute controls for several channels working in alsamixer. The USB audio class 2 spec ...
Jelle Jan's user avatar
1 vote
0 answers
9 views

How to get ALSA to trigger events for USB audio volume changes on the hardware

I've been trying to figure this out for a while, and I've even posted a few questions from different angles on it, but I have yet to get a response. So, if my question is nonsense, please let me know....
knottied's user avatar
1 vote
0 answers
13 views

Why is ALSA often not reading the audio card state

I'm having a terrible time with ALSA on a PI5. It will play and record sound, but the control interface seems to only work sometimes. I cannot find a cause for this. I could use some help ...
knottied's user avatar
0 votes
0 answers
76 views

No audio heard, yet Linux thinks played successfully

I had audio working on my AlmaLinux 9 installation, using a USB sound card. I seemed to have changed something because I no longer hear audio (but AlmaLinux thinks its successfully playing a sound). ...
TSG's user avatar
  • 1,698
0 votes
0 answers
81 views

Script on startup unable to use USB audio

I'm working on a very simple raspberry pi project where a Python script runs in the background and plays an mp3 on keyboard input. Everything works fine when I launch the script manually while SSH'd ...
Cooper Knaak's user avatar
0 votes
0 answers
78 views

USB Audio device no longer usable after reboot

My AlmaLinux9 server has been running great for months, playing audio through a USB device which was detected during installation. After a recent reboot I can no longer play audio because my app ...
TSG's user avatar
  • 1,698
0 votes
0 answers
58 views

Bt audio works, but absolutely no GUI

I have a BT audio device: $ lsusb Bus 005 Device 005: ID 0a12:1275 Cambridge Silicon Radio, Ltd HaiSenKeJi Bus 005 Device 004: ID 0a12:4010 Cambridge Silicon Radio, Ltd In sound settings I can ...
Daniel's user avatar
  • 339
0 votes
1 answer
150 views

USB Headset Prevents Media Playing on Arch

I recently bought a USB headset and it has been behaving very inconsistently. Sometimes it works fine but other times, if I try to play any media, it acts as if it is buffering until I unplug the ...
Aurillium's user avatar
0 votes
0 answers
903 views

Can't play audio from Debian 12 RC

I have a self-built PC consisting of a Gigabyte Z590i Vision D motherboard that I used to run Zorin on. It was great, but I now have a need to use Proxmox so I wanted to switch to Debian. I'm going ...
neildeadman's user avatar
0 votes
1 answer
120 views

Volume Control Extremely Sensitive/Too Loud for Corsair 1500 USB Gaming Headset in Linux Mint

This headset works exactly as expected in non-linux operating systems (e.g. macOS, Windows) such that the volume control smoothly adjusts the loudness of the headset all the way from 0 to 100. In ...
senbrow's user avatar
  • 111
0 votes
0 answers
68 views

Problems connecting MIDI DJ controller

I have a Traktor Kontrol S5 and I really need to use it with Linux (in my case Linux Mint). Also, Im new to Linux. The problem is that, even if Ive installed the driver, the MIDI part of the ...
ramaswag's user avatar
1 vote
1 answer
676 views

USB audio devices not outputting audio unless leaving pulseaudio control applet open

I am having intermittent issues with the output going silent on a USB sound card. Note that this affects both an Apple audio dongle and a Ugreen sound card, two very different chipsets, in the same ...
trr's user avatar
  • 418
0 votes
1 answer
293 views

USB Audio Device (Tascam US-2x2HR) sporadically fails to load, making other USB devices inoperable. How can I fix or debug this problem?

I dual-boot Windows and Ubuntu 22.04.01 LTS. In Windows, my audio device (Tascam US-2x2HR) works well. In Ubuntu, it does not work on boot, but if I repeatedly unplug it and plug it back in, it will ...
weemattisnot's user avatar
2 votes
1 answer
555 views

USB Host controller: xhci-hcd Event TRB with no TDs queued spam during audio playback

I'm on a system with Linux Kernel v5.10.4, and facing an issue where during audio playback through ALSA (aplay). The kernel spams the following log for the duration of the playback and no audio is ...
themaxwellsdemon's user avatar
0 votes
1 answer
877 views

PulseAudio Audio Devices Disappear After Reboot, Or Maybe Not

Half the time after a reboot the USB Behringer U-Control UCA202 does not show as an input or output device in the PulseAudio Volume Control. The system is running Linux Mint Cinnamon 19.3. The UCA202 ...
Herondas's user avatar
0 votes
0 answers
155 views

PulseAudio streaming randomly stops working then works

I am streaming audio stereo input from a USB Behringer U-Control UCA202 to a Bluetooth attached wireless headphone. The audio stream stops randomly every seconds to minutes and lasting for seconds up ...
Herondas's user avatar
1 vote
1 answer
283 views

Convert encode of audio files

I wish to convert the encoder of some audio files. The problem is that my car can't reproduce audio files encoded with LAME3.99.5; it's an issue with some Volvo cars. The problem is with USB and CD. ...
Unix's user avatar
  • 248
1 vote
1 answer
126 views

M-Audio Fast Track C400 USB Audio Interface problem

I`m running Debian 11 on an Asus X750L laptop. I have an M-Audio Fast Track C400 USB Audio Interface. If I restart or shut down the laptop after I turn it on in sound settings there is a signal but ...
Tion's user avatar
  • 11
1 vote
1 answer
151 views

My USB audio input channels max_out/clips at ~15%

I got an M-track 8 audio device (8 I/Os). It works fine for playback. However, the microphone (48 volt XLR mics) barely make any sound. When recording, they cap out at 15% volume in any application. ...
Emmanuel Lepage Vallee's user avatar
0 votes
0 answers
116 views

Dual sound cards, crossover

So, I'm wanting to setup dual sound cards. I'm thinking I can use paprefs to do simultaneous audio. The question is can I control them separately? I'd like to output 5.1 and 5.1, while 1 card is mids/...
maxHAX's user avatar
  • 1
1 vote
0 answers
197 views

How to debug audio cards (missing recording channels)

I have a StudioLive AR8 USB mixer by PreSonus that also functions as an audio card. What is so neat about this is that I get 2 playback channels and 4 recording channels! (1× stereo playback, 2× ...
Peter Nerlich's user avatar
0 votes
1 answer
616 views

Unload snd_usb_audio modules

I am trying to unload the snd_usb_audio kernel module in order to try some other module parameters (with modprobe). This fails: # rmmod snd_usb_audio With the following error: rmmod: ERROR: Module ...
Udi's user avatar
  • 173
1 vote
0 answers
542 views

Can only either have output or input on my USB sound card when having headphones plugged in. No profiles that use both

I recently bought a usb audio device so I won't have to unplug and plug headphone/speakers everytime I wanted to switch between them. The audio card has input for mic and one for speakers/headphones. ...
Jimomo's user avatar
  • 11
2 votes
1 answer
2k views

How to make pulseaudio recognize my usb headphones as stereo instead of mono?

The question itself may not be very explanatory. Let me try and clarify it a bit. I'm running Pop!_OS 20.04 LTS on a PC. I'm also using a pair of Wireless USB headphones (Razer Nari) with two outputs. ...
TermoZour's user avatar
  • 123
0 votes
1 answer
2k views

Fixed card mapping from USB to ALSA device list

I have a few webcam devices connected over USB and I want to record the audio from them using arecord. The device list is below (Cards 1 through 4): t:~$ arecord --list-devices **** List of CAPTURE ...
Human's user avatar
  • 125
2 votes
2 answers
705 views

Parsing audio format rates from USB Audio Interface fails, causing disconnect/rediscover loop

When I connect my PreSonus USB AudioBox 96 to my Ubuntu 18.04LTS desktop via USB2.0 port, dmesg shows the following errors in a loop: [ 8764.468004] usb 1-11: new high-speed USB device number 61 ...
khornlund's user avatar
1 vote
0 answers
530 views

Get the USB port 'by path' to autofill in udev rules file

I'm trying to improve on my udev rules for USB serial devices or USB sound cards. I want the USB port number to be populated in the ENV{ID_PATH} field without having to edit it myself (this becomes ...
skrowten_hermit's user avatar
1 vote
0 answers
67 views

act as bluetooth device for another computer/mobile

Is there a way to communicate to an USB headset (audio + mic) on a linux computer and then relay the usb communication to another device via bluetooth?
sassoPera's user avatar
  • 111
0 votes
1 answer
2k views

USB audio card on Ubuntu

I have a (relatively) old USB sound card, EMU-0404. It's official drivers (for Win/Mac) were not updated for years (last Windows official support is for Win 7, with 64 bit drivers in beta release) ...
Itamar Katz's user avatar
2 votes
0 answers
935 views

How to force PulseAudio to recognize my audio device

I have a Lenovo laptop. For about two years my Focusrite Saffire audio interface has worked correctly and shown up in the "Output" options of the Sound Settings. Now, it not randomly started to now ...
Startec's user avatar
  • 1,879
1 vote
0 answers
204 views

How do I get snd-usb-audio to detach from a device?

Context I'm working on a reverse-engineered controller for an Arturia AudioFuse over at https://github.com/rhofour/audiofuse-cli that uses libusb (through pyusb). I'm able to find the device, detach ...
rofer's user avatar
  • 111
2 votes
1 answer
1k views

Use audio output USB device

I have a Roland TD-30 drum connected using USB to my computer. The USB device support MIDI and audio input/output. Currently Linux does see the USB card. aplay -l shows: kaart 2: TD30 [TD-30], ...
JimmyD's user avatar
  • 189
1 vote
0 answers
625 views

ALSA - Sound stopped working in Arch for USB sound card after upgrading KDE from 5.7 to 5.14

Yesterday, I upgraded KDE from 5.7 to 5.14 after having display issues because it turns out I had installed the wrong package. I had some trouble initially getting sound to work in 5.7, but I finally ...
tayoung's user avatar
  • 131
3 votes
1 answer
1k views

Connect external DAC / sound card in OpenBSD

I am trying to connect a Focusrite Scarlett 2i4 USB DAC to my OpenBSD system to use as an external sound card. From what I have figured out so far, it seems that I need to tell some program or other ...
Os Miridium's user avatar
7 votes
0 answers
3k views

Always a pop sound whenever alsa/pulseaudio is idle for exactly 5 seconds? [closed]

I am playing short sound effects using aplay whenever users interact with the interface. What I notice is that I can play any of the sounds in any order and as long as two sounds play within 5 seconds ...
Logic1's user avatar
  • 181
1 vote
1 answer
4k views

How exactly USB Audio will be detected in Linux? [closed]

How will the Linux detect that I connected a USB Audio Peripheral? If I connect a USB Charger it will charge my mobile and it does not show any Headset icon on my status bar(Android). But when I ...
optimus prime's user avatar
0 votes
1 answer
2k views

Instantly redirect Audio Input to Audio Output [closed]

I am working with a headless flavor of linux and I am stumped when trying to handle some audio workings. I purchased a USB dongle to use which has a pink Audio in, and a green audio out 3.5mm jack. I ...
97WaterPolo's user avatar
2 votes
1 answer
969 views

Linux and the Fender Mustang GT guitar amp series

Note: To ward off any of the inevitable confusion that can arise here it is important to distinguish the old series of Fender Mustang amps (has plenty of support and info on the internet) from the GT ...
David West's user avatar
0 votes
0 answers
391 views

No sound from EasyCAP on OpenSuse Leap 42.3

I picked up an EasyCap but can't get any sound from it, video works fine. if I do lsusb I find the device (ID eb1a:2861 eMPIA Technology, Inc.) I also see the device in pavucontrol (and alsamixer), ...
qrikko's user avatar
  • 136
2 votes
1 answer
1k views

connecting M-Audio USB midi keyboard

I have a M-Audio Keystation 61es USB keyboard, and I could not manage to make it work under Linux despite a reasonable amount of trying. My system is Linux Mint 17.2 (rafaela). My laptop is an Asus ...
Denis's user avatar
  • 131
0 votes
0 answers
5k views

Set up pulseaudio to work with USB headset

I've just bought a new headset with USB and P2 connectors and I want to use it in my laptop to play. I'm using Archlinux with gnome and when I plug it via USB it is not detected. If however I plug it ...
Fnr's user avatar
  • 173
5 votes
1 answer
7k views

Figuring out USB devices

I have hardware to interact with that uses USB. It is a USB sound card The configuration file requires something like this: devstr=1-1.3.1:1.0 lsusb looks like this: Bus 001 Device 004: ID 0d8c:...
Danny's user avatar
  • 175
2 votes
2 answers
3k views

Debian/Gnome: Cannot use USB audio device in Pulse Audio

So following some suggestions, I tried: $ aplay -l | grep card card 0: PCH [HDA Intel PCH], device 0: CX20724 Analog [CX20724 Analog] card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0] card 0: ...
0__'s user avatar
  • 684
4 votes
0 answers
2k views

Docker with real-time / low-latency audio? (for virtual amps like Guitarix...)

I've been trying to get a foss virtual guitar amp to run on my Fedora machine for a while now, Guitarix (which runs on JACK) to be more precise. But I just can't figure it out. People say that it is ...
Forivin's user avatar
  • 847
0 votes
1 answer
2k views

Support for multiple sample rates during playing and recording in an application like Audacity

This is how I have defined my soundcard's channels in .asoundrc: pcm.!default { type plug slave { pcm "hw:1,0" } } ctl.!default { type hw card 1 } pcm_slave.usb_1 { ...
skrowten_hermit's user avatar
8 votes
1 answer
13k views

ALSA set plughw as default

I have a USB audio device, configured as the default device at card 0. I have a 3rd party application that is attempting to play wav files, which fail with the following: Playing WAVE 'sound.wav' : ...
duncanhall's user avatar
2 votes
1 answer
6k views

JACK/Pulseaudio: Output audio from JACK source to headphones (how to route different audio to different soundcards)

I want to play a metronome audio tick out of the built-in headphone port, while playing an audio stream out of a USB soundcard. How can I do this? Deeper context: JACK is running the USB soundcard, ...
theo-brown's user avatar
2 votes
2 answers
2k views

How do I use ALSA or PulseAudio to remap stereo source to an 8-channel PCM and lower the volume?

The details of my setup are as follows: Built-in Intel HD card (card0), to which all my existing applications use by default. Generally stereo output going out to the card from stereo files and ...
Crunchy's user avatar
  • 315
3 votes
1 answer
3k views

alsa audio device reordering: cannot find the slot for index 0 (range 0-1), error: -16

I had no problem for weeks using this configuration to fix the USB card as the primary one (had two, mainboard one and usb): /etc/modprobe.d/alsa-base.conf: options snd_usb_audio index=0 options ...
Nobody's user avatar
  • 539
1 vote
1 answer
4k views

How to use usb ports on a monitor for sound [closed]

I have a monitor with 2 USB ports that I connect through HDMI to my laptop. How do I make a USB sound card work with those ports? My system is Ubuntu 14.04.
spiderface's user avatar