Questions tagged [upgrade]

To upgrade is to replace a piece of hardware or software with a better, and usually newer, version or component.

Filter by
Sorted by
Tagged with
226
votes
3answers
45k views

Why is 'ls' suddenly wrapping items with spaces in single quotes?

I just noticed that on one of my machines (running Debian Sid) whenever I type ls any file name with spaces has single quotes surrounding it. I immediately checked my aliases, only to find them intact....
4
votes
3answers
10k views

How Smooth is Upgrading Linux kernel in Debian 8.5?

I would like to upgrade my Linux kernel to 4.7 in Debian 8.5, since it has significant better Skylake 6th generation support than the current linux kernel. In Ubuntu 16.04, the upgrade is easy. ...
6
votes
3answers
10k views

Ways to update Ubuntu (debian-based distros) offline

What is the easiest way to update/upgrade an offline Ubuntu machine with the help of a Windows machine that has internet access? This question also applies to installing new packages offline and not ...
54
votes
3answers
206k views

How to update glibc to 2.14 in CentOS 6.5

I want to install Android NDK on my CentOS 6.5 machine. But when I ran the program, it says it needs glibc 2.14 to be able to run. My CentOS 6.5 only has Glibc 2.12 installed. So I tried to update ...
240
votes
5answers
306k views

How can I update to a newer version of Git using apt-get?

I've just set up a new machine with Ubuntu Oneiric 11.10 and then run apt-get update apt-get upgrade apt-get install git Now if I run git --version it tells me I have git version 1.7.5.4 but on my ...
64
votes
3answers
112k views

Can I rollback an apt-get upgrade if something goes wrong?

Is there a way, before starting an aptitude upgrade or apt-get upgrade, to set up something so that you can "easily" rollback your system to the "apt" state it was before the actual upgrade, if ...
165
votes
2answers
320k views

In CentOS, what is the difference between yum update and yum upgrade?

What is the difference between yum update and yum upgrade, and when should I use one over the other?
6
votes
2answers
10k views

Openssl upgraded via apt-get, `openssl version` showing previous version

I am running Debian Wheezy. I have just upgraded my system and should have the latest version of openssl (1.0.1g which fixes a critical bug), but it does not appear to be being used. I have run: apt-...
4
votes
1answer
9k views

Upgrade Debian Jessie (8) to Buster (10) possible or need to go sequential in versions upgrades?

Just started working with a Debian Jessie (8) in a production environnent. While presently deployed it is not seeing any heavy use yet. I was looking at the OS LTS page, and I was thinking about how ...
18
votes
1answer
9k views

Unattended upgrades and modified configuration files

We have the unattended-upgrades package upgrading our servers with security upgrades every Monday and it works great. Today though, it upgraded all of our servers with a new version of PHP5. Because ...
12
votes
2answers
6k views

Packages to rebuild after upgrading gcc on gentoo systems

Which packages should be rebuilt after upgrading gcc on a gentoo system? Is it sufficient to run # emerge -a --oneshot `equery depends gcc |awk '{print " ="$1}'` as suggested similar for perl in ...
13
votes
2answers
6k views

Best way to upgrade vim/gvim to 7.3 in Ubuntu 10.04?

I have to use Ubuntu 10.04 at work, and can't upgrade it. I'm using Vim/gVim 7.2. I want to upgrade it to 7.3 (with Python and Ruby extension support). Which is the best way? Add an entry in sources....
2
votes
1answer
5k views

`apt update` failed on Debian Linux

Attempting to upgrade testing/stretch Debian Linux: $ sudo apt update Ign:1 http://dl.google.com/linux/talkplugin/deb stable InRelease Hit:2 http://dl.google.com/linux/talkplugin/deb stable Release ...
8
votes
2answers
2k views

Full-upgrade to Debian Testing fails due to libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is to be installed

I switched the sources to Bullseye and the upgrade went smoothly, but when I do a full-upgrade, I get: libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is to be installed My sources are ...
4
votes
1answer
3k views

How to revert Debian from testing to stable?

I have a PC that is used not so often. Like half a year ago someone changed its repositories from stable to testing and updated/upgraded. After that no one updated or upgraded. Can I change in /etc/...
1
vote
3answers
484 views

What's the advantage of mere Ansible on mere shell-scripting if one doesn't use communally-maintained Ansible-Galaxy roles? [closed]

I establish a LAMP with a few extras on a remote Debian machine with a similar shell (Bash) script: #/bin/bash apt update -y apt upgrade ufw sshguard unattended-upgrades wget curl git zip unzip tree ...
90
votes
5answers
57k views

What does “The following packages have been kept back” mean?

When doing an apt-get upgrade I sometimes get a message saying "The following packages have been kept back". For example: $ sudo apt-get upgrade ...
23
votes
1answer
32k views

Ubuntu upgrade from 17.04 to 18.04

I've installed ubuntu 17.04 and I want to upgrade it to 18.04. When I tried to do: sudo do-release-upgrade I got a message saying An upgrade from 'zesty' to 'bionic' is not supported with this tool....
21
votes
3answers
17k views

How is it possible to do a live update while a program is running?

I wonder how killer applications such as Thunderbird or Firefox can be updated via the system's package manager while they are still running. What happens with the old code while they are being ...
6
votes
6answers
2k views

What I can I do to make the transition to some new computer hardware safe and smooth?

I normally use machine A, and I make backups of A onto a fileserver B. Sooner or later, I will lose machine A for one reason or another. Its hard drive wears out, or it gets hit by lightening, or some ...
13
votes
4answers
29k views

What is the prefered way of updating all software in a Fedora installation?

When I install some system, I usually look for a bulk update method, one that will update my recently-installed software. For example, in Debian, that would be changing the sources.list to point to ...
20
votes
2answers
10k views

How to upgrade shared library without crash?

Here it says that you can rewrite an executable file and the process will run just fine - it will be re-read when a process restarts. However, when I try to replace a binary file while the process is ...
5
votes
3answers
7k views

What is the command-line equivalent to 'mintupdate' for Linux Mint?

Linux Mint has a nice GUI-based Update Manager with selectable update tiers. The defaults are for levels 1 through 3 our of a possible 5 levels. However, I often handle administrative tasks for a ...
31
votes
5answers
31k views

Full-upgrade to Debian testing fails due to libc6-dev : Breaks: libgcc-8-dev

I've just switched to bullseye (see sources below) deb http://deb.debian.org/debian/ testing main contrib non-free deb-src http://deb.debian.org/debian/ testing main contrib non-free deb http://deb....
18
votes
3answers
12k views

Will Debian Wheezy (stable) automatically upgrade to Jessie once Jessie becomes the stable release?

I am on Debian Wheezy (stable) and routinely update my system via the basic: sudo apt-get update sudo apt-get dist-upgrade In the future, once Jessie becomes the stable release, I wonder whether ...
15
votes
1answer
9k views

disable apt-listchanges (and other interactive stuff) during upgrades (reliably)

I have to admit, I really really hate apt-listchanges. If I'm going to do a huge dist-upgrade, I want to just leave the computer there for a few hours. The asker of this serverfault question had a ...
12
votes
4answers
9k views

Problem with appstreamcli when running apt update

I had a problem with debian testing today when I was running an apt update with following return: E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-...
11
votes
1answer
77k views

insmod: ERROR: could not insert module 8188eu.ko: Invalid module format

I'm trying to use the TL-WN725N as an USB WiFi-Adapter with Fedora 20. I followed these insructions and the adapter worked fine and even survived two updates during the last few weeks. Then I did a ...
10
votes
2answers
86k views

How to upgrade Apache 2.2.15 to 2.4.4 in CentOS

I want to upgrade Apache from 2.2.15 to 2.4.4 in CentOS. Do I need to download update files to a folder and update Apache? Is this even possible?
7
votes
5answers
62k views

How to upgrade Kali Linux

I've installed Kali Linux (normally I use ArchLinux, but I need Kali for work) and every time I want to upgrade, a few packages can't upgrade and are kept back. To force them to update I have to ...
6
votes
2answers
427 views

What is an effective method for installing up-to-date software on an out-dated production machine?

My company uses a small out-dated cluster (CentOS 5.4) to do number crunching (finite element calculations to be more specific). They are using a commercial package and have no idea of Linux. They don'...
9
votes
2answers
3k views

Identifying running programs that are using the old version of a library I just replaced

After installing updates to address CVE-2014-0160 (the OpenSSL Heartbleed bug), I had to take care to restart anything that might be using libssl -- many services, such as Apache and my VPN software, ...
4
votes
2answers
178 views

What forces a reboot?

I experience that my Ubuntu Linux requires a restart every now and then and also that it needs restart more often than in the old days (maybe it's because it updates more). I understand that ...
3
votes
3answers
9k views

Upgrade OpenSSH 7.4 to later on RHEL

I have a Red Hat Enterprise Linux server (7.5 x86_64). I have OpenSSH version 7.4. I was asked to upgrade it to a later version for security reasons: Nessus states that OpenSSH should be ugraded from ...
2
votes
2answers
1k views

Am I at risk? How to interpret debscan vulnerability output?

Today I came across a paragraph on how to Identify vulnerabilities debsecan was mentioned. I downloaded and executed debsecan and as a result I received a very long and shocking report. EDIT I ...
2
votes
2answers
2k views

Updates/applications/packages for Ubuntu 10.10 with no internet connection

I recently installed Ubuntu Desktop 10.10 (i.e 2h ago :D) from ISO CD. All went smoothly but now I have an issue. I don't have a network connection. I do not mean that there is a configuration ...
2
votes
1answer
1k views

Debian Linux not updating package

apt list --upgradable shows there's one upgradable package. libreoffice-sdbc-firebird/stretch-backports 1:5.4.4-1~bpo9+1 amd64 [upgradable from: 1:4.3.3-2+deb8u7] However, running apt upgrade does ...
2
votes
3answers
8k views

No matter how many times I try re-installing Linux Mint, I get a GRUB error. How do I fix it?

I have been trying to install Linux Mint 16 Petra using a removable USB thumb drive on my laptop, and after multiple attempts, I get the same error every time: error: file '/boot/grub/i386-pc/normal....
1
vote
1answer
5k views

Temporary failure in name resolution after upgrade to Debian Buster

I upgraded a few machines to Debian Buster and everything went well so far—although when running apt upgrade before apt full-upgrade I ran into a Temporary failure in name resolution. This was ...
1
vote
1answer
395 views

Unable to update my system Ubuntu13.04: Getting message - requires installation of untrusted packages

I had been trying to update my Ubuntu13.04 via 'software updater'. The updater messages that the following needs to be installed. Press continue to install When I press continue , a window appears as ...
41
votes
10answers
346k views

yum update fails: Error: Cannot retrieve repository metadata (repomd.xml) for repository …

I'm using CentOS 6.3. When I try to update my system with yum I have this message: yum update Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirrors.ircam.fr * ...
17
votes
2answers
15k views

How Linux servers update their kernel without rebooting

According to my informations, upgrading the linux kernel needs a reboot. Rebooting a home computer is not a problem, but I don't think that it is the same thing for a server. So does the servers that ...
16
votes
5answers
25k views

Failed at step EXEC spawning /bin/plymouth (Debian testing)

After I performed a dist-upgrade on a Debian testing (Jessie) instance, I can no longer boot. I'm marooned at the command prompt: Welcome to emergency mode! After logging in, type "journalctl -xb" to ...
12
votes
2answers
7k views

Linux - display or upgrade security updates only using apt

is there a way to list or install security upgrades only using apt? if I list upgrades with: apt list --upgradable can I also see without knowing packages and libraries which upgrades are relevant ...
8
votes
4answers
8k views

How to run unattended-upgrades not daily but every few hours

By default unattended-upgrades runs with cron.daily, that is at most on a daily basis. This can be a lot of time for attackers. I'd like to run it every 4 hours, how can I do this?
10
votes
1answer
23k views

How to properly upgrade glibc?

The firmware of my NAS comes with a rather old version of glibc, namely 2.5. In order to cope with some precompiled binaries linked* to glibc 2.15, I would like to upgrade it. From some simple testing ...
6
votes
1answer
34k views

Installing openjdk-7-jdk does not update java (which is still version 1.6)

I am having issues updating Java. I am running Ubuntu 11.10. I can execute sudo apt-get install openjdk-7-jdk and it completes successfully. javac -version is 1.7, however java -version is 1.6. This ...
12
votes
3answers
44k views

No DNS resolution after upgrade from ubuntu 14.04 to 16.04

I upgraded ubuntu 14.04 to ubuntu 16.04 and I have a problem with the internet connection. Specifically, DNS after update stopped working. For debugging purposes I set the only DNS 8.8.8.8, but name ...
10
votes
2answers
3k views

Is it normal that a restart is required to mount USB after a kernel upgrade?

Sometimes I see the Linux kernel being mentioned in the list of upgrades, when running pacman -Syu (updating my packages in Arch Linux). Whenever this happens, after installation of the packages, I ...
10
votes
2answers
382 views

Is there a mechanism that protects applications during library upgrade?

If user works on an application that is dynamically linked, and system is being upgraded, is there any protection mechanism that prevents application corruption? Or is it up to application?