Questions tagged [upgrade]

To upgrade is to replace a piece of hardware or software with a better, and usually newer, version or component.

Filter by
Sorted by
Tagged with
3
votes
1answer
23 views

How to upgrade with kernel taking more than half of /boot

The latest Linux kernel now takes more than half of my /boot space. Next time I want to upgrade, how do I do that? Can I purge the current in-use kernel and then issue aptitude full-upgrade or do-...
0
votes
1answer
122 views

Upgrading manjaro system fails when install lib32-libcanberra

I used pacman -Syu to upgrade my manjaro system, but some new libraries like lib32-libcanberra-pulse and libcanberra-pulse failed to be installed due to the dependencies. I have tried twice whether ...
1
vote
4answers
8k views

Upgraded Python, and now I can't run “yum upgrade”

I have upgraded my system (CentOS 7) to Python 3.7 and it seems that has broken a ton of things. In particular, I can't perform a yum upgrade ... [myuser@server ~]$ sudo yum upgrade Loaded plugins: ...
0
votes
1answer
3k views

can't update-initramfs generating /boot/initrd.img-3.16.0-4-amd64 error

Hi today I did a upgrade in my debian after of this. have a problem really I look a solution for this problem and I don't find anything. Configurando linux-image-3.16.0-4-amd64 (3.16.7-ckt20-1+...
0
votes
3answers
32 views

Upgrade certbot on Debian Jessie

Hi i have a machine based on Debian Jessie running an apache web server along with certbot 0.10.2. Due to this message i've received: As of June 1, 2021, you are no longer be able to renew your ...
51
votes
6answers
134k views

How do I upgrade all of my installed packages in OpenWRT?

I'm just wondering what is the equivalent of apt-get upgrade apt upgrade yum update with OpenWRT or LEDE?
0
votes
1answer
39 views

How to fix microsoft repo downloads being slow for apt upgrade?

Intro: I'm running into an issue while upgrading my installed packages with apt, and I'm curious whether you have an idea where to start resolving my issue, because I'm afraid I don't. I'm surprised ...
0
votes
0answers
27 views

Can't remove Centos 7 kernel while updating to Centos 8

I am attempting to upgrade my Centos 7 installation to Centos 8 by following this guide. When I get to the step to remove the old kernel and run rpm -e `rpm -q kernel` I am met with several dozen ...
0
votes
0answers
21 views

Cannot ping the server after upgrade from 14.04 to 16.04

We have a remote server where all our GPU are. We recently upgraded ubuntu from 14.04 to 16.04, the upgrade wasn't smooth, but we somehow did it after the reboot command we have lost access to our ...
0
votes
0answers
15 views

Ubuntu can't upgrade c++ package and can't fix broken packages

I'm just trying to upgrade my compiler to 8.4, with this command : sudo apt upgrade c++ But it says : E: Broken packages Last few lines are : xmabacus : Conflicts: xabacus xorg-server-source-hwe-...
0
votes
0answers
18 views

can't ping ubuntu server after upgrade

I upgraded to Ubuntu 16.04 from Ubuntu 14.04 on my remote server. I can not ping/ssh to the server. I sent someone to physically have a look into the server and got to know it can't ping other servers ...
0
votes
1answer
37 views

How to do multiple sequential Debian distribution upgrades?

I understand that it is generally recommended to always upgrade Debian sequentially. For example upgrade Debian Jessie (8) to Stretch (9) and then to Buster (10). But I couldn't find any clear ...
0
votes
0answers
10 views

Diagnosing Fallback Mode

After a recent system upgrade to PopOS 20.10, my computer boots in fallback mode and asks if I want to restart Cinnamon. What is the proper way to diagnose this issue via terminal? (i.e. log locations,...
0
votes
1answer
16 views

Installing VirtualBox 6.1.22 conflicts with installed 6.0.20

On my CentOS 7 installation I am looking to upgrade VM VirtualBox. The downloaded installer runs through yum and asks permission to install. However the installation fails with a Transaction check ...
0
votes
0answers
12 views

Ran out of space during upgrade, Pop! OS

Today I was upgrading to version 20.10 while low on space, and now my disk is at 0 and the system upgrade seems to have not completed. Logging in as a user yields a black screen with log entries and ...
0
votes
0answers
16 views

apt update and upgrade error [duplicate]

┌──(badoukone㉿LAPTOP-6GSFE4DV)-[~] └─$ apt update Reading package lists... Done E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission de E: Unable to lock directory /var/lib/apt/...
0
votes
0answers
28 views

Problem with updating Cent OS 8 Linux with yum and dnf

I am new to CentOS 8. I installed CentOS 8 and now i am facing problems with updating the CentOS. I tried with yum and dnf both. Below is the error which I am getting. Could you kindly help. [root@...
1
vote
1answer
115 views

end Kernel panic - not syncing

Few days ago, after I did an apt upgrade, I got something like this in the log, multiple times Error 24 : Write error : cannot write compressed block E: mkinitramfs failure cpio 141 lz4 -9 -I 24 ...
-1
votes
1answer
51 views

I'm trying to update Debian Bullseye packages using apt update

when I type the following I get this jerry@debian:~$ sudo apt update [sudo] password for jerry: Ign:1 cdrom://[Debian GNU/Linux bullseye-DI-rc1 _Bullseye_ - Unofficial amd64 DVD Binary-1 ...
50
votes
7answers
127k views

Ubuntu update error “ waiting for unattended-upgr to exit ”

I'm unable to update my system having 2 installations of Ubuntu , one is version 16.04 & the other version is 17.04. In both, I'm getting the same error. For ex., in Ubuntu 16.04, I run software ...
1
vote
0answers
15 views

Newbit to Linux and Pop OS

So I am running Pop OS 20.10, though I initially installed 20.04 (seems like an autoupdate), well now I have a bunch of files/softwares I can no longer update because this happens Setting up linux-...
0
votes
1answer
2k views

E: Unable to correct problems, you have held broken packages kali Linux 2020

So I am running the latest version of kali Linux. I was previously using the 2019 version of kali which had no issue but after updating, I gave command apt install mono-devel mono-complete mono-dbg ca-...
0
votes
3answers
13k views

Kali Error while installing any package

I had recently installed kali from parrot. After Successful installation. I run sudo apt-get update sudo apt upgrade Now I am unable to install any package. It shows me error: Reading package lists......
226
votes
3answers
45k views

Why is 'ls' suddenly wrapping items with spaces in single quotes?

I just noticed that on one of my machines (running Debian Sid) whenever I type ls any file name with spaces has single quotes surrounding it. I immediately checked my aliases, only to find them intact....
0
votes
2answers
1k views

No matching VNC server running for this user!

I'm using Kali Nethunter, and I need help to fix this.  I've been using the command nethunter -r kex & and I'm getting this error: vncserver: No matching VNC server running for this user! ...
3
votes
1answer
2k views

How do I find available versions of package for downgrade?

I am having issues with an update of the ImageMagick package breaking 3rd party software on a CentOS 6.x server. I know that some prior version of ImageMagick worked OK. How do I find out which ...
0
votes
1answer
22 views

Pacman downgrading my Linux kernel?

While updating my Linux installation on an AMD Ryzen system with sudo pacman -Syu, I noticed this row: gremlins/linux-zen 5.12.1.zen2-1 5.12.4.zen1-1 0.05 MiB 98.39 MiB So the kernel ...
0
votes
0answers
40 views

Cannot upgrade to ubuntu 20.04.2 LTS from 18.04.5 LTS? from

Hey I have been trying to upgrade my linux vm on azure but it's stopped at the middle for some unknown error , and When I checked the apt.log file I found many of the packages were broken but I cannot ...
5
votes
3answers
3k views

How to Switch From CentOS 8 to CentOS Stream

Is there any way to do a sort of in-place upgrade to CentOS Stream? I'm currently running CentOS 8 and for various reasons would like to switch over to the new Stream version. Is it possible to do ...
0
votes
0answers
28 views

ubuntu: upgrade 16.04.7 LTS to 18.04.5 LTS

I have a machine with fairly old Ubuntu-16.04.7 LTS. I kept packages up-to-date and regularly updated them, however didn't upgrade the whole distro, including kernel and system libraries. Now every ...
2
votes
2answers
2k views

Can't change update settings on elementary?

I can't update elementary os, when I try to change the settings 'Install updates from', none of the check boxes will check, it stays like the following image. What should I do?
0
votes
1answer
61 views

Python 3 version outdated on Mint 20.1

I am having a course with Python 3 and I see its 3.8.5: mint@mint-System-Product-Name:~$ python3 --version Python 3.8.5 I've updated the OS to the latest version possible, using: sudo apt-get update ...
3
votes
0answers
49 views

After upgrade, “everything” starts to segfault

I just upgraded my Ubuntu 20.04. After the upgrade I suddenly started to see a massive amounts of segfaults like this: [ 87.157912] perl[5442]: segfault at 0 ip 0000556a510d9f05 sp 00007fff768ae410 ...
0
votes
2answers
80 views

How to upgrade to newer OpenSSH version on OpenBSD

I'm on OpenBSD 6.8 and am running OpenSSH 8.4. How do I upgrade to OpenSSH 8.6, the newest version? Based off of this page https://www.openssh.com/openbsd.html , I know where to download it from, just ...
0
votes
1answer
26 views

How to upgrade Ubuntu without updating third party packages

I recently upgraded one of our dev servers from Ubuntu 18 to 20. The commands I used in order are: sudo apt update sudo apt upgrade -y sudo apt full-upgrade sudo reboot sudo apt --purge autoremove ...
0
votes
0answers
21 views

Cuda update on centos wants to install new version. but old versions are taking up so much space that new version can't be installed

I just ran yum update, and a cuda update on centos 7 wants to install new version. but old versions are taking up so much space that new version can't be installed. Install 3 Packages (+52 Dependent ...
0
votes
0answers
144 views

Upgrade Fedora 33 to Fedora 34 failed due to insufficient /var space

I was performing an upgrade from Fedora 33 to Fedora 34 Everything seemed to work, then I did the system upgrade reboot, and that seemed to work too until I got to the login where I got just a black ...
1
vote
1answer
61 views

How to configure apt-listchanges to send a unique summary email when running unattended-upgrades

I'm currently on Debian 10, and updates are applied with the unattended-upgrades tool. I wish apt-listchanges to send me a unique summary mail per machine as it did with Debian 9; but it sends a ...
3
votes
1answer
17k views

libc6 does not want to update to 2.29

I tried to install KiCad after i updated my Debian box to Debian 10, but i got the following error. The following packages have unmet dependencies: kicad : Depends: libc6 (>= 2.29) but 2.28-10 is to ...
3
votes
2answers
151 views

unable to upgrade or fix either (Kali)

┌──(istiak㉿kali)-[~] └─$ sudo apt-get upgrade [sudo] password for istiak: Reading package lists... Done Building dependency tree... Done Reading state information... Done You might want to run 'apt --...
0
votes
2answers
551 views

Failing to update from repository in MX linux

I use MX-Linux KDE version. Today, all on a sudden, when I tried to run apt update, the update process is not done fully. One of the resources man page showing a forbidden IP error. This is the result ...
3
votes
3answers
3k views

how do I know if the kernel changed

I have a scenario where I need to recompile my display drivers after kernel updates. I'm trying to shome how automate it with bash scripts during boot time. so I need some sort of a way to know that ...
0
votes
0answers
36 views

Apt not upgrading with a “There is 1 additional version” report

I am running Ubuntu 20.04. I figured I'm having some issues (listed below) with the graphics card, so I re-ran sudo ubuntu-drivers autoinstall. I then ran sudo apt update to update my repos, and ...
2
votes
1answer
2k views

Delete foreign packages in Migration to Linux Mint 20

The new version of Linux Mint 20 has been announced and along with it a User Guide (migrated from this tutorial) to help us in the migration process. Now, there are two steps which trouble me: 1- ...
2
votes
0answers
97 views

How to install R 4.0.* on Raspbian GNU/Linux 10 (buster)?

I believe I have followed the instructions on the relevant CRAN site to update R to the newest version (currently R 4.0.5) but with no luck. I'm running $ cat /etc/os-release PRETTY_NAME="...
0
votes
2answers
1k views

Fedora 23 black screen after update

I've installed fedora 23 xfce desktop on my laptop few days ago and it worked like a beauty. After few days i did sudo dnf update. after the update i couldn't change the wallpaper so i restarted my ...
0
votes
2answers
1k views

Sub-process /usr/bin/dpkg returned an error code (1)

I understand that this is a generic error message, but I'm having trouble deciphering what's going on - why doesn't Apache want to update? (Reading database ... 50302 files and directories currently ...
7
votes
2answers
3k views

Delaying kernel upgrades on Arch Linux

On Arch Linux, whenever a kernel upgrade is applied (via pacman -Su), problems occur. For example, iptables can no longer be used: # iptables -L iptables v1.4.21: can't initialize iptables table `...
0
votes
0answers
7 views

Packaging an Ubuntu DIFF from a package repo for application to an offline mirror

I have a situation where I have an offline Ubuntu mirror that I need to update. I cannot bring it online so I need to apply updates based on the current state of the offline mirror and the current ...
0
votes
0answers
105 views

Gnome 40 updated. not working

Today Manjaro Linux had a huge upgrade with Gnome 40. I upgraded my system and restarted it. but Gnome 40 is not enabled. I'm still seeing Gnome 38 in front of me. here is the photo of my Gnome ...

1
2 3 4 5
22