Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [upgrade]

To upgrade is to replace a piece of hardware or software with a better, and usually newer, version or component.

0
votes
0answers
9 views

debian stretch missing do-rel.h after upgrade

debian 9 apt-get update;apt-get upgrade now mplayer, mpv and chromium seg fault with similar errors; gdb /usr/bin/mpv says Program received signal SIGSEGV, Segmentation fault. elf_dynamic_do_Rela ...
3
votes
1answer
28 views

List Dependencies of Pending `pkg upgrade`

I wanted to update most of the stuff on my FreeBSD system, so I was going to perform a pkg upgrade. I noticed that one of the listed new packages to be installed was Wayland; I'm not interested in ...
0
votes
1answer
29 views

I want to update the glibc version from 2.17-222.el7.x86_64 to 2.17-260.el7

I want to update the glibc version from 2.17-222.el7.x86_64 to 2.17-260.el7. Will there be any effect ? IS 2.17-260.el7 compatible to centos 7.2 as all my machines are in centos 7.2 only.
2
votes
2answers
26 views

SSH session closed during apt upgrade, and is prompting for input. What are my options to continue?

I'm viewing /var/log/apt/term.log because the ssh session closed while it was running and my apt-get upgrade is prompting for input, but because I'm viewing the log I can't give input. What are my ...
0
votes
1answer
185 views

MediaWiki automatic upgrades

I use latest MediaWiki (either on Arch Linux or Debian stable) in a personal project - I'm the only one who works on it, and I use MediaWiki in a core-only way (I don't install any extensions ...
0
votes
0answers
12 views

Upgrade to Cosmic Cuttlefish window enlargens so that I cannot press the button to complete the upgrade

I know this may sound like a pretty odd question, and it's kind of hard to describe. I currently have Ubuntu 18.04 Bionic Beaver, and by a popup given to me by the Ubuntu Software Updater I was asked ...
0
votes
0answers
28 views

Update postfix/mail version

When I'm checking my postfix version postconf -d | grep mail_version the output I get is mail_version = 2.11.0 milter_macro_v = $mail_name $mail_version But when I run apt-get install postfix, ...
-4
votes
0answers
15 views

How i solve update problem in linux Kali [duplicate]

(appstreamcli:3159): GLib-CRITICAL **: 13:08:58.535: g_atomic_ref_count_dec: assertion 'g_atomic_int_get (arc) > 0' failed
0
votes
1answer
50 views

Why does upgrading through Ansible commonly considered “idempotent”?

I know that an idempotent function returns a result which is can be returned more than once without changing the application essentially (like adding zero to a number or multiplying that number by 1). ...
0
votes
1answer
29 views

Do rolling release distros like Arch Linux include kernel upgrades as part of their rolling upgrades?

Do fully rolling_release distros like ArchLinux, openSUSE, Alpine and so forth include kernel-upgrades as part of their rolling upgrades? Or kernel upgrades are a separate issue even within the ...
1
vote
3answers
327 views

What's the advantage of mere Ansible on mere shell-scripting if one doesn't use communally-maintained Ansible-Galaxy roles? [closed]

I establish a LAMP with a few extras on a remote Debian machine with a similar shell (Bash) script: #/bin/bash apt update -y apt upgrade ufw sshguard unattended-upgrades wget curl git zip unzip tree ...
1
vote
2answers
42 views

Can kernel upgrades be done with configuration management (CM) tools for above-OS software?

I use various Linux Distros, mostly Debian-based, usually all default (I change nothing in the kernel/shell or internal-utilities (utilities that come with the distro). I usually install Apache, MySQL ...
0
votes
1answer
302 views

An upgrade from 'zesty' to 'bionic' is not supported with this tool. Tried official links, no success

I tried following https://help.ubuntu.com/community/EOLUpgrades/Feisty link, but without success. I need to upgrade my system to 17.10(EOL) from 17.04. When running following command I am getting an ...
1
vote
1answer
62 views

Lenovo Thinkpad Mute LED Stopped working after update

Updated my packages today on my Lenovo Thinkpad X1 Carbon (6th Gen). I didn't expect anything to happen but it did. The Mute indicator LED's on the F1 and F4 key stopped working. I actually know this ...
0
votes
1answer
56 views

Do bug corrections spread automatically to all Linux distros and updates? [closed]

I'm using Debian 9. When turning off my computer, many times (more than 50%, I think) I get the following message: A stop job is running for Session 3 of user rodrigo (Xs / 1min 30s) X increments ...
-1
votes
1answer
75 views

How to fully upgrade Debian from command line (including release_version)?

I desire to totally upgrade everything in Debian:Stable including the release version, to the newest stable release available: Packages update Packages upgrade D:S minor_version D:S major_version D:S ...
0
votes
1answer
186 views

Upgrade OpenSSH 7.4 to later on RHEL

I have a Red Hat Enterprise Linux server (7.5 x86_64). I have OpenSSH version 7.4. I was asked to upgrade it to a later version for security reasons: Nessus states that OpenSSH should be ugraded from ...
-1
votes
1answer
114 views

KDE on LTS 18.04 - Cannot Upgrade or 'sudo apt --fix-broken install'

https://askubuntu.com/questions/176121/dpkg-error-trying-to-overwrite-file-which-is-also-in https://askubuntu.com/questions/1067430/apt-fix-broken-install-does-not-work-package-manager-broken-after-...
0
votes
0answers
39 views

An upgrade from 'zesty' to 'bionic' is not supported with this tool [duplicate]

Hi i am getting the error below when i try and update my ubuntu server through command line: Reading cache Checking package manager Cannot upgrade An upgrade from 'zesty' to 'bionic' ...
0
votes
1answer
160 views

Upgrading go version to 1.11 in ubuntu [closed]

I am trying to upgrade go version to 1.11 in ubuntu 16.04. I try the following tutorial but it only upgrade user go version to 1.11. when i call sudo go version it still return go 1.6.2. How can i ...
2
votes
0answers
32 views

Upgrading Python3 Without Breaking Access to lib Folder

Upgrading Python3 package is always a big pain for me. Every time I upgrade from one version, e.g. 3.7.0, to another, e.g. 3.7.1, my python script loses access to my /usr/local/lib/python3.7/site-...
0
votes
1answer
82 views

Ubuntu upgrade from 18.04 to 18.10 got stuck in “Removing xserver-xorg-hwe-16.04 (3:14.1)”

I'm in the process of upgrading from Ubuntu 18.04 LTE to Ubuntu 18.10. I've started do-release-upgrade from inside a GNOME Terminal window. It made some progress but now got stuck in Removing xserver-...
0
votes
0answers
65 views

How to update FreeBSD without freebsd-update when the source cannot be compiled?

I run FreeBSD on a Raspberry Pi 3. This computer is permanently installed in a server room I do not have easy access to. Once FreeBSD 12 comes out, I want to update the computer to the new system ...
0
votes
0answers
17 views

Upgrade Ubuntu without btrfs snapshot

On every do-release-upgrade Ubuntu does a btrfs snapshot. What sounds like a good idea is quite annoying if you don't have enough disk space. The update requires the same amount of space as currently ...
3
votes
1answer
109 views

Upgrading to Fedora 29 from 28 resulted into inaccessible SSH and other TLS dependent services

After running standard distro upgrade command for Fedora Server: dnf system-upgrade download --releasever=29 && dnf system-upgrade reboot and rebooting back to the server I could not connect ...
1
vote
1answer
121 views

What is the difference between a Redhat “Binary DVD” and an “Update Binary DVD”?

Some versions of RHEL, but not all (for example, 7.4), have ISO download options of both a "Binary DVD" (e.g. Red Hat Enterprise Linux 7.4 Binary DVD, 3.78GB) and an "Update Binary DVD" (e.g. Red Hat ...
0
votes
1answer
21 views

Protect user edited *.desktop files from upgrades

I like to edit /usr/share/applications/*.desktop files (fortunately, just a few of them) to fit my needs. When the relative application is updated, though, those edits I made get lost. How should I ...
1
vote
1answer
88 views

Upgrade from openjdk-7 to openjdk-8 on debian

I have the following Java-related packages installed on my Debian 8 machine # sudo dpkg -l | grep -i java ii ca-certificates-java 20140324 all Common CA ...
13
votes
3answers
2k views

What's going to be new in bash 5

I was just going through the official bash repository(I don't usually do this) for something unrelated but noticed that bash 5 was already in beta. I was just curious about what's going to be new in ...
0
votes
0answers
91 views

Unable to boot from kernel 4.18.16-200.fc28.x86_64

I updated the kernel last Thursday to version 4.18.16-200.fc28.x86_64. Now every time I booted from that kernel it just always get stuck on an empty black screen with blinking cursor. I've tried ...
-1
votes
1answer
230 views

Error sh: 0: getcwd() failed: No such file or directory when I try to upgrade Debian

Error when i try to upgrade Debian based distro After this operation, 347 MB of additional disk space will be used. Do you want to continue? [Y/n] y sh: 0: getcwd() failed: No such file or directory ...
1
vote
1answer
54 views

Overriding apt-get security check in Debian 9 (stretch) for Cloudera upgrade

I am trying to update Cloudera packages on several servers that have recently been upgraded to Debian 9 (stretch). The latest updates for Cloudera were for Debian 8 (jessie). The update/upgrade fails ...
1
vote
1answer
62 views

After an AIX mksysb NIM migration upgrade, virtual package AIX-rpm is out-of-sync with the OS level

After upgrading an AIX system using mksysb migration via NIM, the AIX-rpm virtual package was left behind at the previous AIX level: $ oslevel -r 7100-04 $ rpm -q AIX-rpm AIX-rpm-6.1.7.0-7 This ...
0
votes
1answer
110 views

GPGME error on Arch Linux 32bit

I need to fix this issue with GPGME error. I cannot upgrade or install anything. This is what I get in terminal: sudo pacman -Syyu error: GPGME error: No data error: GPGME error: No data error: GPGME ...
0
votes
2answers
98 views

Have /bin/bash not /usr/bin/bash but Cant install RPM Update because of Failed Dependency

Linux system with bash located in /bin and not /usr/bin. Attempting to install (as root) glibc-common-2.17-222.el7.x86_64 using either of the following commands: rpm -ivh glibc-2.17-222.el7.x86_64....
-2
votes
1answer
133 views

I can't upgrade Linux Mint — unmet dependencies

I installed Linux Mint 19 “Tara” Cinnamon, and when I want to upgrade or sudo apt-get dist-upgrade, there is some bug: The following packages have unmet dependencies: indicator-sensors:i386 : ...
2
votes
3answers
95 views

Can a server SSH key change due to software upgrades?

I have a VPS in the cloud (Ubuntu server 16.04) I SSH to the server (no problem there) I update the software: apt upgrade+apt update I reboot the server: shutdown -r now. SSH connection is closed ...
0
votes
1answer
16 views

TCB Enabled During Upgrade

I'm pretty sure I know the answer to this, but I wouldn't be doing my due diligence if I didn't ask: I know that you can only enable TCB in AIX during install, but what about during an upgrade? Can ...
0
votes
1answer
238 views

Update Vim in RHEL to version 7.4.2009

I am trying to write a Go server on a RHEL 7 system, but the Vim plugin, vim-go, requires version 7.4.2009, where the system only has 7.4.1099. I have tried yum install vim and it already has the ...
0
votes
0answers
18 views

Synaptic doesn't find updates

Pretty easy to describe problem: Synaptic one day stopped receiving updates, clicking "mark all updates" marks nothing. sudo apt-get update && sudo apt-get upgrade works without problems, but ...
13
votes
1answer
618 views

apt package manager on Debian lists a package as upgradable but does not upgrade

This issue is similar to Debian Linux not updating package, but in my case the newer package is not from backports: § apt list --upgradable Listing... Done firefox-esr-l10n-en-gb/stable 60.2.0esr-1~...
1
vote
0answers
30 views

what is inside weak-update folder?

First, installed a driver package to OS (ex: CentOS ) -- foo_1.0.rpm Second, install the same driver but different version -- foo_2.0.rpm by rpm -ivh --force foo_2.0.rpm It seems an extra folder ...
0
votes
0answers
21 views

Kali OS Update turns GRUB into a Terminal [duplicate]

A little while ago, I installed Kali Linux 2018.2 on my laptop via USB. I had to do some tweaking to fit my needs, but overall it worked fine. However, recently I got a notification from the Software ...
2
votes
1answer
51 views

e2fsprogs issues on Debian testing - unable to upgrade packages

After trying to do a regular update on Debian Buster, I ended up with the following issue. The following package was automatically installed and is no longer required: libraw16 Use 'apt autoremove' ...
1
vote
1answer
201 views

How to deal with undocumented Arch Linux update failures?

I've been using Arch for about 3-4 months now and I've never actually had to deal with an upgrade error. Yesterday when I ran sudo pacman -Syu I got :: Starting full system upgrade... resolving ...
-1
votes
1answer
71 views

I am having problems running updates and downloading software in terminal

Everytime I try and update my software this is what is says... mint@mint ~ $ apt-get update Reading package lists... Done W: chmod 0700 of directory /var/lib/apt/lists/partial failed - ...
0
votes
1answer
1k views

Debian: Why my debian_version is “buster/sid” after upgrading from stretch to testing [duplicate]

I installed a Debian stable from ISO. /etc/debian_version was "9.5". Then I changed apt from "stretch" to "testing" and upgraded. Now debian_version is "buster/sid"!? I thought sid is always "...
1
vote
1answer
105 views

How to access the “Software Update Preferences” GUI on a RHEL 7 server?

I have numerous RHEL 6 servers and we configure automatic updates using the "Software Update Preferences" GUI, however I cannot locate the same GUI on a newer RHEL 7 server. This is the GUI that I am ...
4
votes
1answer
501 views

Problem with appstreamcli when running apt update

I had a problem with debian testing today when I was running an apt update with following return: E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-...
0
votes
1answer
137 views

Unmet dependencies due to slightly too new package installed

When I tried to apt-get upgrade (yes, I did an update first), I get the following: Reading package lists... Done Building dependency tree Reading state information... Done You might want to ...