Questions tagged [uefi]

Questions about the Unified Extensible Firmware Interface (UEFI), the software interface aiming to replace typical BIOSes. This tag may also be used for questions related to UEFI partitions and systems.

Filter by
Sorted by
Tagged with
-1
votes
1answer
556 views

Debian 9 and UEFI

I have installed Debian Stretch (9.6) on UEFI-based platform Everything went fine, but I cannot... boot to the system. After the GRUB2 starts the image all I get is: Loading Linux 4.9.0-8-amd64 ...
1
vote
1answer
410 views

GRUB does not load in Windows10+Linux with UEFI

I have a new computer that comes with UEFI but I'm unable to use Windows 10 and Linux in dual boot, after installation of Linux+GRUB and reboot it loads Windows without showing GRUB, notice that first ...
1
vote
1answer
601 views

Can't boot on Win10 with dual-boot Fedora 29 + Win10 (both encrypted partitions)

Did install Fedora 29 on a different partition than Win10, usual dual boot configuration that I already used a good number of times. The new parameter is that I use encryption on Windows system (...
1
vote
1answer
71 views

Multiple Linux Installation - managing shared ESP and Bootable options

I have installed Manjaro alongside BlackArch. BlackArch has its bootloader in /boot which is a separate partition. Manjaro has three partitions, one for root(/), one for /boot, and one for /boot/efi. ...
3
votes
1answer
76 views

Dual boot ignores EFI devices

My pc does not boot anymore in EFI/UEFI mode. I had grub installed and was able to boot on both Windows 10 and Ubuntu Linux (14.04 LTS). I recently tried to install Fedora Workstation 29 '...
0
votes
0answers
272 views

boot/grub/efi.img invalid image size

I am attempting to create a custom Ubuntu 16.04 LTS Server installation media and have been following the instruction here https://help.ubuntu.com/community/InstallCDCustomization When I attempt to ...
0
votes
1answer
241 views

grub2 no such device (Win10 / Fedora)

I have Win10 installed on a nvme drive. I have installed Fedora 29 on another ssd with LVM. When grub boots, it shows Fedora & Windows 10 on the list, as it should. But starting with Windows ...
2
votes
0answers
473 views

Deepin Installer won't start - stuck on black screen with single dash

I have just bought an Asus Zenbook UX433FA, on which I want to install Deepin 15.8 as my only OS. I have followed the installation guide on the Deepin website, therefore creating a bootable USB device ...
3
votes
1answer
55 views

Clone Debian installation

I want to clone an existing Debian installation and restore on a new machine with a hard drive of different size. The partioning is very easy - /dev/sda1 for EFI, /dev/sda2 for Linux and /dev/sda3 ...
0
votes
2answers
850 views

No boot option after Linux Mint installation (dual boot)

I recently installed Linux Mint 19 onto my Dell XPS 15 laptop with Windows 10 pre-installed. The initial install of Mint seemed to go fine. I booted off of a live USB and installed Mint onto a ...
-1
votes
1answer
97 views

How can I mount a partition before the OS has booted?

In the instructions for configuring an EFI system partition in Arch Linux, it reads as follows: mount ESP to /boot. This is the preferred method when directly booting a EFISTUB kernel from UEFI. ...
3
votes
0answers
140 views

FreeBSD 11.2: how to resize the boot options menu on a UEFI/GPT/ZFS machine?

Is there a way to resize the boot options menu in Freebsd 11.2 on a UEFI/GPT/ZFS machine (zfs-on-root)? On multiple machines, the installation resulted in the boot options menu being rendered in a ...
0
votes
0answers
108 views

UEFI Stub booting not working

I am trying to boot Arch Linux via an EFI Stub. I created an EFI partition (formatted as FAT32), a swap partition and a main partition on which I installed the Arch Linux core package group. I then ...
0
votes
1answer
37 views

Swapping hard drives results in being unable to boot

I have a laptop that I installed Arch on, so far so good. After getting things set up just the way I wanted them and using it for a few days, I decided to experiment a little and install SteamOS. ...
0
votes
1answer
706 views

What is causing my EFI partition to become corrupt when booting CentOS after installation?

I am attempting to install the latest CentOS 7.5 x64 on small form factor PC ASUS Eee Box EB1037. It is an Intel Celeron J1900 (Bay Trail) with an onboard NVIDIA GeForce GT 820M. The installtion media ...
0
votes
2answers
1k views

Can't install Fedora 29 on Thinkpad W550s due to GPT

I have a Lenovo Thinkpad W550s that already has Windows 7 on it. I would like to install Fedora 29 Workstation alongside Windows 7, but I have run into some problems. The hard drive was formatted ...
5
votes
3answers
2k views

GPU passthrough works with UEFI firmware but not Windows iso

I am trying to set up a virtual machine with passthrough graphics. I am able to get the passthrough working for the UEFI shell, but not the official Windows installer. I can get the Windows installer ...
0
votes
1answer
162 views

Accessing UEFI hardware info from Linux

I want to get info about hardware through UEFI. I know, I can get the efi variables and make dump using fwts tool in Linux. Also, I know about "device" command for EFI shell, which will show me all ...
0
votes
1answer
18 views

Two separate disks, no grub displayed but boots straight to Windows

I have a laptop that contains two SSD disks. Legacy mode is completely disabled in BIOS, so I'm most likely using UEFI only. The bigger disk was used to install a fresh copy of Windows. I then used ...
0
votes
2answers
943 views

GRUB disappeared from Boot Menu after UEFI (BIOS) upgrade on Thinkpad X1 Carbon gen5

I have dual boot system with Windows 10 and Arch linux (with grub) installed on Thinkpad X1 Carbon gen5. I've updated BIOS from version 1.22 to 1.34. Before Update I had several options in Boot Menu ...
0
votes
1answer
415 views

How to install Ubuntu on ASUS F556U, JournalError error? [closed]

I'm trying to install Ubuntu 18.04 on my ASUS F556U laptop without success. I already asked other questions on the subject, thinking that the problems were by UEFI mode. Well surpassed that, I already ...
0
votes
2answers
2k views

Debian UEFI Boot with DELL Latitude 7490 “No bootable devices found”

I have tried to install Debian 9.5 on a DELL Latitude 7490 with UEFI, but when I try to boot the machine I get the infamous "No bootable devices found". EFI partition has been created, and I can see ...
3
votes
1answer
7k views

Timed out waiting for device dev-disk-by\x2duuid-C829\x2dC4C1.device

I had formatted efi partition and installed windows again. I have dual boot Windows and Linux, then I installed the grub bootloader again from a live usb using these commands: mount /dev/sda* /mnt ...
-1
votes
2answers
1k views

new kali installation (EFI), I can't start on kali OS without the “super grub 2” usb key

I got a new computer. This computer works before with a multi boot (ubuntu OS, kali OS and windows OS). I wanted to erase all datas for install only a Kali linux OS (no multi boot, just only Kali). ...
0
votes
2answers
280 views

UEFI cannot boot Debian install on external USB without nvram entry

I have installed Debian Stretch onto an external USB drive that I plan to use as a portable installation that I can use on multiple computers, so I need to be able to boot it from the USB directly ...
0
votes
1answer
178 views

Change UEFI boot order from busybox

After generate a new efi boot entry with efibootmgr: # efibootmgr -c -g -L "Debian (EFI stub)" -l '\EFI\debian\vmlinuz' -u "root=UUID=955548bd-9c77-4893-8633-3a5e7966dfc9 ro quiet rootfstype=ext4 ...
1
vote
0answers
259 views

GRUB Change EFI to BIOS legacy boot mode

I need to change the boot mode of an UNIX system from EFI to BIOS. This system (Fedora Atomic Host) uses GRUB as a default bootloader. I need to change the bootloader to BIOS, because I want to ...
1
vote
0answers
908 views

Solus OS broken boot

I had a perfectly fine and running Solus OS installation on a 100gb of 1tb hard drive. When I created a partition on the remaining 900gb, boot just vanished. I tried all the things from the internet, ...
1
vote
1answer
172 views

Shim only works in non-Secure Boot mode

I'm trying to get my dual boot (Arch+Win10) to work with Secure Boot. I followed the Arch Wiki, with the following steps. sudo mount /dev/sda1 /boot/efi sudo mv /boot/efi/EFI/Boot/bootx64.efi /boot/...
-1
votes
1answer
1k views

Manjaro: SSD not recognized in BIOS after installation

I've installed Manjaro 17.11.1 on my ASUS UX31A. Before there was ElementaryOS running on it without a problem. When I startup the system after installation the laptop enters BIOS directly. There's ...
0
votes
0answers
28 views

How to get Linux install on USB to show in Mac Startup Manager?

I started off by installing the full version Kali Linux on a USB drive. I went through the graphical installer and repartitioned the USB with /home and swap partitions so this isn't a Live USB, just ...
0
votes
1answer
552 views

Dual boot Windows and Linux on separate HDDs - error: no such device

I followed online tutorials to install Windows 10 alongside Linux (Arch) on separate HDDs. This involved physically disconnecting each HDD while installing the OS on the other. The only thread I ...
0
votes
2answers
162 views

Can I trust initramfs and vmlinuz images?

I am running an Arch Linux installation on my laptop with the following partition scheme: /dev/sda1 is my /boot partition, which is also my ESP /dev/sda2 is my LUKS encrypted root partition I use ...
1
vote
1answer
490 views

Convert a Ubuntu BIOS install to EFI/UEFI in USB stick

I have a linux installation (full installation not live) in a USB stick. When I set it up it uses BIOS to boot but now I need to change it to UEFI because some newer machines only boot in UEFI. I ...
0
votes
1answer
97 views

Bootable NixOS ISOs not working (18.03.132847)

After following the NixOS' Installation Guide, I'm failing to create a bootable Installation ISO. I created an issue for this on NixOS/nixpkgs. But I wanted to see if there was any knowledge here. ...
0
votes
1answer
353 views

How to install GRUB with dualboot in Legacy mode?

I have a problem with my laptop, I have Windows 10 and Parrot Home OS (a Debian based OS) in other partition, yesterday when I installed Parrot, the installer noticed me that the only thing that ...
1
vote
1answer
408 views

Build Archiso with proper UEFI SecureBoot signing

I'm building an Archiso live USB. My goal is to make it SecureBoot compatible (users with SecureBoot enabled should be able to boot it). It seems like this has been asked before (How to boot Arch ...
2
votes
1answer
1k views

systemd-boot skips boot menu and ignores settings in /loader/loader.conf

Recently, after I've done something to my multiboot system, when I boot NixOS with systemd-boot, boot menu does not show up anymore even though the timeout is still set to 2 seconds in /loader/loader....
0
votes
1answer
97 views

Two drives with their own ESP

I'm having a problem about how I boot to Linux. I tried and successfully boot if there is only one drive and one ESP. but my goal is to have two different drives with their own ESP. the first drive ...
1
vote
0answers
494 views

How can I get Linux fully installed and operational on 32 bit U/EFI & 64 bit Atom (baytrail) tablet?

How can I get Linux fully installed and operational on a 2 in 1 Trio Windows 10.1 OD Tablet? ( http://www.triotablets.us/tablets/windows-tablets/pro-book-10-1/ ) It utilizes a 32 bit U/EFI and a ...
0
votes
2answers
296 views

EFI can't to boot Linux

I have bought a HP Probook x360 11 G1 EE laptop with an EFI boot and Windows preinstalled. The first problem is that there's no option in the bios to support legacy boot, so I can't do without EFI. ...
0
votes
2answers
1k views

How can I get an ESXi installation to PXE boot using UEFI?

I would like to PXE boot some ESXi hosts using UEFI, but keep getting the following message: I am testing with a VM and can see it hitting the DHCP/TFTP server (CentOS 7) in a packet capture (3 ...
1
vote
0answers
830 views

Linux Mint 19 Tara - can only install without EFI [duplicate]

For the past week I've been trying to create a dual boot with Windows 10 and Linux Mint 19 Tara. The base setup, as intended is supposed to be a simple 1 operating system per SSD: /dev/sda (250GB ...
0
votes
0answers
67 views

Grub and Nvidia driver behaving differently when Dell non-UEFI (legacy) boot is enabled

The main hard disk of my Dell Precision 3620 is partitioned with a GPT and Ubuntu is installed and boots (via grub2) in UEFI mode. For months now, I have been struggling to get the Nvidia driver for ...
2
votes
3answers
9k views

Fresh Ubuntu 18.04 LTS Installation will only boot into grub mode

I have installed Ubuntu 18.04 LTS (minimal setup with default partitioning and security encryption) on a laptop with a 120 GB SSD drive. When I try to boot, it will only load into command line grub ...
1
vote
1answer
268 views

Problem with instaling GRUB/LILO in dual boot with windows 10 UEFI/GPT

I am having some issues when trying to install Debian 9 alongside Windows 10. Everything goes smoothly until the GRUB installation comes up. After I pick the partition it starts to install and after ...
2
votes
0answers
205 views

Arch Linux (k4.17) boot failure on Baytrail

I recently installed Arch Linux on one of the cheap windows tablet. I chose arch linux, because it had latest kernel, and in kernel 4.12 the rtl8723bs wifi driver was mainlined. I was surprised how ...
3
votes
2answers
2k views

grub2 using wrong /boot partition

I recently installed Ubuntu 18.04 from a USB. I did everything the same way I'd done when upgrading from 14 to 16, and 16 to 17, and it worked every time until now. I selected "erase ubuntu 17 and ...
2
votes
2answers
42 views

No bootable device error after restoring debian image to annother ssd disk

I created an image of debian 7 on an SSD disk and later restored it on another computer with excatly same type of HW. however I'm getting the error message: No bootable device -- insert boot disk and ...
0
votes
1answer
103 views

My (slightly) customised Slax 9.4 distro doesn't load properly

Even though I have USB Storage set as the default boot item in my Surface UEFI, I cannot seem to boot from my USB. I have tried swiping left on the USB Storage option to immediately boot, but that ...